27.02.2017 14:58
rollan
 
Приветствую, форумчане!
Есть касса Wincor Nixdorf Beetle M, ОС стоит Windows XP SP3.
ОЗУ 256 Мб, жесткий диск 80Гб IDE.
Работает на Frontol, переходим на фронт-офис на 1С РМК.
Новая РМК работает на конфигурации 1С 8.3 которая не поддерживает Windows XP, для нее требуется Windows 7.
Windows 7 соответственно требует минимум 1Гб физической памяти.
Требовалось увеличить ОЗУ. Купили на алиэкспресс ОЗУ 512MB PC133 133MHz SDRAM 168pin DIMM - 12 штук.
Все пришло, ОЗУ в хорошем состоянии. Поставил оперативки на мать, запускаю, а он пищит и не запускается, экран черный.
Запускаю на своей родной 256 Мб, запускается нормально.
Запускаю попарно в одном слоте новая ОЗУ 512 Мб, во втором слоте старая 256 Мб, касса запускается, но видит только старую ОЗУ на 256 Мб.
Через AIDA64 проверил все характеристики ОЗУ, через нее новую ОЗУ на 512Мб видит и читает все параметры. Разница между новой и старой в поддержке ECC.

Информация из интернета:
Поддержка ECC
Поддержка Error Checking and Correction - алгоритма, позволяющего не только выявлять, но и исправлять случайные ошибки (не более одного бита в байте), возникающие в процессе передачи данных. Технологию ECC поддерживают некоторые материнские платы для рабочих станций и практически все серверные. Модули памяти с ECC имеют более высокую стоимость, чем не поддерживающие этот алгоритм.

Теперь стал вопрос:
1) Моя касса не видит ОЗУ из-за технологии ECC? т.к. в нете пишут что ее поддерживают только некоторые материнские платы.

2) на офф.сайте Wincor Nixdorf пишут что мать поддерживает SDRAM 64 – 512 MB. Это суммарное кол-во или одну плату с такой памятью?

Прошу подсказать как быть теперь! кто сталкивался с такой задачей???

во вложении скрины параметров кассы через AIDA64
Вложения
Тип файла: rar 123.rar (1022.1 Кб, 31 просмотров)
27.02.2017 15:23
bob
 
на 99 процентов да. из-за ECC. мы ставили несколько планок в сумме на 1 гиг на такие аппараты.
27.02.2017 16:28
~Guest~
 
Не все матери одинаково полезны, необходимо было запросить список планок поддерживаемых у производителя, в Винкоре.
Тут не только с ECC связано, но в том числе и могут быть различия по питанию, опять же, на уровне БИОС, в частности для моего ноута, вроде не самого старого, есть определенный список ОЗУ в поддержке, пробовал сам тестить и ставить любые до 8 Гб, нет, нет и еще раз нет.

Так же и с нашими системниками, есть рекомендованный диапазон:
- по частоте
- по объему
- а так же жесткое указание по питанию.
27.02.2017 16:36
KirillHome
 
Цитата:
bob на 99 процентов да. из-за ECC. мы ставили несколько планок в сумме на 1 гиг на такие аппараты.
Поддержу.
Память с поддержкой ECC мне лично ни разу не удалось "подружить" с несерверной материнской платой.
27.02.2017 20:39
bob
 
Цитата:
~Guest~ Не все матери одинаково полезны, необходимо было запросить список планок поддерживаемых у производителя, в Винкоре.
Тут не только с ECC связано, но в том числе и могут быть различия по питанию, опять же, на уровне БИОС, в частности для моего ноута, вроде не самого старого, есть определенный список ОЗУ в поддержке, пробовал сам тестить и ставить любые до 8 Гб, нет, нет и еще раз нет.

Так же и с нашими системниками, есть рекомендованный диапазон:
- по частоте
- по объему
- а так же жесткое указание по питанию.
Мы взяли первую попавшуюся под руку. завелось все.
27.02.2017 21:46
~Guest~
 
Цитата:
bob Мы взяли первую попавшуюся под руку. завелось все.

Ну у Вас как в анекдоте: "Ну что я могу сказать, повезло" (с).

Можно так же к моему ноуту, первую попавшуюся воткнете, а она заработает? Потому что тех поддержка Асуса не так позитивно настроена, а дает конкретные рекомендации:
"Спасибо за обращение в службу технической поддержки ASUS.

Планки памяти часто не подходят. Их нужно подбирать или ставить в условияхсервисного центра. Если память не подошла, "что-нибудь сделать" невозможно. И в частности, Kingston KVR серии часто не подходит. Вы могли заранее это узнать.

Протестированные модули памяти:
DDR3L 1600 SO-DIMM 2GB 204P HYNIX/HMT425S6AFR6A-PB
DDR3L 1600 SO-DIMM 2GB 204P HYNIX/HMT325S6CFR8A-PB
DDR3L 1600 SO-DIMM 4GB 204P HYNIX/HMT451S6AFR8A-PB
DDR3L 1600 SO-DIMM 4GB 204P KINGSTON/ASU16D3LS1KFG/4G
DDR3L 1600 SO-DIMM 8GB 204P SAMSUNG/M471B1G73QH0-YK0
Подходят и другие модули. Но любые модули нужно тестировать перез покупкой
или договариваться о возможности возврата.
"

И ведь я им не поверил при первом ответе :) Взял две плашки 8Гб (разные по частоте и питанию), и ничего, как не видит их, так и не видит. Вот жду Самсунговскую, один в один как указали.
27.02.2017 21:59
nik_ll
 
Win7 нужен как минимум 1gb, а сколько еще нужно 1с 8.3? Мне одному кажется, что такой эксперимент бесчеловечен?
27.02.2017 22:34
baggio
 
Цитата:
nik_ll Win7 нужен как минимум 1gb, а сколько еще нужно 1с 8.3? Мне одному кажется, что такой эксперимент бесчеловечен?
+1
27.02.2017 22:50
KirillHome
 
Цитата:
rollan Приветствую, форумчане!
....Новая РМК работает на конфигурации 1С 8.3 которая не поддерживает Windows XP, для нее требуется Windows 7.
....
Вообще, 1с 8.3 работает и на Windows XP

И, для памяти, требования к компьютерам от 1с
Цитата:
Толстый клиент:
Системные требования
Процессор Intel Pentium Celeron 2400 Мгц и выше
Оперативная память 1024 Мб и выше
Жесткий диск 40Гб и выше
Устройство чтения компакт-дисков
USB-порт
SVGA-видеокарта

Тонкий клиент:
Системные требования
Процессор Intel Pentium Celeron 1800 Мгц и выше
Оперативная память 256 Мб и выше
Жесткий диск 40Гб и выше
Устройство чтения компакт-дисков
USB-порт
SVGA-видеокарта

Веб-клиент:
Системные требования
Процессор Intel Pentium Celeron 1800 Мгц и выше
Оперативная память 256 Мб и выше
Жесткий диск 40Гб и выше
Устройство чтения компакт-дисков
SVGA-видеокарта
Хотя зачем им Устройство чтения компакт-дисков - не очень понимаю

Ну, и ссылка требований по операционкам
27.02.2017 23:07
KirillHome
 
Я не в курсе, какие требования у неназванного РМК, но, к примеру, в типовой БП 3.0 (на платформе 1с 8.3) при запуске в файловом режиме одно время были рекомендации по увеличению ОЗУ до 4Гб (сейчас, если не ошибаюсь - до 2Гб).
Да, сейчас 2Гб

Вот здесь определяется
Код:
// Возвращает общие параметры базовой функциональности.
//
// Возвращаемое значение: 
//  Структура - структура со свойствами:
//      * ИмяФормыПерсональныхНастроек            - Строка - имя формы для редактирования персональных настроек.
//                                                           Ранее определялись в
//                                                           ОбщегоНазначенияПереопределяемый.ИмяФормыПерсональныхНастроек.
//      * МинимальноНеобходимаяВерсияПлатформы    - Строка - полный номер версии платформы для запуска программы.
//                                                           Например, "8.3.4.365".
//                                                           Ранее определялись в
//                                                           ОбщегоНазначенияПереопределяемый.ПолучитьМинимальноНеобходимуюВерсиюПлатформы.
//      * РаботаВПрограммеЗапрещена               - Булево - Начальное значение Ложь.
//      * ЗапрашиватьПодтверждениеПриЗавершенииПрограммы - Булево - по умолчанию Истина. Если установить Ложь, то 
//                                                                  подтверждение при завершении работы программы не
//                                                                  будет запрашиваться,  если явно не разрешить в
//                                                                  персональных настройках программы.
//      * ОтключитьИдентификаторыОбъектовМетаданных - Булево - отключает заполнение справочников ИдентификаторыОбъектовМетаданных
//              и ИдентификаторыОбъектовРасширений, процедуру выгрузки и загрузки в узлах РИБ.
//              Для частичного встраивания отдельных функций библиотеки в конфигурации без постановки на поддержку.
//
Функция ОбщиеПараметрыБазовойФункциональности() Экспорт
	
	ОбщиеПараметры = Новый Структура;
	ОбщиеПараметры.Вставить("ИмяФормыПерсональныхНастроек", "");
	ОбщиеПараметры.Вставить("МинимальноНеобходимаяВерсияПлатформы", "8.3.6.2041");
	ОбщиеПараметры.Вставить("РаботаВПрограммеЗапрещена", Ложь); // Блокировать запуск, если версия ниже минимальной.
	ОбщиеПараметры.Вставить("ЗапрашиватьПодтверждениеПриЗавершенииПрограммы", Истина);
	ОбщиеПараметры.Вставить("ОтключитьИдентификаторыОбъектовМетаданных", Ложь);
	ОбщиеПараметры.Вставить("РекомендуемыйОбъемОперативнойПамяти", 2);
	
	ОбщегоНазначенияПереопределяемый.ПриОпределенииОбщихПараметровБазовойФункциональности(ОбщиеПараметры);
	
	Возврат ОбщиеПараметры;
	
КонецФункции
Вот здесь проверяется
Код:
&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	Отказ = Истина;
	
	СистемнаяИнформация = Новый СистемнаяИнформация;
	ДоступныйОбъем = Окр(СистемнаяИнформация.ОперативнаяПамять / 1024, 1);
	
	Если ДоступныйОбъем >= РекомендуемыйОбъем Тогда
		Возврат;
	КонецЕсли;
	
	ТекстСообщения = НСтр("ru = 'На компьютере установлено %1 Гб оперативной памяти.
		|Для того чтобы программа работала быстрее, 
		|рекомендуется увеличить объем памяти до %2 Гб.'");
	
	ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекстСообщения, ДоступныйОбъем, РекомендуемыйОбъем);
	
	ЗаголовокСообщения = НСтр("ru = 'Рекомендация по повышению скорости работы'");
	
	ПараметрыВопроса = СтандартныеПодсистемыКлиент.ПараметрыВопросаПользователю();
	ПараметрыВопроса.Заголовок = ЗаголовокСообщения;
	ПараметрыВопроса.Картинка = БиблиотекаКартинок.Предупреждение32;
	ПараметрыВопроса.Вставить("ТекстФлажка", НСтр("ru = 'Не показывать в течение двух месяцев'"));
	
	Кнопки = Новый СписокЗначений;
	Кнопки.Добавить("ПродолжитьРаботу", НСтр("ru = 'Продолжить работу'"));
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ПослеПоказаРекомендации", ЭтотОбъект);
	СтандартныеПодсистемыКлиент.ПоказатьВопросПользователю(ОписаниеОповещения, ТекстСообщения, Кнопки, ПараметрыВопроса);
	
КонецПроцедуры

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.