Форум OlegON > > >

1.033.4 сп1 - перестал работать ЕГАИС. шестнадцатеричное значение 0x06, является недопустимым знаком., строка 1, позиция 1

11.12.2019 13:45


21.04.2017 20:14
Starter
 
На одной базе после обновления перестали отправляться пакеты в ЕГАИС.
УТМ работаает (сторонними сервисами все отсылается, чеки уходят).
А вот СМ не хочет отправлять -

В логах:
2017.04.21 (пятница) 20:13:22 1.33.4.0 sp1 Sm.Post.Server
----- Прерывание работы программы -----
сообщение: "Ошибка отсылки транспортом пакета «X:\SM_TRANSPORT\EGAIS\OUT\170421201148_7806_1.SVP»"
исключение: Sm.Core.BaseException
источник: Sm.Post.Server
метод: Void SendPackages()
в Sm.Post.Server.TransportRunner.TransportThreadRunner.SendPackages()
----- Причина исключения, уровень вложения 1 -----
сообщение: """, шестнадцатеричное значение 0x06, является недопустимым знаком., строка 1, позиция 1."
исключение: System.Xml.XmlException
источник: System.Xml
данные:
исходящий почтовый ящик: EGAIS
исходящий пакет: 170421201148_7806_1.SVP
метод: Void Throw(System.Exception)
в System.Xml.XmlTextReaderImpl.Throw(Exception e)
в System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
в System.Xml.XmlTextReaderImpl.ThrowInvalidChar(Char[] data, Int32 length, Int32 invCharPos)
в System.Xml.XmlTextReaderImpl.ParseRootLevelWhitespace()
в System.Xml.XmlTextReaderImpl.ParseDocumentContent()
в System.Xml.XmlTextReaderImpl.Read()
в System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
в System.Xml.XmlDocument.Load(XmlReader reader)
в System.Xml.XmlDocument.Load(String filename)
в Sm.Post.Filters.Egais.EgaisXmlDocReader.DecodeHeader()
в Sm.Post.Filters.Egais.EgaisDecoder.GetEgaisObjectId(String packagePath, String& egaisObjectType, String& objectNumber)
в Sm.Post.Filters.Egais.EgaisTransport.PostPackageCore(String physicalPackage, ITaskBreaker breaker)
в Sm.Post.Transports.TransportBase.PostPackage(String physicalPackage, ITaskBreaker breaker)
в Sm.Post.Server.TransportRunner.TransportThreadRunner.SendPackages()
--------------------------------------------------------
2017.04.21 (пятница) 20:13:23 1.33.4.0 sp1 Sm.Post.Server
----- Прерывание работы программы -----
сообщение: "При транспортировке не отослан 1 пакет"
исключение: Sm.Core.BaseException
источник: Sm.Post.Server
метод: Void SendPackages()
в Sm.Post.Server.TransportRunner.TransportThreadRunner.SendPackages()
в Sm.Post.Server.TransportRunner.TransportThreadRunner.RunTransport()
21.04.2017 21:29
Stels
 
ой.
А я только обновляться хотел ...

А УТМ какой версии?
И операционка на сервере какая?
21.04.2017 21:40
Starter
 
УТМ:
version:2.0.4
changeSet:8b1605b3137e+
buildNumber:1005
Но УТМ как раз работает превосходно.
Операционка - 2008r2x64
И - такая ситуация только в одном магазине, т.е. это не повальное бедствие.
22.04.2017 16:24
baggio
 
да опять какойнить служебный символ...
24.04.2017 14:10
Starter
 
Из ответа ТП: Неверно настроены каталоги почтового модуля. Виртуальные пакеты выкладываются прямо в каталог исходящих сообщений.
Собственно, так оно и было. поменяли каталоги, отсылка пошла.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.