[ОТВЕТИТЬ]
Опции темы
29.09.2011 22:51  
Аникин
При инициализации базы вылетает ошибка следующего плана,

"
BEGIN AdminCore.InstallFunction(827,8,'SUPERMAG_FN_EDITCARDMATRIX','Изменение классификатора номенклатур товаров'); END;

*
ошибка в строке 1:
ORA-04068: существующее состояние пакетов было сброшено
ORA-04063: package body "SUPERMAG.CORE" имеет ошибки
ORA-06508: PL/SQL: Невозможно найти вызываемый программный блок
ORA-06512: на "SUPERMAG.ADMINCORE", line 161
ORA-06512: на "SUPERMAG.ADMINCORE", line 206
ORA-06512: на line 1
"

по совету, был возврат базы из дампа, после чего повторный процесс инициализации дал тот же результат...
Будьте добры, подскажите что делать ...
 
30.09.2011 07:36  
OlegON
что значит "возврат базы из дампа"? Рекомендую прочитать тему про инвалидные объекты и добиться, чтобы перед переинициализацией их не было ни одного. А заодно посмотреть, что в алерте (FAQ).
 
30.09.2011 08:11  
Mtirt
Версия Оракла?
Это новая база или обновление существующей?
Если обновление, с какой версии обновляетесь?
 
30.09.2011 09:17  
whitewizard
Я так понимаю (https://olegon.ru/showthread.php?t=966&page=15), что идёт обновление с 1.024.6 до 1.028.2 напрямую.
На форуме было написано, что такую процедуру надо делать в несколько этапов.
 
30.09.2011 09:20  
Mtirt
Да вроде не надо в несколько.
Должно обновляться напрямую.
Олег на днях обновлял с похожей версии.
 
30.09.2011 09:25  
OlegON
Цитата:
Сообщение от Mtirt
Олег на днях обновлял с похожей версии.
Нет-нет, я с 26.4 поднимал... А до 26.4 поднимался поэтапно. Но тогда она была последней... Может, 28 поднимает сразу, не знаю...
 
30.09.2011 09:26  
whitewizard
Не думаю. Там слишком много переходных моментов было.
 
30.09.2011 12:04  
Аникин
версия oracl'a 9i, обновление существующей, старая версия СМ 1.027.3

"Возврат базы из дампа" - импорт базы из дампа, извините не правильно выразился...
 
30.09.2011 12:05  
Аникин
обновил так базу на 7 серверах, все нормально было... а вот на восьмом уперся в эту стенку...
 
30.09.2011 12:06  
Mtirt
Хорошо. Давай сначала.
Сейчас у тебя есть база с версией 1.027.3. И ты её хочешь обновить до 1.028.2?
Проверил и перекомпилировал инвалиднные объекты, как по указанной Олегом ссылке?
 
 


Опции темы



Часовой пояс GMT +3, время: 08:49.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.