[ТЕМА ЗАКРЫТА]
05.07.2012 10:16
Kryukov
 
Подскажите что за ошибка... под пользователем oracle запускаю терминал в OpenSuse 12
выдаёт ошибку
ERROR: ld.so: object '/usr/lib/libInternalSymbols.so' from LD_PRELOAD cannot be preloaded: ignored.
05.07.2012 10:24
OlegON
 
после инсталляции Oracle RDBMS надо было запустить два скрипта от рута, ты это сделал? перед инсталляцией все пакеты поставил? ставил что-то мимо репозитариев, кроме Oracle?
Да, /usr/lib/libInternalSymbols.so существует? Инсталляция не ругалась, что ей чего-то не хватает? Ignore не делал? ORACLE_BASE и ORACLE_HOME в .bashrc или .bashprofile прописаны? Перегружался?
В общем, пиши подробнее...
05.07.2012 10:25
Kryukov
 
Цитата:
OlegON после инсталляции Oracle RDBMS надо было запустить два скрипта от рута, ты это сделал?
я еще не ставил оракл... только первый раз зашел под пользователем oracle
05.07.2012 10:33
OlegON
 
Цитата:
OlegON В общем, пиши подробнее...
с этого начнем... что за юзер, откуда взялся...
05.07.2012 10:38
Kryukov
 
Делал по инструкции запустил
rpm –ivh orarun.rpm взял отсюда

раньше все проходило без проблем
05.07.2012 11:41
Kryukov
 
пробую установить оракл:
Checking operating system requirements ...
Expected result: One of redhat-6,redhat-5,redhat-4,redhat-3,SuSE-11,SuSE-10,SuSE-9,asianux-3,asianux-2,asianux-1
Actual Result: asianux-ld.so: object '/usr/lib/libInternalSymbols.so' from LD_PRELOAD cannot be preloaded: ignored.
Check complete. The overall result of this check is: Failed <<<<
Problem: Oracle Database 10g is not certified on the current operating system.
Recommendation: Make sure you are installing the software on the correct platform.
=======================================================================

Checking operating system package requirements ...
Check complete. The overall result of this check is: Not executed <<<<
OUI-18001: The operating system 'Linux Version asianux-ld.so: object '/usr/lib/libInternalSymbols.so' from LD_PRELOAD cannot be preloaded: ignored.' is not supported.
Recommendation: Install the required packages before continuing with the installation.
=======================================================================

Checking kernel parameters
Check complete. The overall result of this check is: Not executed <<<<
OUI-18001: The operating system 'Linux Version asianux-ld.so: object '/usr/lib/libInternalSymbols.so' from LD_PRELOAD cannot be preloaded: ignored.' is not supported.
Recommendation: Perform operating system specific instructions to update the kernel parameters.
=======================================================================

Checking Recommended glibc version
Check complete. The overall result of this check is: Not executed <<<<
OUI-18001: The operating system 'Linux Version asianux-ld.so: object '/usr/lib/libInternalSymbols.so' from LD_PRELOAD cannot be preloaded: ignored.' is not supported.
Recommendation: You may actually have installed packages which have obsoleted these, in which case you can successfully continue with the install. If you have not, it is recommended that you do not continue. Refer to the readme to find out how to get the missing packages.
=======================================================================

Checking physical memory requirements ...
Expected result: 922MB
Actual Result: 48388MB
Check complete. The overall result of this check is: Passed
=======================================================================

Checking available swap space requirements ...
Expected result: 36291MB
Actual Result: 2053MB
Check complete. The overall result of this check is: Failed <<<<
Problem: The system does not have the required swap space.
Recommendation: Make more swap space available to perform the install.
=======================================================================

Checking the Components installed in Oracle Home
Check complete. The overall result of this check is: Passed
=======================================================================

Checking for Oracle Home incompatibilities ...
Actual Result: NEW_HOME
Check complete. The overall result of this check is: Failed <<<<
Problem: This software can only be installed into an existing Oracle Database 10g Oracle Home.
Recommendation: Choose an existing Oracle Database 10g Oracle Home for installing this software.
=======================================================================
05.07.2012 11:51
OlegON
 
ну вот... а то без полной ошибки и непонятно было...
05.07.2012 14:24
Kryukov
 
Я недогоняю что не так ? и как лечить
05.07.2012 14:55
OlegON
 
ты бы прочитал, что оно тебе пишет-то...
Цитата:
Kryukov Checking operating system package requirements ...
Check complete. The overall result of this check is: Not executed <<<<
OUI-18001: The operating system 'Linux Version asianux-ld.so: object '/usr/lib/libInternalSymbols.so' from LD_PRELOAD cannot be preloaded: ignored.' is not supported.
Recommendation: Install the required packages before continuing with the installation.
=======================================================================
05.07.2012 15:02
Kryukov
 
я понял что просит установить пакеты какие именно ... откуда скачать
05.07.2012 15:59
OlegON
 
попробуй эти поставить для начала... хуже не будет
05.07.2012 16:09
Kryukov
 
вот рарыл такое
AMD64 Server : libc.so.6 error
If you have installed old orarun on AMD64 server and getting libc.so.6 error,
while doing “su - oracle” then comment following lines in /etc/init.d/oracle and /
etc/profile.d/oracle.[c]sh
#test -d /lib/i686 && export LD_ASSUME_KERNEL=2.x.x
10. Installation Notes: EM64T Servers
Please make sure you have selected proper Oracle and SLES9 Software i.e
x86-64 based.
1. Follow all the steps above and make sure gcc-3.3.3 and gcc-c++ and libaio-
devel packages are installed.
2. If you are getting "dircolors: error while loading shared libraries: /
usr/lib/libInternalSymbols.so: cannot open shared object file: No such file or
directory..." or not able to login as user “oracle”
commenting the line “test -f /usr/lib/libInternalSymbols.so && export
LD_PRELOAD=/usr/lib/libInternalSymbols.so” or by changing
LD_PRELOAD into LD_PRELOAD_32 in /etc/profile.d/oracle.sh will help.
3. make sure glibc-devel-32bit-9-200407011229 is installed to avoid linking of
ins_sysman.mk error.
Here is a brief list of required packages (or later versions):
1. gcc-3.3.3-43
2. gcc-c++-3.3.3-43
3. glibc-2.3.3-98
4. glibc-devel-32bit-9-*
5. libaio-0.3.98-18
6. libaio-devel-0.3.98-18
7. make-3.80
8. openmotif-libs-2.2.2-519.1
05.07.2012 16:11
Kryukov
 
Осталось... хотя версию добавил
Checking operating system requirements ...
Expected result: One of redhat-6,redhat-5,redhat-4,redhat-3,SuSE-11,SuSE-10,SuSE-9,asianux-3,asianux-2,asianux-1
Actual Result: SuSE-12.1
Check complete. The overall result of this check is: Failed <<<<
Problem: Oracle Database 10g is not certified on the current operating system.
Recommendation: Make sure you are installing the software on the correct platform.
=======================================================================

Checking operating system package requirements ...
Check complete. The overall result of this check is: Not executed <<<<
OUI-18001: The operating system 'Linux Version SuSE-12.1' is not supported.
Recommendation: Install the required packages before continuing with the installation.
=======================================================================

Checking kernel parameters
Check complete. The overall result of this check is: Not executed <<<<
OUI-18001: The operating system 'Linux Version SuSE-12.1' is not supported.
Recommendation: Perform operating system specific instructions to update the kernel parameters.
=======================================================================

Checking Recommended glibc version
Check complete. The overall result of this check is: Not executed <<<<
OUI-18001: The operating system 'Linux Version SuSE-12.1' is not supported.
Recommendation: You may actually have installed packages which have obsoleted these, in which case you can successfully continue with the install. If you have not, it is recommended that you do not continue. Refer to the readme to find out how to get the missing packages.
=======================================================================

Checking physical memory requirements ...
Expected result: 922MB
Actual Result: 48388MB
Check complete. The overall result of this check is: Passed
=======================================================================

Checking available swap space requirements ...
Expected result: 36291MB
Actual Result: 2053MB
Check complete. The overall result of this check is: Failed <<<<
Problem: The system does not have the required swap space.
Recommendation: Make more swap space available to perform the install.
=======================================================================

Checking the Components installed in Oracle Home
Check complete. The overall result of this check is: Passed
=======================================================================

Checking for Oracle Home incompatibilities ...
Actual Result: NEW_HOME
Check complete. The overall result of this check is: Failed <<<<
Problem: This software can only be installed into an existing Oracle Database 10g Oracle Home.
Recommendation: Choose an existing Oracle Database 10g Oracle Home for installing this software.
=======================================================================
05.07.2012 16:14
OlegON
 
Пригляделся, ты же пакеты ставишь от 11 Suse, доку читаешь от 11 Suse, а стоит у тебя 12я...
05.07.2012 16:19
Kryukov
 
я понял что это оракл говорит что не может встать на suse12
05.07.2012 16:28
OlegON
 
Может и встанет, если правильные пакеты поставишь... Не знаю. Не пробовал.
Опции темы


Часовой пояс GMT +3, время: 21:02.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.