[ОТВЕТИТЬ]
29.10.2015 13:32
Tushkanchik
 
Вот я олух )) Спасибо ))
Хранилище
может кому пригодится
29.10.2015 14:13
KirillHome
 
Посмотрел на эту обработку.
Собственно, код такой
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 5 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
11.02.2016 23:39
Tushkanchik
 
Помогите скачать

Универсальная печать справочников для 1С 8.1,8.2
12.02.2016 00:11
Tushkanchik
 
Цитата:
Tushkanchik Помогите скачать

Универсальная печать справочников для 1С 8.1,8.2
А все не надо ))) Хранилище
Для 8,3 чтото похожее надо...
15.02.2016 18:31
Tigra_N
 
помогите, пожалуйста скачать с infostart по этим ссылкам:



21.04.2017 20:17
Tushkanchik
 
Может есть у кого такое ?

Универсальная обработка "Изменение записей регистров сведений и накопления"
21.04.2017 23:34
KirillHome
 
Цитата:
Tushkanchik Может есть у кого такое ?

Универсальная обработка "Изменение записей регистров сведений и накопления"
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 10 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
25.04.2017 23:37
Tushkanchik
 

Получение Алкокода из PDF417. Или может чтото аналогичное для УФ.
25.04.2017 23:52
MWWRuza
 
Цитата:
Tushkanchik Получение Алкокода из PDF417.
https://storage.olegon.ru/supermag/u...20-%202.epf.7z
19.12.2017 17:25
info975
 
Помогите пожалуйста скачать с Инфорстарта .
24.12.2017 18:41
MWWRuza
 
Вот:
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
10.01.2018 00:28
KirillHome
 
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 300 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
01.03.2018 14:38
Dim
 
KirillHome, у меня по предыдущему сообщению при переходе по ссылке -
Цитата:
Доступ ограничен
Доступ к запрашиваемому ресурсу ограничен по решению суда или по иным основаниям,
установленным законодательством Российской Федерации
может в хранилище переложить?
01.03.2018 15:11
Dim
 
вообще нужно
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.

в сборнике KirillHome он есть
01.03.2018 17:35
KirillHome
 
Цитата:
Dim вообще нужно
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.

в сборнике он есть
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
01.03.2018 20:55
Fomka
 
Честно покупал эту обработку за 5к, но очень душит 1.5к платить за то, чтобы скачать свежую версию :) Вдруг кто тоже себе брал и может поделиться, саму покупку для порядочности могу подтвердить)
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 5 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
01.03.2018 23:40
KirillHome
 
Fomka, там в комментариях есть несколько советов.
Не помогут?
02.03.2018 10:39
Fomka
 
KirillHome, я там вижу в комментах, что раньше обработка была за стартмани, а ща надо покупать заново) Хотя я и не за стартмани покупал, а за рубли.
02.03.2018 12:03
KirillHome
 
На будущее
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.


Там в комментариях есть и информация по коду. К примеру
Подсказка:

вот область регистрации на форме:
Код:
#Область РегистрацияИзОбработки
Функция НайтиДопОбработку(Наименование)
    Запрос = Новый Запрос(
    "ВЫБРАТЬ
    |    ДополнительныеОтчетыИОбработки.Ссылка
    |ИЗ
    |    Справочник.ДополнительныеОтчетыИОбработки КАК ДополнительныеОтчетыИОбработки
    |ГДЕ
    |    ДополнительныеОтчетыИОбработки.Наименование = &ИмяОбработки"
    );
    Запрос.УстановитьПараметр("ИмяОбработки", Наименование);
    Результат = Запрос.Выполнить().Выгрузить();
    Если Результат.Количество() = 0 Тогда
        Возврат Справочники.ДополнительныеОтчетыИОбработки.ПустаяСсылка();
    Иначе
        Возврат Результат[0].Ссылка;
    КонецЕсли;
КонецФункции

Функция ПолучитьСведенияОРегистрации() Экспорт
    ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
    ПараметрыРегистрации = ОбработкаОбъект.СведенияОВнешнейОбработке();
    ТабКоманд = ПараметрыРегистрации.Команды[0];
    Результат = НайтиДопОбработку(ПараметрыРегистрации.Наименование);
    Если Результат = Справочники.ДополнительныеОтчетыИОбработки.ПустаяСсылка() Тогда
        Зарегистрировано = Ложь;
        ВерсияИБ = "";
    Иначе
        Зарегистрировано = Истина;
        ВерсияИБ = Результат.Версия;
    КонецЕсли;
    Возврат Новый Структура("Зарегистрировано, Наименование, Представление, Версия, ВерсияИБ",
                             Зарегистрировано, ПараметрыРегистрации.Наименование, ТабКоманд.Представление, ПараметрыРегистрации.Версия, ВерсияИБ);
КонецФункции

Процедура ЗарегистрироватьНаСервере() Экспорт
    Если Не Константы.ИспользоватьДополнительныеОтчетыИОбработки.Получить() Тогда
        Константы.ИспользоватьДополнительныеОтчетыИОбработки.Установить(Истина);
    КонецЕсли;
    ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
    ПараметрыРегистрации = ОбработкаОбъект.СведенияОВнешнейОбработке();
    Результат = НайтиДопОбработку(ПараметрыРегистрации.Наименование);
    Если НЕ Результат = Справочники.ДополнительныеОтчетыИОбработки.ПустаяСсылка() Тогда
        НовОбъектСпрвочникаДопОбработкок = Результат.ПолучитьОбъект();
        БылаЗарегина = Истина;
    Иначе
        //В таком порядке получения объекта есть смысл -
        // в перем. НовОбъектСпрвочникаДопОбработкок так доступен список реквизитов через точку :-)
        НовОбъектСпрвочникаДопОбработкок = Справочники.ДополнительныеОтчетыИОбработки.СоздатьЭлемент();
        БылаЗарегина = Ложь;
    КонецЕсли;
    ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
    ИспользуемоеИмяФайла = ОбработкаОбъект.ИмяФайлаОбработки();
    НовОбъектСпрвочникаДопОбработкок.БезопасныйРежим = ПараметрыРегистрации.БезопасныйРежим;
    НовОбъектСпрвочникаДопОбработкок.Версия = ПараметрыРегистрации.Версия;
    НовОбъектСпрвочникаДопОбработкок.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительнаяОбработка;
    КомандыРегистрации = ПараметрыРегистрации.Команды[0];
    НовОбъектСпрвочникаДопОбработкок.ИмяОбъекта = КомандыРегистрации.Идентификатор;
    НовОбъектСпрвочникаДопОбработкок.ИмяФайла = ИспользуемоеИмяФайла;
    НовОбъектСпрвочникаДопОбработкок.Информация = ПараметрыРегистрации.Информация;
    Если НовОбъектСпрвочникаДопОбработкок.Команды.Количество() Тогда
        НовОбъектСпрвочникаДопОбработкок.Команды.Очистить(); //Команды стоит заменить, мало ли чего в новой версии поменялось
    КонецЕсли;
    НовСтрКоманды = НовОбъектСпрвочникаДопОбработкок.Команды.Добавить();
    НовСтрКоманды.ВариантЗапуска = Перечисления.СпособыВызоваДополнительныхОбработок.ОткрытиеФормы;
    НовСтрКоманды.Идентификатор = КомандыРегистрации.Идентификатор;
    НовСтрКоманды.Модификатор = КомандыРегистрации.Модификатор;
    НовСтрКоманды.ПоказыватьОповещение = КомандыРегистрации.ПоказыватьОповещение;
    НовСтрКоманды.Представление = КомандыРегистрации.Представление;
    НовОбъектСпрвочникаДопОбработкок.Комментарий = "#Зарегистрирована из самой обработки";
    НовОбъектСпрвочникаДопОбработкок.Наименование = ПараметрыРегистрации.Наименование;
    НовОбъектСпрвочникаДопОбработкок.Ответственный = Пользователи.ТекущийПользователь();
    НовОбъектСпрвочникаДопОбработкок.Публикация = Перечисления.ВариантыПубликацииДополнительныхОтчетовИОбработок.Используется;
    Если Не БылаЗарегина Тогда //Разделы уже есть, не трогаем
        Раздел = НовОбъектСпрвочникаДопОбработкок.Разделы.Добавить();
        Раздел.Раздел = Справочники.ИдентификаторыОбъектовМетаданных.НайтиПоРеквизиту("ПолноеИмя", "Подсистема.Продажи");
        Раздел = НовОбъектСпрвочникаДопОбработкок.Разделы.Добавить();
        Раздел.Раздел = Справочники.ИдентификаторыОбъектовМетаданных.НайтиПоРеквизиту("ПолноеИмя", "Подсистема.Покупки");
        Раздел = НовОбъектСпрвочникаДопОбработкок.Разделы.Добавить();
        Раздел.Раздел = Справочники.ИдентификаторыОбъектовМетаданных.НайтиПоРеквизиту("ПолноеИмя", "Подсистема.ПокупкиИПродажи82");
    КонецЕсли;
    НовОбъектСпрвочникаДопОбработкок.РежимСовместимостиРазрешений = Перечисления.РежимыСовместимостиРазрешенийДополнительныхОтчетовИОбработок<wbr>­.Версия_2_2_2;
    ДвДанные = Новый ДвоичныеДанные(ИспользуемоеИмяФайла);
    ДвДанные.Записать(ИспользуемоеИмяФайла);
    НовОбъектСпрвочникаДопОбработкок.ХранилищеОбработки = Новый ХранилищеЗначения(ДвДанные);
    НовОбъектСпрвочникаДопОбработкок.Записать();
    Если Не БылаЗарегина Тогда //Если уже была зарегистрирована, не будем портить список пользователей
        ПользователиИБ = ПользователиИнформационнойБазы.ПолучитьПользователей();
        
        Если ПользователиИБ.Количество() > 0 тогда
            Для Каждого Пользователь Из ПользователиИБ Цикл
                Если Не Пользователь = Справочники.Пользователи.ПустаяСсылка() и Не Пользователь = Неопределено Тогда
                    РегистрДоступа = РегистрыСведений.ПользовательскиеНастройкиДоступаКОбработкам.СоздатьМенеджерЗаписи();
                    РегистрДоступа.Активность = Истина;
                    РегистрДоступа.ДополнительныйОтчетИлиОбработка = НовОбъектСпрвочникаДопОбработкок.Ссылка;
                    РегистрДоступа.Доступно = Истина;
                    РегистрДоступа.ИдентификаторКоманды = КомандыРегистрации.Идентификатор;
                    //РегистрДоступа.Пользователь = Справочники.Пользователи.НайтиПоРеквизиту("ПолноеИмя", Пользователь.ПолноеИмя);
                    РегистрДоступа.Пользователь = Справочники.Пользователи.НайтиПоНаименованию(Пользователь.ПолноеИмя);
                    РегистрДоступа.Записать();
                КонецЕсли;
            КонецЦикла;
        Иначе
            РегистрДоступа = РегистрыСведений.ПользовательскиеНастройкиДоступаКОбработкам.СоздатьМенеджерЗаписи();
            РегистрДоступа.Активность = Истина;
            РегистрДоступа.ДополнительныйОтчетИлиОбработка = НовОбъектСпрвочникаДопОбработкок.Ссылка;
            РегистрДоступа.Доступно = Истина;
            РегистрДоступа.ИдентификаторКоманды = КомандыРегистрации.Идентификатор;
            РегистрДоступа.Пользователь = Пользователи.ТекущийПользователь();
            РегистрДоступа.Записать();
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
#КонецОбласти
плюс в модуле надо добавить функцию:
Код:
Функция ИмяФайлаОбработки() Экспорт
    Возврат ЭтотОбъект.ИспользуемоеИмяФайла;
КонецФункции

Ещё чуть-чуть:

anna140331, Вангую - работаете в БП 3.0, перешли на новую версию платфомы.
В модуле формы надо закомментарить все вхожения строки:
Код:
ТаблицаРезультатов.Показать();

Возможно, есть ещё что-то.
Поэтому и спросил - что, эти "подсказки" не помогают?
02.03.2018 16:12
Fomka
 
KirillHome, понял о чем ты, спасибо)
Нет, это не то. У меня более свежая версия обработки чем из этих комментов. Я их просто и не читал, т.к. они слишком старые для меня)
16.03.2018 12:08
Micle
 
Уважаемые, посодействуйте плиз
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
16.03.2018 12:55
KirillHome
 
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 10 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
19.03.2018 08:21
Micle
 
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 2000 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
19.03.2018 10:34
MWWRuza
 
Цитата:
Micle требуется (2000 сообщение(ий), у вас 888)
Ну, как хочешь, хотел тебе помочь, и СтартМаней лишних много, но, столько не нафлудил!
19.03.2018 10:54
Fomka
 
MWWRuza, видимо прицел четко на KirillHome )))
19.03.2018 12:02
KirillHome
 
Цитата:
MWWRuza Ну, как хочешь, хотел тебе помочь, и СтартМаней лишних много, но, столько не нафлудил!
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 10 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
19.03.2018 12:48
KirillHome
 
Цитата:
MWWRuza Ну, как хочешь, хотел тебе помочь, и СтартМаней лишних много, но, столько не нафлудил!
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 10 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
19.03.2018 18:11
MWWRuza
 
Вот.

А что с "Хранилищем" случилось? Раньше была кнопка, "Загрузить в хранилище", а сейчас не нашел... Только открывается на просмотр...
Поэтому, прицепил к сообщению....

PS Нашел... Теперь, надо сначала зайти в нужную папку, и внизу появляется загрузка.
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 60 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.


Удалил из вложений, переложил в хранилище.

Последний раз редактировалось MWWRuza; 19.03.2018 в 18:25.


Опции темы


Часовой пояс GMT +3, время: 23:50.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.