[ОТВЕТИТЬ]
Опции темы
13.10.2013 17:03  
KirillHome
Сделал глупость - перевёл сейчас, а не с "начала периода" (ну, хотя бы с нового года).

Проблемы, которые мне попались:

1) Переделывание всех внешних обработок, печатных форм.
Всё решаемо - с той или иной степенью сложности и ... не удачности.
К примеру - тоже самое "Заявление о выдаче средств".
Претензии:
1.1) Во-первых, эта форма печати появляется (при нажатии кнопки "Печать") у всех расходных ордеров, а не только расходных ордеров с операцией "Выдача под отчёт" (в 2.0 настраивалось так, что появлялась только у указанной операции). Нет, у других операций - она говорит, что печатать не будет (не совпали операции), но в списке - есть. Не нравится.
Примеры - pict_01 и pict_02
1.2) При выборе внешней формы запускается просмотр, в котором "основная кнопка печати" - нерабочая, а "вспомогательная" - рабочая. Не нравится.
Пример - pict_03

2) Изменена нумерация. Почти всего. Как минимум - документов и справочников.
Да, 1с, конечно, дала рекомендацию:
Цитата:
Способ нумерации документов в редакции 3.0 изменен по сравнению с редакцией 2.0. Для правильной нумерации документов необходимо изменить номер первого создаваемого документа каждого вида так, чтобы он продолжал нумерацию из старой версии. При этом номера документов, перенесенных из редакции 2.0, в печатных формах будут отображаться правильно. Например, последний номер документа "Реализация товаров и услуг" был 00000000131. После обновления на редакцию 3.0 первый введенный документ будет иметь номер 0000-000001. Чтобы сохранить правильную нумерацию, необходимо в этом документе изменить номер на 0000-000132. В дальнейшем всем введенным документам "Реализация товаров, услуг" будет присваиваться правильный номер.
Но - они забыли сказать, что касается это не только документов, но и справочников.
При этом (что самое обидное) - не всех справочников.
К примеру, справочник банков, валют, стран мира, возможно - единиц измерения - предлагается заполнить из "Общероссийских классификаторов", встречал упоминания о том, что ряд предопределённых значений справочников - тоже имеет "не новую" нумерацию.
Пока даже не знаю, с какой стороны к этому подойти.
Написал "совсем тупую" обработку для справочников, но из-за того, что:
2.1) Не у всех справочников есть поле "Код" (к примеру, у справочника "Пользователи" этого поля нет - смотри pict_05)
2.2) У части есть предопределённые значения в "старом формате" (к примеру, у справочника "Статьи затрат" - смотри pict_04)
не могу её "глобализовать"
На всякий случай - [spoil=текст этой "тупой обработки" для контрагентов]

Код:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Запрос = Новый Запрос;
	ТекстНачало = "ВЫБРАТЬ
	|	НашСправочник.Ссылка,
	|	НашСправочник.Код
	|ИЗ
	|	";

	Для каждого Справочник из Метаданные.Справочники Цикл
		ИмяСправочника = Справочник.Имя;
		МенеджерСправочника = Справочники[ИмяСправочника];
		Если ИмяСправочника = "Контрагенты" Тогда
			Запрос.Текст = ТекстНачало + "Справочник."+ИмяСправочника+" КАК НашСправочник";
			Результат = Запрос.Выполнить();
			ВыборкаДетальныеЗаписи = Результат.Выбрать();
			Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
				КодТекущий = ВыборкаДетальныеЗаписи.Код;
				КодНовый = "00-"+Прав(ВыборкаДетальныеЗаписи.Код,6);
				//На самом деле - надо проверять:
				//Какова длина поля код? Прав(ВыборкаДетальныеЗаписи.Код,6) верно только если длина = 9
				//А не предопределённый ли это код?
				//А правильно ли сформировали КодНовый (Нет ли там пробелов? А прочих, не числовых символов?)
				Если КодТекущий <> КодНовый тогда
					Попытка
						НашСправочник = МенеджерСправочника.НайтиПоКоду(КодТекущий);
						НашСправочникОбъект = НашСправочник.ПолучитьОбъект();
						НашСправочникОбъект.Код = КодНовый;
						НашСправочникОбъект.Записать();
					Исключение
						Сообщить("Ошибка(скорее всего) при записи элемента справочника "+ИмяСправочника+" из кода " + КодТекущий + " под кодом " +КодНовый); 
					КонецПопытки;
				КонецЕсли;
			КонецЦикла;
		КонецЕСли;
	КонецЦикла;

КонецПроцедуры
[/spoil]

3) Не знаю, не разобрался - или 1с "в своём репертуаре"
Случилось чудо, и наконец появилась возможность поставить у пользователя в правах доступа "Только просмотр" (см. pict_06).
Казалось бы - вот оно, счастье!
Тем, кому нужен только доступ к отчётам - ставим роль "только просмотр" - и всё, у них нет возможности изменения данных.
На деле - получается смешнее.
Да, можно сформировать любой отчёт и посмотреть на него на экране.
Нельзя ни распечатать (см. pict_07 - кнопки печати "засерены"), ни сохранить (см. pict_08 - все действия "засерены").
Буду дальше смотреть - как это обходить?

На этом пока всё.
Да, ещё мне показалось, что стало чуть медленнее загружаться - но, во-первых, возможно - действительно показалось, во-вторых - всё это крутится на очень уж старом "сервере" со старым железом (P4 - 2.8ГГц, 4ГБ оперативки, 2 IDE диска (!!!), всё - в терминальных сессиях под Win'2003 x32, одновременно - порядка 20 терминальных сессий, 1с - в 4-5 сессиях).
Миниатюры
Нажмите на изображение для увеличения
Название: pict_01.jpg
Просмотров: 538
Размер:	265.4 Кб
ID:	2552   Нажмите на изображение для увеличения
Название: pict_02.jpg
Просмотров: 474
Размер:	145.4 Кб
ID:	2553   Нажмите на изображение для увеличения
Название: pict_03.jpg
Просмотров: 491
Размер:	161.4 Кб
ID:	2554   Нажмите на изображение для увеличения
Название: pict_04.jpg
Просмотров: 462
Размер:	50.9 Кб
ID:	2555   Нажмите на изображение для увеличения
Название: pict_05.jpg
Просмотров: 504
Размер:	218.3 Кб
ID:	2556  

Нажмите на изображение для увеличения
Название: pict_06.jpg
Просмотров: 502
Размер:	166.3 Кб
ID:	2557   Нажмите на изображение для увеличения
Название: pict_07.jpg
Просмотров: 523
Размер:	195.4 Кб
ID:	2558   Нажмите на изображение для увеличения
Название: pict_08.jpg
Просмотров: 498
Размер:	170.4 Кб
ID:	2559  
 
"Спасибо" KirillHome от:
13.10.2013 22:45  
KirillHome
4) Ещё одна проблема, связанная с правами пользователей.
Отныне обработка "Удаление помеченных объектов" доступна только пользователю с правами "Администратор".
Казалось бы - ничего страшного, ну удалишь когда-никогда - и всё.
Ан нет. Есть ведь ряд документов, в нумерации которых не должно быть "дырок" (да хоть те же приходные и расходные кассовые ордера). Соответственно - удалять надо оперативно.

Не исключаю, что я опять не понял "всю глубину наших глубин" (с), но какое-то это странно...
Ну почему эту .... привилегию не сделать доступной хотя бы ещё и пользователю роли "главный бухгалтер"?
 
 
Опции темы



Часовой пояс GMT +3, время: 04:57.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.