20.11.2014 21:22
GENDALF
 
Как решили проблему??? help me!
20.11.2014 21:23
OlegON
 
Какая версия Супермага?
21.11.2014 07:44
OlegON
 
ставь 11.2.0.3 или 10.2.0.4
21.11.2014 11:58
baggio
 
Цитата:
GENDALF Как решили проблему??? help me!
11.2.0.3
21.11.2014 15:07
GENDALF
 
Прогнал... получил ошибку

grant SUPERMAG_FN_SMPOST_POST to SUPERMAG_FN_EDIT_SYSPAR

Посмотрел вот это:
select * from dba_roles where password_required='YES';

Ответило
SUPERMAG_MODULE_SMPOST
SUPERMAG_ADMIN_GROUP
SUPERMAG_ADMINSYS_GROUP...........
........................................

Жму
alter role SUPERMAG_MODULE_SMPOST not identified;
alter role SUPERMAG_ADMIN_GROUP not identified;
alter role SUPERMAG_ADMINSYS_GROUP not identified;
alter role SUPERMAG_FN_SMPOST_POST not identified;
alter role SUPERMAG_FN_OPERFIFO not identified;
alter role SUPERMAG_FN_SMPOST_SETUP not identified;
alter role SUPERMAG_FN_SMPOST_CONTROL not identified;
alter role SUPERMAG_FN_SMPOST_SYT not identified;
alter role SUPERMAG_FN_SMPOST_SYR not identified;
alter role SUPERMAG_FN_XMLSCHEMAEDITOR not identified;
alter role SUPERMAG_MODULE_ADMIN not identified;
.........................................

select * from dba_roles where password_required='YES';

отобрал 0...

grant SUPERMAG_ADMIN .............

странно как то получается... схемы нет, чтоб роли поправить... пробовал на ходу (лупом)... всвязи с минимум времени... забиваю на это дело...
с новой базой не получится видимо... кто делает экспорт импорт... и поднимает версию см... может и поможет.

Жаль... управлялся бы генератор... :( спасиб за ответы
02.12.2018 09:41
OlegON
 
проапгрейдил тут базу 1.036.1 на 11.2.0.4, блин... спасло только
SQL код:
DECLARE
   
sql_stmt   VARCHAR2 (100);
BEGIN
   
FOR c IN (SELECT role FROM dba_roles
                  WHERE role like 
'SUPERMAG%')
   
LOOP
begin       
EXECUTE IMMEDIATE 
'ALTER role '||c.role || ' not identified';
end;
   
END LOOP;
END;

25.07.2019 11:13
Neutron
 
Не знаю актуален этот вопрос еще или нет, в качестве обходного пути сделал:
alter system set "_grant_secure_role"=true scope=spfile;
25.07.2019 11:29
OlegON
 
А зачем вообще 11.2.0.4 ставить-то, если версия СМ древняя?
25.07.2019 12:33
Neutron
 
Цитата:
OlegON А зачем вообще 11.2.0.4 ставить-то, если версия СМ древняя?
Пoтому что новое железо не поддерживает 2008R2 а 10-ка насколько я знаю не работает с 2012

П.С.
Кстати это временное решение, на днях будет новая версия

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.