[ОТВЕТИТЬ]
Опции темы
09.01.2014 13:45  
KirillHome
Обновил БП до 3.0.28.12
В числе изменений было и "С 1 января 2014 года для обмена с системами "Клиент банка" применяется формат обмена версии 1.02"

Сегодня бухгалтерия не смогла загрузить информацию в "Сбербанк-Онлайн" - с совсем не информативным сообщение - "неверный формат данных" (сообщения из журнала пишу по памяти).

Исправил в заголовке файла строку
Код:
ВерсияФормата=1.02
на
Код:
ВерсияФормата=1.01
Всё заработало!
 
"Спасибо" KirillHome от:
09.01.2014 16:23  
KirillHome
Та же история с Райффайзеном.
Вечером буду смотреть - можно ли где-то настроить этот "показатель".
 
09.01.2014 21:38  
KirillHome
Посмотрел.
Тупо зашито в конфигурации в модуле менеджера обработки КлиентБанк

Код:
	Если Год(НачПериода) > 2013 Или Год(КонПериода) > 2013 Или Год(ТекущаяДата()) > 2013 Тогда
		ВерсияФормата = "1.02";
	Иначе		
		ВерсияФормата = "1.01";
	КонецЕсли;
В БП 3.0 точно - можно показать бухгалтерам следующий путь решения (если не залезать в конфигуратор и не снимать с сопровождения).
В обработке "Клиент-Банк" после выгрузки есть возможность посмотреть файл (рядом с кнопкой "Выгрузить" есть две гипер-ссылки - "Отчёт о выгрузке" и "Выгруженный файл").
Нажимаем на "Выгруженный файл", исправляем во второй строчке 1.02 на 1.01, закрываем это окно (вкладку) - 1с спрашивает "Сохранить изменения в файл выгрузки?". Сохраняемся, и продолжаем работать уже с банком в части загрузки информации.

А это то отличие при формировании строк файла обмена, на которое
влияет версия формата

1) Добавляется поле код.
Код:
	Если ВерсияФормата = "1.02" Тогда
		СтруктураЭкспорта.Вставить("Код", ""); // "Уникальный идентификатор платежа"
	КонецЕсли;
2) Заполняется поле код.
Код:
	КодПредусмотренСтандартамиОбмена = СтрокаЭкспорта.Свойство("Код");
	КодВыгружаетсяВОтдельномПоле     = (ВыборкаДляЭкспорта.Дата >= ПлатежиВБюджетКлиентСервер.НачалоПримененияИдентификатораПлатежа());
	Если КодВыгружаетсяВОтдельномПоле И КодПредусмотренСтандартамиОбмена Тогда
		
		Если ВыборкаДляЭкспорта.ПеречислениеВБюджет 
			И ПустаяСтрока(ВыборкаДляЭкспорта.ИдентификаторПлатежа) Тогда
			СтрокаЭкспорта.Код = "0"; // требования 107н
		Иначе
			СтрокаЭкспорта.Код = ВыборкаДляЭкспорта.ИдентификаторПлатежа; // только требования 383-П
		КонецЕсли;
		
	КонецЕсли;
И как я понимаю - это только для перечислений в бюджет (при импорте "обычных платёжек" у меня этой строки нет).
Миниатюры
Нажмите на изображение для увеличения
Название: Выгрузка.jpg
Просмотров: 848
Размер:	59.5 Кб
ID:	3001  
 
"Спасибо" KirillHome от:
13.01.2014 22:45  
KirillHome
Вышли обновления, в которых:
Цитата:
Добавлена возможность выбрать версию формата обмена с системами "Клиент банка" при выгрузке платежных поручений;
:)
И для БП 2.0 и для БП 3.0
 
 
Опции темы



Часовой пояс GMT +3, время: 20:43.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.