[ТЕМА ЗАКРЫТА]
02.05.2014 22:13
SergeiM
 
Принесли нам пинпады от сбербанка vx 805 и появилась проблемка.
Сб говорит что на компе нужен инет прямой чуть ли вторую сетевую карту надо ставить и якобы нужен прямой ип (пусть даже через роутер) который смотри в инет.
У нас есть сервак на нем две сетевые карты (локалка через фиксированный ip , инет через роутер).
Я СБ говорю если у сервака поставить настройку Разрешить др пользователям использовать подключение инет, решит проблему не устанавливать вторую сетевую, ответ нет нужно отдельную сетевую.

Поэтому спрашиваю у вас.
Как правильно подвести инет к компу к которому подключается пинпад.
1) Поставить вторую сетевую
2) оставить настройку Разрешить др пользователям использовать подключение инет (я так понимаю инет пойдет по сети)
3) В роутер локальной сети подключить кабель инет, тогда инет будет на всех машинах, но на каждую машину нужно ставить антивирус.
03.05.2014 04:00
Vovantus
 
пинпад, это типа терминал? у нас в магазинах, на центральных компах, по две сетевые. одна - для локалки, вторая - для инета. терминал подключен к свитчу, к которому, соответственно, подключён и комп. внутри сети все друг друга видят, само собой. что касается инета. если на компе используется соединение, типа pppoe или pptp, то просто расшаривай доступ для этого соединения, что бы через него все могли в инет выходить. если соединение с инетом устанавливает роутер, то тут немного сложнее, нужно настраивать маршрутизацию.

для виндовс xp необходимо изменить одно значение в реестре и перезагрузить комп. для серверных ОС маршрутизация настраивается другим способом, лень описывать и бум надеяться, что ОС не серверная :)

Цитата:
Чтобы включить маршрутизацию пакетов TCP/IP, выполните указанные ниже действия.
Запустите редактор реестра (Regedit.exe).
В редакторе реестра найдите такой раздел:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
.
Установите следующее значение параметра реестра:
Имя значения: IPEnableRouter.
Тип значения: REG_DWORD.
Значение: 1
значение 1 включает маршрутизацию пакетов TCP/IP для всех сетевых подключений, которые установлены и используются на данном компьютере.
Закройте редактор реестра.
после настройки маршрутизации, на терминале нужно указать в качестве шлюза адрес сетевой, которая смотрит в сеть. настраивать внешнюю сетевуху, полагаю, не нужно, если сейчас инет и так работает. ну как-то так, на вскидку.
03.05.2014 04:22
Vovantus
 
хотя.. наверное можно сделать -по-другому. походу, я только усложнил задачу :) расшарить на компе то соединение, которое смотрит на роутер, тогда всё, что придёт на сетевуху, смотрящую в сеть, пойдёт через вторую сетевуху на роутер и далее, в инет.

компа с двумя сетевыми под рукой нет, потому проверить не могу. помню, что заморачивался когда-то с маршрутизацией, но это наверное из другой оперы совсем.
03.05.2014 05:44
whitewizard
 
Если расшарить, тобудет работать
03.05.2014 14:03
SergeiM
 
Пытался расшарить, выдает предупреждение поменяю ip на 192.168.0.1
Далее почитав эту тему еще на др машины нужно выставить настройки, если я поменяю сеть похерится.
Схема у меня такая, инет идет через роутер, местная настроена через роутер с wi-fi ип адресса закреплены в роутере, соответственно на машине ип не прописываю.
Я чет последовательность не могу понять.
Если я поменяю локальной машине ip тогда она потеряет связь с локалкой, если еще ip сменится на серваке тогда он будет не доступен.
Подскажите как правильно настроить то.
03.05.2014 15:42
whitewizard
 
После того, как поставит на локальной сетевой адрес 192.168.0.1, поменяй его обратно тот, который нужен.
03.05.2014 16:45
SergeiM
 
Да забыл сказать, терминал печатает слипы через фискальник.
03.05.2014 16:47
whitewizard
 
Какое-то извращение.

Кассовое ПО какое?
04.05.2014 11:43
SergeiM
 
1с тис без всяких пос программ и систем.
Пытался вчера расшарить инет, не получилось.
Создаю сеть указываю что этот комп раздает инет, на соединении инет расшариваю доступ, на местной локалке меняю ип на грубо говоря 192.168.0.100 маска 255.....0 шлюз пусто.
Далле компы объединяются в сеть через роутер( кстати в справке написанно что сеть должна быть организованна через простой свит без дшсп и статичесикх ип и роутеров)
идем на комп где нам нужно подключение подключаемся к сети(создание или подключение сети) в настройках указываем что данный комп имеет доступ в инет через др комп.
Прописываем ип 192.168.0.101 маска 255....0 шлюз 192.168.0.100. Да забыл в роутере всем компам присвоем статический ип (или вроде резервация дшсп)
Перезагружаем компы. Сеть видит, 1с запускается.
Но подключения инет так нет , эксплорер не грузит страницы.
Т.е я так понимаю нужно роутер менять на простой свитч, не вариант проще вторую сетевую воткнуть.
Кстатит помучился с настройками двух сетевых, локалка пашет инет нет. Долго рыл инет, заработал один вариант, поменять метрику и на локальную(местную) сеть прописать ип и маску а шлюз пусто. Только так робит и сеть и инет.
воткнул вторую настроил инет.
зарегил компоненты от сб пилот и сбком длл. запускаем сбпилот ехе . нажимаю сверка но выдает ошибку 4120.
кстати есть файл настройки *.tlv в нем только прописан сом порт а ип не прописали , когда приходил сб установщик он ип не прописал и сказал не важно и так подключиться.
Короче буду пытаться все подключить о ходе событий отпишусь, может даже выложу обработку для 1с 7.7.
04.05.2014 15:37
whitewizard
 
сберовцы не дали обработку для 1с?
там всё же просто - пинпад подключается по USB или RS232 и через обработку и их DLL нормально работает.

и всё выше описанное извращение не требуется.
04.05.2014 21:10
SergeiM
 
Не дали к 7.7 у них ничего нет, а в 8 все прекрасно без обработок подключается.
Настроку пинпада до конца не провели.
Короче имею папку с длл со всеми от сбера и все, как 1с свяжется с пин падом их не касается.
09.05.2014 14:31
SergeiM
 
Сб пилот не то, у меня по типу оле все робит.
Сегодня получилось следующее.
Используется в организации два типа касс штрих фрк (со старых времен) и новые сп 402.
Банк предоставил оборудование для эквайринга, пинпад а слипы печатает фискальник.
Завели 2 кассы одна для розницы, др безнал.
Есть обработка для оплат картами, но она написана на Атол драйвере.
Что происходит сейчас.
Берем чек ккм, забиваем позиции, нажимаем кнопку оплата картой, долговато грузится, потом просит ввести послед цифры карты, распечатывает слип, а потом говорит что ком порт занят и сам чек не распечатывает.
Как устроена система.
При начале работы системы в настройках фискального регистратора проставлены данные от штрих или сп, когда нажимаем кнопку оплаты картой в обработке ПриОткрытии() грузится драйвер атолл
Код:

Процедура ПодключитьДрайверККМ()
Попытка
Результ = ЗагрузитьВнешнююКомпоненту("FPRNM1C.dll");
Если Результ = 1 Тогда
ECR = СоздатьОбъект("AddIn.FprnM45");
Иначе
Сообщить ("Не загружена внешняя компонента AddIn.FprnM45.");
КонецЕсли;
Исключение
Сообщить ("Не найдена внешняя компонента AddIn.FprnM45.");
КонецПопытки;

ECR.DeviceEnabled = 1;
Если ECR.ResultCode <> 0 тогда
Возврат;
КонецЕсли;
КонецПроцедуры // ПодключитьДрайверККМ()

соответственно когда обработка завершает свое действие и закрывается

Код:

Процедура ПриЗакрытии()
ECP=0;
//тут еще всякие параметры
КонецПроцедуры

В действие вступает процедура чекаККМ Провести()
Чек проводится, но не распечатывается, ошибка Сом порт занят другим приложением.

Как сделать переключение между кассами или нужно пилить обработку под эти два вида фискальника (просто атол хорошо тем что он уневерсален и не важно какой фискальник стоит)?
19.05.2014 21:26
SergeiM
 
В 1с кто нить шарит?
Нужна помощь, в обработку фискальника засунул то что нужно печатать, точнее от фискальника поступила длинная строка примерно 1580 символов. Фискальник штрих фр к отказывается печатать такую длинную строку. В саппорте сказали что нужно эту длинную строку резать по 36 символов. В строке есть символ, его код 13 и смивол код 10 который переносит длинную строку на новую строчкту, мне нужно создать цикл переберая строку до символа 13 а потом продолжить отбор строки опять до символа код 13.
т.е построчно вывести строку и печатать.
СписокСтрок=СоздатьОбъект("СписокЗначений");

Пока 1=1 Цикл
ПозицияПеренос=Найти(ECR,"""+Симв(13)+Симв(10));
Если ПозицияПеренос=0 Тогда //все последняя строка
СписокСтрок.ДобавитьЗначение(ECR);
прервать;
Иначе
СписокСтрок.ДобавитьЗначение(Лев(ECR,ПозицияПеренос-1));
ECR = Сред(ECR,ПозицияПеренос+2);
КонецЕсли;
КонецЦикла;

Но по позиция перенос найти не срабатывает пишет что равно 0
19.05.2014 21:46
OlegON
 
Оффтоп, закрываю тему.
Опции темы


Часовой пояс GMT +3, время: 19:45.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.