[ТЕМА ЗАКРЫТА]
Опции темы
04.05.2014 21:10  
SergeiM
Не дали к 7.7 у них ничего нет, а в 8 все прекрасно без обработок подключается.
Настроку пинпада до конца не провели.
Короче имею папку с длл со всеми от сбера и все, как 1с свяжется с пин падом их не касается.
 
09.05.2014 14:31  
SergeiM
Сб пилот не то, у меня по типу оле все робит.
Сегодня получилось следующее.
Используется в организации два типа касс штрих фрк (со старых времен) и новые сп 402.
Банк предоставил оборудование для эквайринга, пинпад а слипы печатает фискальник.
Завели 2 кассы одна для розницы, др безнал.
Есть обработка для оплат картами, но она написана на Атол драйвере.
Что происходит сейчас.
Берем чек ккм, забиваем позиции, нажимаем кнопку оплата картой, долговато грузится, потом просит ввести послед цифры карты, распечатывает слип, а потом говорит что ком порт занят и сам чек не распечатывает.
Как устроена система.
При начале работы системы в настройках фискального регистратора проставлены данные от штрих или сп, когда нажимаем кнопку оплаты картой в обработке ПриОткрытии() грузится драйвер атолл
Код:

Процедура ПодключитьДрайверККМ()
Попытка
Результ = ЗагрузитьВнешнююКомпоненту("FPRNM1C.dll");
Если Результ = 1 Тогда
ECR = СоздатьОбъект("AddIn.FprnM45");
Иначе
Сообщить ("Не загружена внешняя компонента AddIn.FprnM45.");
КонецЕсли;
Исключение
Сообщить ("Не найдена внешняя компонента AddIn.FprnM45.");
КонецПопытки;

ECR.DeviceEnabled = 1;
Если ECR.ResultCode <> 0 тогда
Возврат;
КонецЕсли;
КонецПроцедуры // ПодключитьДрайверККМ()

соответственно когда обработка завершает свое действие и закрывается

Код:

Процедура ПриЗакрытии()
ECP=0;
//тут еще всякие параметры
КонецПроцедуры

В действие вступает процедура чекаККМ Провести()
Чек проводится, но не распечатывается, ошибка Сом порт занят другим приложением.

Как сделать переключение между кассами или нужно пилить обработку под эти два вида фискальника (просто атол хорошо тем что он уневерсален и не важно какой фискальник стоит)?
 
19.05.2014 21:26  
SergeiM
В 1с кто нить шарит?
Нужна помощь, в обработку фискальника засунул то что нужно печатать, точнее от фискальника поступила длинная строка примерно 1580 символов. Фискальник штрих фр к отказывается печатать такую длинную строку. В саппорте сказали что нужно эту длинную строку резать по 36 символов. В строке есть символ, его код 13 и смивол код 10 который переносит длинную строку на новую строчкту, мне нужно создать цикл переберая строку до символа 13 а потом продолжить отбор строки опять до символа код 13.
т.е построчно вывести строку и печатать.
СписокСтрок=СоздатьОбъект("СписокЗначений");

Пока 1=1 Цикл
ПозицияПеренос=Найти(ECR,"""+Симв(13)+Симв(10));
Если ПозицияПеренос=0 Тогда //все последняя строка
СписокСтрок.ДобавитьЗначение(ECR);
прервать;
Иначе
СписокСтрок.ДобавитьЗначение(Лев(ECR,ПозицияПеренос-1));
ECR = Сред(ECR,ПозицияПеренос+2);
КонецЕсли;
КонецЦикла;

Но по позиция перенос найти не срабатывает пишет что равно 0
 
19.05.2014 21:46  
OlegON
Оффтоп, закрываю тему.
 
 


Опции темы



Часовой пояс GMT +3, время: 02:10.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.