Форум по программам и оборудованию > >

Только у меня сайт в IE перестал открываться?

22.05.2018 22:45


[ОТВЕТИТЬ]
20.02.2015 10:04
MWWRuza
 
Недолго музыка играла...
Было все отлично, а теперь(пару дней?) в IE перестали работать картинки на страницах, в том числе аватарки. Красный крестик в рамке, и все.
В хроме все OK.
20.02.2015 10:17
BotMan
 
есть такое дело, авы показывает по желанию.
20.02.2015 10:17
OlegON
 
Эхх, может, ну его? :) Он еще и gzip не поддерживает. А в результате того, что я убрал проверку браузера, теперь все пошустрее бегать стало...
20.02.2015 10:18
OlegON
 
Стоп, речь про IE6 на XP или вообще IE?
20.02.2015 10:20
BotMan
 
у меня 8.0 на вин 7. авки показывает не все.
как по мне, так я IE вообще не юзаю.
20.02.2015 10:30
OlegON
 
Хнык... Подтверждаю, на IE8/Win7 в IE нет картинок... И что это за хрень, я не понимаю :(
20.02.2015 10:37
Dim
 
IE не пользуюсь давно, но там по умолчанию стоят параноидальные настройки безопасности и была возможность отключить показ картинок. может быть это?
20.02.2015 10:45
OlegON
 
Покрутите кто-нибудь, плз? У меня IE достаточно далеко, чтобы тестировать. И я пока не понимаю, что это такое... Гзип убираю обратно, картинки все равно не возвращаются :(
20.02.2015 10:50
OlegON
 
Цитата:
curl -I https://olegon.ru/customavatars/avatar1_18.gif
HTTP/1.1 200 OK
Server: nginx
Date: Fri, 20 Feb 2015 07:47:50 GMT
Content-Type: image/gif
Content-Length: 9070
Last-Modified: Sat, 08 Nov 2014 09:42:37 GMT
Connection: keep-alive
ETag: "545de58d-236e"
Expires: Thu, 31 Dec 2037 23:55:55 GMT
Cache-Control: max-age=315360000
Public-Key-Pins: pin-sha256="base64+info1="; pin-sha256="backup+pin+here=="; max-age=15768000; includeSubDomains
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Strict-Transport-Security: max-age=15768000; includeSubDomains
Accept-Ranges: bytes
Все нормально... Осел пишет, что картинка недоступна... Что ему еще надо?
20.02.2015 10:59
BotMan
 
убрал все настройки IE безопасности на минимум. ноль эмоций!
20.02.2015 11:50
OlegON
 
Какая-то хрень...
Тыкаю в ссылку своей аватарки https://olegon.ru/customavatars/avatar1_18.gif
В журнале:
Цитата:
"GET /customavatars/avatar10830_1.gif HTTP/1.1" 304 491 "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; .NET4.0E)" olegon.ru - -
типа зашел, спросил, изменилась? - нет? - ну и не надо...
что за...
20.02.2015 12:44
Micle
 
Цитата:
OlegON Какая-то хрень...
Тыкаю в ссылку своей аватарки https://olegon.ru/customavatars/avatar1_18.gif
В журнале:

типа зашел, спросил, изменилась? - нет? - ну и не надо...
что за...
Примерно так работает кеширование в браузере... чего тут необычного ?
20.02.2015 12:48
OlegON
 
Необычно то, что IE при этом картинку не отображает... Я почистил кеш, т.е. Etag, по идее, у него при этом должен был потеряться... Т.е. картинки у него нет, он спрашивает - "есть новое"? Новое не берет, старого взять неоткуда, в итоге выводит в свойствах "Недоступна". Я теряюсь в догадках, что ему надо...
20.02.2015 12:51
Micle
 
Цитата:
OlegON Необычно то, что IE при этом картинку не отображает... Я почистил кеш, т.е. Etag, по идее, у него при этом должен был потеряться... Т.е. картинки у него нет, он спрашивает - "есть новое"? Новое не берет, старого взять неоткуда, в итоге выводит в свойствах "Недоступна". Я теряюсь в догадках, что ему надо...
а как ты ему кеш чистил? штатными средствами?
20.02.2015 12:54
OlegON
 
Да... Кнопочкой. Дело-то не в этом, он с самого начала их не показывает. Картинки-то. Даже те, которые не видел вообще.
Попробуй сам, может, будут идеи какие-то... У кого 11 осел есть? В нем видно?
20.02.2015 12:57
Micle
 
Хм. и вправду нет авы в IE11 .. Чудеса однако )
20.02.2015 13:00
OlegON
 
Причем, тут: Русский язык аватарку не видно, а картинку видно нормально... Ппц.
20.02.2015 13:01
OlegON
 
Цитата:
Micle Хм. и вправду нет авы в IE11 .. Чудеса однако )
Я бы подумал про проблемы с кодом страницы, но он и просто, отдельно картинку не показывает... Не понятно, почему...
20.02.2015 13:09
Micle
 
Вот так выглядит загрузка страницы в ie11

никаких 304 и в помине нет. он её не пытается загружать походу

20.02.2015 13:12
OlegON
 
Это нерегистрированному. Им аватарки не показывают.
20.02.2015 13:16
Micle
 
Цитата:
OlegON Это нерегистрированному. Им аватарки не показывают.
А как объяснить вот такое поведение...

20.02.2015 13:17
OlegON
 
Ахха! Т.е. он их все же сливает, но не может отобразить... Спасибо! Сейчас попробую отключить gzip.
20.02.2015 13:20
Micle
 
Причём firebug ничего странного в заголовках ответа не показывает. Может у сервера на useragent (IE) какая специальная реакция заложена?
20.02.2015 13:30
OlegON
 
В том и дело, что по крайней мере в конфиге ничего про IE точно нет... Отключение гзипа не помогает...

Цитата:
box / # curl -I https://olegon.ru/customavatars/avatar1_18.gif HTTP/1.1 200 OK
Server: nginx
Date: Fri, 20 Feb 2015 10:29:50 GMT
Content-Type: image/gif
Content-Length: 9070
Last-Modified: Sat, 08 Nov 2014 09:42:37 GMT
Connection: keep-alive
ETag: "545de58d-236e"
Expires: Thu, 31 Dec 2037 23:55:55 GMT
Cache-Control: max-age=315360000
Public-Key-Pins: pin-sha256="base64+info1="; pin-sha256="backup+pin+here=="; max-age=15768000; includeSubDomains
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Strict-Transport-Security: max-age=15768000; includeSubDomains
Accept-Ranges: bytes

box / # curl -A "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; .NET4.0E)" -I https://olegon.ru/customavatars/avatar1_18.gif
HTTP/1.1 200 OK
Server: nginx
Date: Fri, 20 Feb 2015 10:29:53 GMT
Content-Type: image/gif
Content-Length: 9070
Last-Modified: Sat, 08 Nov 2014 09:42:37 GMT
Connection: keep-alive
ETag: "545de58d-236e"
Expires: Thu, 31 Dec 2037 23:55:55 GMT
Cache-Control: max-age=315360000
Public-Key-Pins: pin-sha256="base64+info1="; pin-sha256="backup+pin+here=="; max-age=15768000; includeSubDomains
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Strict-Transport-Security: max-age=15768000; includeSubDomains
Accept-Ranges: bytes
В общем, осел чем-то давится, а чем - не могу понять...
20.02.2015 13:33
OlegON
 
Хм, у меня про картинку, что тебе 9.40Кб говорит, фокс говорит, что 8,86 KB (9 070 bytes)...
Типа он вместо картинки что-то еще сливает...
20.02.2015 13:42
Micle
 
Цитата:
OlegON Хм, у меня про картинку, что тебе 9.40Кб говорит, фокс говорит, что 8,86 KB (9 070 bytes)...
Типа он вместо картинки что-то еще сливает...
возможно эта разница в байтах обусловлена методом подсчёта. FF считает без заголовков, может IE включает их в подсчёт..

Что ещё заинтересовало: если сохранить картинку через FF в файл, а затем перетащить её в IE, то она отображается.
20.02.2015 13:46
Micle
 
ну и вот тут изображён полный "финал" на мой взгляд...


20.02.2015 13:47
Micle
 
мало того, что он её скачивает, он её понимает как изображение. Вопрос только в том, почему не отображает...
20.02.2015 13:50
OlegON
 
спасибо за тесты!


Опции темы


Часовой пояс GMT +3, время: 22:45.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.