[ОТВЕТИТЬ]
Опции темы
10.03.2015 20:40  
KirillHome
В выходные обновил БП 3.0 с 3.0.38.51 на 3.0.38.53.

Сегодня с утра чуть не убили - при разноске банковской выписки не подставляются суммы платежей

На скорую руку "придумал" способ:
входим в каждую строку

видим, что сумма пустая, "перевыбираем" статью движения денежных средств (статья ДДС в табличной части), сумма заполняется, сохраняем.

Вечером стал смотреть - что, собственно, изменилось.

Документ СписаниеСРасчетногоСчета, в модуле объекта -
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)

Было (3.0.38.51)
Код:
	Если ВидОперации <> Перечисления.ВидыОперацийСписаниеДенежныхСредств.ПеречислениеНалога
		И ВидОперации <> Перечисления.ВидыОперацийСписаниеДенежныхСредств.ПеречислениеЗП
		И ВидОперации <> Перечисления.ВидыОперацийСписаниеДенежныхСредств.ПеречислениеЗаработнойПлатыРаботнику
		И ВидОперации <> Перечисления.ВидыОперацийСписаниеДенежныхСредств.ПеречислениеДепонентов
		И ВидОперации <> Перечисления.ВидыОперацийСписаниеДенежныхСредств.ВыдачаЗаймаРаботнику
		И ВидОперации <> Перечисления.ВидыОперацийСписаниеДенежныхСредств.ПеречислениеПодотчетномуЛицу
		И ВидОперации <> Перечисления.ВидыОперацийСписаниеДенежныхСредств.ПереводНаДругойСчет
		И ВидОперации <> Перечисления.ВидыОперацийСписаниеДенежныхСредств.ЛичныеСредстваПредпринимателя Тогда
		СуммаДокумента = РасшифровкаПлатежа.Итог("СуммаПлатежа");
	КонецЕсли;
стало (3.0.38.53)
Код:
	Если НЕ Документы.СписаниеСРасчетногоСчета.ЕстьРасшифровкаПлатежа(ВидОперации) Тогда
		СуммаДокумента = РасшифровкаПлатежа.Итог("СуммаПлатежа");
	КонецЕсли;
Пока смотрю и не понимаю что делать....
Миниатюры
Нажмите на изображение для увеличения
Название: bank_01.jpg
Просмотров: 497
Размер:	61.4 Кб
ID:	4439   Нажмите на изображение для увеличения
Название: bank_02.jpg
Просмотров: 539
Размер:	211.7 Кб
ID:	4440  
 
10.03.2015 20:48  
KirillHome
Завтра буду смотреть - что происходит при загрузке выписки из "Клиент-Банка", а не при "разнесении руками" (через подбор платёжных поручений).
 
10.03.2015 21:05  
KirillHome
Посмотрел ещё чуть-чуть.

В модуле менеджера документа СписаниеСРасчетногоСчета появились две функции:

Код:
Функция ПолучитьСписокВидовОперацийСРасшифровкойПлатежа() Экспорт
	
	СписокОпераций = Новый СписокЗначений();
	СписокОпераций.Добавить(Перечисления.ВидыОперацийСписаниеДенежныхСредств.ОплатаПоставщику);
	СписокОпераций.Добавить(Перечисления.ВидыОперацийСписаниеДенежныхСредств.ВозвратПокупателю);
	СписокОпераций.Добавить(Перечисления.ВидыОперацийСписаниеДенежныхСредств.РасчетыПоКредитамИЗаймам);
	СписокОпераций.Добавить(Перечисления.ВидыОперацийСписаниеДенежныхСредств.ПрочиеРасчетыСКонтрагентами);
	
	Возврат(СписокОпераций);
	
КонецФункции

Функция ЕстьРасшифровкаПлатежа(Знач ВидОперации) Экспорт
	
	СписокВидовСРасшифровкойПлатежа = ПолучитьСписокВидовОперацийСРасшифровкойПлатежа();
	
	Возврат СписокВидовСРасшифровкойПлатежа.НайтиПоЗначению(ВидОперации) <> Неопределено;
	
КонецФункции
Абсолютное впечатление, что НЕ - лишнее в данном случае
Код:
	Если НЕ Документы.СписаниеСРасчетногоСчета.ЕстьРасшифровкаПлатежа(ВидОперации) Тогда
		СуммаДокумента = РасшифровкаПлатежа.Итог("СуммаПлатежа");
	КонецЕсли;
 
10.03.2015 21:42  
MWWRuza
Ну да. С "НЕ" это условие вроде как безсмысленно... Попробуй без "НЕ"...
 
"Спасибо" MWWRuza от:
10.03.2015 21:45  
MWWRuza
А вообще конечно, надо в отладчике смотреть... На вскидку может чего и не видим...
 
10.03.2015 21:48  
KirillHome
Скорее всего - так и придётся.

План пока такой:
1) Сохранить конфигурацию в файл (будет поставкой перед следующим обновлением).
2) Разрешить изменения
3) Изменить эту строчку

Ну, и потом:
4) Дождаться обновления. Проверить там этот момент.
5) Перед следующим изменением - загрузить конфигурацию из файла (там возможны варианты - сначала выгрузить данные, потом - загрузить конфигурацию из файла, потом - загрузить данные). В общем получить базу с неизменённой конфигурацией поставщика.
6) Обновить.
 
10.03.2015 21:50  
KirillHome
Да смотрел я в отладчике.

Документы.СписаниеСРасчетногоСчета.ЕстьРасшифровкаПлатежа(ВидОперации) - получаю Истина (операция - Перечисления.ВидыОперацийСписаниеДенежныхСредств.ОплатаПоставщику).

РасшифровкаПлатежа.Итог("СуммаПлатежа") - получаю нужную сумму документа

Но, так как условие - "НЕ Истина", то СуммаДокумента - получаю 0.

Фигня какая-то :)
 
10.03.2015 22:30  
MWWRuza
Ну, ошиблись... Как обычно... Хреново, что исправлять сложно, в связи с поддержкой. В 7.7 проще было, там проблемаы только с базовыми версиями были, в профках можно было делать все, что хочешь...
А план правильный. Так и надо сделать.
 
10.03.2015 22:34  
KirillHome
Цитата:
Сообщение от MWWRuza
Ну, ошиблись... Как обычно...
Я пока на такое - первый раз попадаю

И удивляет, что нигде нет никаких сообщений на эту тему - ни на мисте (там тоже создал, но пока - ни ответа, ни привета), ни на клерке. Вот и думаю - может, всё же я чего-то не понимаю.
 
10.03.2015 22:40  
MWWRuza
Не знаю. Я пока этим релизом еще ни кому профки не обновлял. А пользователи базоых обновляются сами...
Пока не жаловались. Будет прецидент - посмотрю. А так, попробуй исправить, на копии... Если все нормально - действуй по плану. Если нет - ну, можешь дать мне копию базы(естественно, конфиденциальность гарантирую!:))
посмотрим вместе.
 
 


Опции темы



Часовой пояс GMT +3, время: 17:41.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.