[ОТВЕТИТЬ]
11.08.2015 12:30
OlegON
 
В общем, поиграл.

Во-первых, изменили инсталлятор. Он теперь гламурный, т.е. по RDP намаетесь. Хотя... Это больше придирка.

Во-вторых, если что-то не так, то инсталлятор прекращает работу. Например, если с хаспом какие-то вопросы вроде установленного сервиса или более новой версии. Поэтому, если ключ работает нормально, возможно, стОит галочку инсталляции дров хаспа снять сразу.

В-третьих, это .Net4. Предлагается установить.

В-четвертых, на ХР вот такое вот сообщение
Цитата:
2015.08.11 (Tuesday) 13:26:24 1.32.0.0 sp0 Sm.Main
----- Прерывание работы программы -----
сообщение: "Указанный алгоритм шифрования не поддерживается на этой платформе."
исключение: System.PlatformNotSupportedException
источник: Sm.Main
метод: Void loginWorker_RunWorkerCompleted(System.Object, System.ComponentModel.RunWorkerCompletedEventArgs)
в Sm.Main.Login.LoginModel.loginWorker_RunWorkerCompleted(Object sender, RunWorkerCompletedEventArgs e)
в Sm.Core.TaskWorker.OnRunWorkerCompleted(RunWorkerCompletedEventArgs e)
при подключениях клиентов к базе потом, причем, как говорят, прямое и через сервер приложений подключения одинаковы. Есть идеи по последнему?
11.08.2015 13:03
baggio
 
ха...
я так понимаю они начали использовать
CNG (Cryptography API: Next Generation)
и ХР и 2003 проходят мимо...
11.08.2015 14:26
OlegON
 
Я не углублялся, вроде как после лопатки этого сообщения дальше работают нормально...
11.08.2015 14:52
baggio
 
крайне странно... что работает после этого - возможно после ошибки уходит на другой алгоритм
ошибка говорит о том что идет попытка использования алгоритма шифрования которого нет в ОС...
т.е. в дот нет нет алгоритма реализации как таковой... он перекладывает это на ОС...
а в ОС нет такого алгоритма...
вот и ошибка...
11.08.2015 15:15
OlegON
 
По идее оно тупо не шифрует что-то, либо так же тупо где-то не работает :)
11.08.2015 15:21
kadr
 
А cупермажные службы на XP завелись? Не от нового ли механизма проверки ключа и лицензии данная ошибка
11.08.2015 15:25
OlegON
 
А там их никто и не запускал... Забавно будет, если лицензии с ХР не будут учитываться :)
11.08.2015 15:31
kadr
 
Менее забавно будет если полноценно с XP работать не будет, у меня ещё куча рабочих машин на XP
11.08.2015 16:05
OlegON
 
Вроде работает пока. Тут как раз была ситуация, что все машины в офисе - ХР. Одна семерка, где такой проблемы нет.
18.08.2015 14:18
akonev
 
еще менее забавно, что у меня пока что все терминальники на 2003.
включая тот, на котором лицензии.
19.08.2015 15:57
Dim
 
версию 32.0 без СП сегодня пересобрали
Опции темы


Часовой пояс GMT +3, время: 08:40.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.