[ОТВЕТИТЬ]
Опции темы
13.11.2015 04:53  
Алхимик
Приветствую уважаемые коллеги!

Ситуация:

Софт: SetRetail 5
Весы: CAS CL5000J

Вопрос: как заставить весы принимать весовой товар именно как весовой а не штучный? (Признак весового товара в карточке товара выставлен).
 
13.11.2015 07:30  
OlegON
Полная уверенность, что проблема в весах, а не настройках SetRetail? А то завести бы тему в соответствующем разделе, сюда спецы по SetRetail редко заглядывают...
 
13.11.2015 10:20  
Алхимик
Спецы по SetRetail-у расписались в своём бессилии, к сожалению. Дело в том, что они всегда работали с толедами и касы никогда не настраивали. Все настройки, что можно было покрутить уже покрутили. Осталась очередь за спецами по весам.
 
13.11.2015 11:05  
MWWRuza
Честно говоря, проблема вообще непонятна - слишком много неизвестных...
Чем Вы их грузите?
Как программа с ними "вяжется"?
Из какого-то(какого?) драйвера напрямую, или формирует файл, который загружается стандартным(каким?) загрузчиком? Если так, то "файл в студию"...
Я с этими весами много работал, но из 1С, даже писал обработку для ККС, когда только появился драйвер под них. Вроде нет там никаких настроек в весах, если правильно их загружать, то работают "из коробки"...
 
13.11.2015 11:18  
grannie
Хранилище

Из этого всё прочитали?
Былой опыт подсказывает, что содержимое файлика SetScales.conf нужно вдумчиво проанализировать
 
13.11.2015 11:22  
MWWRuza
Вот кусочек кода, который у меня грузит эти весы в 1С:

Код:
СписокТоваров.ВыбратьСтроки();
Пока СписокТоваров.ПолучитьСтроку()=1 Цикл 
		
		Объект.InitData();//Очистка свойств связанных с загрузкой параметров о товаре
		
		PLUКод = СписокТоваров.PLU;
		Если ( PLUКод < 1 ) ИЛИ ( PLUКод > 6000 ) Тогда
					Сообщить( PLUКод + " PLU-код товара " + СОКРП(СписокТоваров.Товар.Наименование)
						+ " больше 6 тысяч! Товар пропущен." );
			Продолжить;
		КонецЕсли;   
		
		Если СтрДлина(СокрЛП(СписокТоваров.ШтрихКод)) > 5 Тогда
			Сообщить( "Код товара " + СОКРП(СписокТоваров.Товар.Наименование )
						+ " больше пяти символов! Товар пропущен.");
			Продолжить;
		КонецЕсли;
		
		Если СтрДлина(СокрЛП(СписокТоваров.ШтрихКод)) = 0 Тогда
			Сообщить( "У товара " + СОКРП(СписокТоваров.Товар.Наименование )
						+ " отсутствует штрихкод! Товар пропущен.");
			Продолжить;
		КонецЕсли;		
        
		Если СписокТоваров.Цена=0 Тогда
			Сообщить ("Нулевая цена товара "+ СОКРП(СписокТоваров.Товар.Наименование));
		КонецЕсли;
		                                      
		
		Состояние( "Загрузка товара с PLU-кодом " + Строка( PLUКод ) + ", " 
		+ СписокТоваров.Товар.Наименование ); 
		
		Объект.pluNumber = PLUКод;
		Объект.pluDept = 1;
		Объект.pluName1 = Лев(СокрЛП(СписокТоваров.Товар.Наименование),54);
		//Объект.pluName2 = "name1";
		Объект.pluPrice = Цел(СписокТоваров.Цена*100);
		Объект.pluType = 1;
		//Объект.pluStrLogo = "1";
		Объект.pluGroupCode = 1;
		Объект.pluItemCode = СписокТоваров.ШтрихКод;
		//Объект.pluFixedPrice = 0;
		//Объект.pluWeightTare	= 0;
		//Объект.pluDatePack = 0;
		//Объект.pluTimePack = 0;
		Объект.pluDateLife = СписокТоваров.Товар.СрокГодности;
		//Объект.pluTimeLife = 0;
		//Объект.pluNumberMsg = 1;
		//Объект.pluTextMessage = "0";
		Если Константа.ФорматЭтикеткиLC5000 > 0 Тогда
			Объект.pluNumberLabel = Константа.ФорматЭтикеткиLC5000;
		КонецЕсли;
		//Объект.pluNumberBarcode = 0;
		//Объект.pluDateCreate = 0;
		//Объект.pluTextNumber = 0;
		//
		//Объект.pluTextNumber = 0;
		//Объект.pluLP16logoNumber = 0;
		//Объект.pluSYmbol = 0;
		//Объект.pluExtPCS = 0;
		//Объект.pluExtOrigin = 0;
		//Объект.pluExtBar2 = 0;
		//Объект.pluExtFixedWeight = 0;
		
		Объект.SendPlu();
		
		Если Объект.ResultCode = 0 Тогда
			Состояние("Успешно загружен.");
		Иначе
			Сообщить("Не удалось загрузить товар " + СокрЛП(СписокТоваров.Товар.Наименование) + " " + ОписаниеОшибкиДрайвера(Объект.ResultCode));
		КонецЕсли;
	КонецЦикла;	
	Объект.Close();
	Сообщить("Все товары успешно загружены в весы!");
Не знаю, поможет это Вам чем-то, или нет... Сейчас точно не помню, доков к драйверу под рукой нет, но вроде вот этот параметр: "Объект.pluType = 1;" как раз и отвечает за тип товара весовой/штучный. Куча всяких параметров закомментирована, как не обязательная. Все и так работает.
 
13.11.2015 12:21  
Алхимик
Благодарю всех за помощь! Особенно grannie. Архив помог. Дело было в переменной NonWeightPrefixes.
 
13.11.2015 12:43  
grannie
Цитата:
Сообщение от Алхимик
Спецы по SetRetail-у расписались в своём бессилии, к сожалению.
А это кто конкретней был?
 
14.11.2015 07:29  
Алхимик
Это был "Сервис-Трейд", но в конечном итоге их совет и помог, это они указали на переменную NonWeightPrefixes.
 
 
Опции темы



Часовой пояс GMT +3, время: 00:50.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.