[ОТВЕТИТЬ]
Опции темы
10.03.2016 09:36  
Tigra_N
Цитата:
Во вложении, не смотря на название, оказалась обработка с (отображаемым в конфигурации) именем УправлениеВесамиUnitech. Так что буду отвечать на вопросы о той, что выложил я.
Параллельно работаю над несколькими задачами, поэтому у меня такая путаница.
Цитата:
Версия, отображаемая в заголовке формы - см. процедуру ПриСозданииНаСервереExt
спасибо за подсказку, буду менять, чтобы не путаться
Цитата:
Сделано для того, что бы пользователь (по злобе ли, или нет) не смог изменить считанные из ТСД данные (да, я не знаю, как разрешить выделять строки, но при этом не дать изменять строки).
в большинстве случаев пользователь даже не догадается, но будет не совсем правильно давать ему такую возможность. может на форме добавить какую-нибудь кнопку для выделения строк программно?
Цитата:
Это "хвост" из оригинальной обработки.
я так и понял, но как его сделать невидимым? в свойствах этой вкладки убираю галочку "Видимость", но его все равно видно
Цитата:
Должно быть
я поменяю код процедуры на этот и выложу последнюю версию обработки.
Вложения
Тип файла: rar УправлениеТСДExt_ver1.1.rar (63.3 Кб, 32 просмотров)
 
10.03.2016 09:38  
Tigra_N
Цитата:
я поменяю код процедуры на этот и выложу последнюю версию обработки.
выложил, не поменяв, потому, что не было 1с под рукой. потом поменяю и выложу
 
10.03.2016 10:06  
KirillHome
Цитата:
Сообщение от Tigra_N
в большинстве случаев пользователь даже не догадается, но будет не совсем правильно давать ему такую возможность. может на форме добавить какую-нибудь кнопку для выделения строк программно?
Объясни, для чего надо "выделять несколько строк".
После этого будем думать, как это решить.

Цитата:
Сообщение от Tigra_N
я так и понял, но как его сделать невидимым? в свойствах этой вкладки убираю галочку "Видимость", но его все равно видно
Странно, но у меня она не видима (см. вложение)

Цитата:
Сообщение от Tigra_N
я поменяю код процедуры на этот и выложу последнюю версию обработки.
Выкладывай, будем смотреть.
Миниатюры
Нажмите на изображение для увеличения
Название: Отсутствие вкладки Документы.jpg
Просмотров: 80
Размер:	143.2 Кб
ID:	7090  
 
10.03.2016 11:06  
Tigra_N
Цитата:
Объясни, для чего надо "выделять несколько строк".
После этого будем думать, как это решить.
Нужно выделить строки для копирования. Когда таблица в режиме "Только для чтения", копируется только последняя строка, так как выделена только она. Я хочу программно выделить все строки, но чтобы для пользователя таблица все же оставалась в режиме "Только для чтения"
Миниатюры
Нажмите на изображение для увеличения
Название: УправлениеТСДExt_SelectAll.png
Просмотров: 81
Размер:	53.7 Кб
ID:	7091  
Вложения
Тип файла: rar УправлениеТСДExt_ver0.10.rar (63.8 Кб, 27 просмотров)
 
10.03.2016 15:00  
KirillHome
Цитата:
Сообщение от Tigra_N
Нужно выделить строки для копирования. Когда таблица в режиме "Только для чтения", копируется только последняя строка, так как выделена только она. Я хочу программно выделить все строки, но чтобы для пользователя таблица все же оставалась в режиме "Только для чтения"
Понял.
Вроде бы даже разобрался с выделением. Но - есть "засада".
Дело в том, что из ТСД мы получаем строки "не свёрнуто", и, соответственно, так же отображаем.
Получается, что и копировать мы можем "развёрнуто".

Есть совсем дурацкий вариант:
1) Добавить на форму не только ТоварыИзТСД, но и ТоварыИзТСДСвернуто.
2) Разместить кнопки копирования и на одной ТЧ, и на другой.

Мне он не нравится, но на всякий случай я его сделал (см. версию 0.11 во вложении)
Отличия от версии 0.10
1) Вынесена на форму ТЧ ТоварыИзТСДСвернуто
2) Заработал механизм выделения строк без изменения
3) в шапке ТЧ ТоварыИзТСДСвернуто так же добавлены СВОИ команды копирования выделенных строк
4) Убраны с ТЧ ТоварыИзТСД кнопки "выбрать всё/снять выбеление" и колонка "Выбрано"
Вложения
Тип файла: zip УправлениеТСДExt.zip (65.0 Кб, 30 просмотров)
 
10.03.2016 18:13  
KirillHome
Только сейчас понял - есть недобработка (когда очищается ТЧ ТоварыИзТСД, но не очищается ТЧ ТоварыИзТСДСвернуты).

Заменить
Код:
&НаКлиенте
Процедура ОчиститьТоварыИзТСД()
	Элементы.ТоварыИзТСД.Доступность = Истина;
	Если Объект.ТоварыИзТСД.Количество() > 0 Тогда
		Объект.ТоварыИзТСД.Очистить(); // т.к. добавляются все товары
		Элементы.ТоварыИзТСД.Обновить();
	КонецЕсли;
	Элементы.ТоварыИзТСД.Доступность = Ложь;
КонецПроцедуры
на
Код:
&НаКлиенте
Процедура ОчиститьТоварыИзТСД()
	Элементы.ТоварыИзТСД.Доступность = Истина;
	Если Объект.ТоварыИзТСД.Количество() > 0 Тогда
		Объект.ТоварыИзТСД.Очистить(); // т.к. добавляются все товары
		Элементы.ТоварыИзТСД.Обновить();
	КонецЕсли;
	Если Объект.ТоварыИзТСДСвернуты.Количество() > 0
		Объект.ТоварыИзТСДСвернуты.Очистить(); //
		Элементы.ТоварыИзТСДСвернуты.Обновить();
	КонецЕсли;
	Элементы.ТоварыИзТСД.Доступность = Ложь;
КонецПроцедуры
 
11.03.2016 09:37  
Tigra_N
Привет, KirillHome.
Цитата:
Вроде бы даже разобрался с выделением. Но - есть "засада".
Дело в том, что из ТСД мы получаем строки "не свёрнуто", и, соответственно, так же отображаем.
Получается, что и копировать мы можем "развёрнуто".
я подумал и пришел к выводу, что строки в развернутом виде нам не нужны. я прошелся по всем документам, и ни в каком из них не нужно получать строки в развернутом виде.
Цитата:
Есть совсем дурацкий вариант:
1) Добавить на форму не только ТоварыИзТСД, но и ТоварыИзТСДСвернуто.
2) Разместить кнопки копирования и на одной ТЧ, и на другой.
я просмотрел этот вариант и вот что я предлагаю:
1. сделать невидимым вкладку "ТоварыИзТСД"
2. сделать основной вкладной "ТоварыИзТСДСвернуто", но уже с нормальным названием для пользователя
3. получать строки в свернутом виде и уже работать с полученной ТЧ.
Цитата:
Заработал механизм выделения строк без изменения
этот механизм очень понравился. все так, как я хотел
 
11.03.2016 10:07  
KirillHome
Я уже писал, чем мне не нравится отсутствие "развёрнутых" строк.

Пришла мысль - добавить в настройки параметр "Режим отображения прочитанного из ТСД" с тремя вариантами:
"Только свёрнуто"
"Только развёрнуто"
"И свёрнуто, и развёрнуто"

Попробую сегодня сделать, заодно подчистить хвосты.
 
11.03.2016 11:48  
Tigra_N
Цитата:
Для контроля "всё или не всё закачалось обработкой" на странице загрузки из ТСД
думаю контролировать не имеет смысла. зачем контролировать? в счет-фактурах, которые приносят с собой поставщики указано количество. если после считывания что-то не совпадет будем разбираться.
Цитата:
Пришла мысль - добавить в настройки параметр "Режим отображения прочитанного из ТСД" с тремя вариантами:
мысль отличная. самый лучший вариант
Цитата:
Попробую сегодня сделать, заодно подчистить хвосты.
что именно? может я почищу, чтобы не отнимать у тебя времени?
 
11.03.2016 15:06  
KirillHome
Цитата:
Сообщение от Tigra_N
что именно? может я почищу, чтобы не отнимать у тебя времени?
Да какие-то вещи, которые были задуманы, но пропущены.

Ладно, вроде релиз.
Часть логики перенесен из процедуры "ПриСозданииНаСервереExt" в "ПриОткрытии" (при создании ещё не все реквизиты доступны, а при открытии - уже всё).
Для смены версии вызываем "ПроверитьОбновленияНаСервере" (где, в частности, проверяется смена версии).
При смене версии открывается справка и фокус переходит на страницу настроек(увы, на справке не получилось сфокусироваться).
Как и планировалось, добавлена настройка (Реквизит) "КакВыводитьТовары". В зависимости от неё видны вкладки "Товары из ТСД", "Товары из ТСД (сгруппировано)".
На вкладке "Выгружаемые из ТСД товары" добавлена команда "Очистить имеющиеся строки в товарах из ТСД". Смысл в том, что в настройках мы можем сказать "Не очищать ТЧ при создании документа", и очистить её в таком случае можно будет только закрыв и открыв заново форму.

Ну, и на этом, наверное, всё?
Нет, можно ещё много "причёсывать" (к примеру - "не выпускать" с вкладки "Настройки" если не всё заполнено, или что-то заполнено неверно; запомнить не только птички "отображать операцию" и "сворачивать строки для операции" но и имя и синоним операции и перезаполнять таблицу операций из метаданных только при смене версии конфигурации; сделать ещё миллион каких-то проверок, и, в зависимости от них делать доступными или нет какие-то действия - и так далее). Но если честно - надоело
Вложения
Тип файла: zip УправлениеТСДExt.zip (66.8 Кб, 34 просмотров)
 
"Спасибо" KirillHome от:
 


Опции темы



Часовой пояс GMT +3, время: 11:03.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.