[ОТВЕТИТЬ]
Опции темы
04.03.2016 13:14  
baggio
Готовый образ можно найти здесь : UTM (УТМ) + Jacarta + raspberry pi

Внимание!!! работает только на второй и третьей малине кторые armv7!!!

для поиска:
Установка Универсального Транспортного модуля (УТМ) на линукс, Linux, ARMv7, ARM, rasbian, РаР, Егаис, EGAIS
Альтернатива Атол HUB-19, Дешевая альтернатива. подтверждение накладных в ЕГАИС, Егаис в рознице, Джакарта, Jacarta




Итак...
принципиально это видимо возможно...

мало того я думаю нужно...
будем пилить?

Последний раз редактировалось baggio; 25.03.2016 в 13:23.
 
04.03.2016 13:18  
baggio
Jacarta Jost
Цитата:
root@raspberrypi:/home/pi# lsusb
Bus 001 Device 004: ID 24dc:0101
 
04.03.2016 13:23  
baggio
sudo apt-get install lsb-base lsb-core alien
sudo apt-get install libmotif4
 
04.03.2016 13:36  
EugeneT
Джава на малинке очень грустно работает. На первой во всяком случае
 
04.03.2016 13:59  
baggio
sudo apt-get install pcsc-tools
 
04.03.2016 13:59  
baggio
Цитата:
Сообщение от EugeneT
Джава на малинке очень грустно работает. На первой во всяком случае
2 и 3 - огонь по сравнению с версией В...
она в 10 раз шустрее первой малины...
 
04.03.2016 14:04  
baggio
root@raspberrypi:/home/pi# dmesg | grep -B 3 -A 1 JaCa
[ 2.994625] usb 1-1.3: new full-speed USB device number 4 using dwc_otg
[ 3.110448] usb 1-1.3: New USB device found, idVendor=24dc, idProduct=0101
[ 3.122842] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 3.135540] usb 1-1.3: Product: JaCarta
[ 3.139239] systemd[1]: Starting Forward Password Requests to Wall Directory Watch.
 
04.03.2016 14:23  
baggio
итак...
нам для счастья нужно jcgostclient_1.5.3.444.deb под armhf
jcpkcs11_1.5.3.859.deb

они как обычно проданы Атолу... но не пользователям... т.е. под х32 х64 есть под armhf болт...
1. нужно раздербанить deb и понять что они делают...
я думаю они апдейтят
/usr/lib/pcsc/drivers/ifd-ccid.bundle/Contents/Info.plist
добавляя vid pid jacarta...
далее
check pcscd version in altlinux

и есть jcpkcs11_1.5.3.859.deb
который ставит
libjcPKCS11.so
libjcPKCS11.so.1
которые я думаю нам и нужны...
 
04.03.2016 14:26  
baggio
Все файлы которые нам нужны есть здесь...


Олег... я один не справлюсь... нужна твоя линуксоидная помосчь...
 
04.03.2016 14:37  
OlegON
Я сейчас немного в запаре, даже читаю не все. Что нужно сделать?
 
 


Опции темы



Часовой пояс GMT +3, время: 14:52.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.