[ОТВЕТИТЬ]
27.02.2017 11:22
student
 
Цитата:
grigoriyp Значит не поменяли ещё.
поменяли - для 2.04 - с форума рара
Разделение внешнего адреса на который обращается УТМ
Тестовый контур.
УТМ обращается вместо 1 адреса test-utm.egais.ru, на три других адреса.
documents-test.utm.egais.ru - все предметные документы
cheques-test.utm.egais.ru - чеки
queries-test.utm.egais.ru - справочники
- Обновление реализовано на УТМ 1.0.14.
Продуктивный контур.
УТМ будет обращаться вместо 1 адреса utm.egais.ru, на три других адреса.
documents-utm.egais.ru - все предметные документы
cheques-utm.egais.ru - чеки
queries-utm.egais.ru - справочники
- Обновление реализовано на УТМ 2.0.4.
Обращаем внимание, что в настройках межсетевых экранов нужно использовать DNS-имена, а не IP-адреса.
Служба оставляет за собой право провести замену IP-адресов без предварительного предупреждения.
27.02.2017 12:09
grigoriyp
 
Не понятно. Если остальные библиотеки хотябы в кучи других пакетов встречались, то jni вобще не встречается отдельно. И в большинстве ссылок, что выдаёт гугл - jni просто встроено в нужную библиотеку... Да и без неё столько времени работало нормально.
27.02.2017 12:11
grigoriyp
 
Ну не знаю. Есть ещё пара 203-х. Ибо без jni не стартует 204, а соответственно и 205.
27.02.2017 12:12
grigoriyp
 
Есть конечно дурацкая идея под qemu запустить как и вайн... Но кажется не хилым таким костылём...
27.02.2017 13:33
baggio
 
написал на всякий зайвку на sdk от аладин... может дадут...
28.02.2017 05:33
ke3u5
 
А как атол хабы сейчас работают?
28.02.2017 05:34
ke3u5
 
Там тоже arm архитектура.. значит у них эта библиотека ест :)
28.02.2017 08:14
grigoriyp
 
Ха, пишут, что Атол тоже загнулся при обновлении)))
На egais2016 ru

Видимо им тоже не пришла библиотека.
28.02.2017 08:16
ke3u5
 
Все там уже работает!!!
28.02.2017 08:27
grigoriyp
 
Значит надо у них вытянуть jni.
28.02.2017 10:13
baggio
 
Алладин мягко послал с библиотеками и СДК. Сказав что мы конечно можем скомпилить за отдельные деньги ...
Вообщем он копает себе могилу...
Кстати а что там с рутокен?
28.02.2017 10:19
MWWRuza
 
Вчера заглянул на АлиЭкспресс. Малинка подешевела, однако :) Видимо рынок насыщается. За 2700 можно купить PI-3 с корпусом, радиаторами и адаптером питания. Остается флешку докупить, и все.
Отсюда, у меня появился интерес, с учетом, что есть на ком поэкспериментировать :)
Вопрос: везде пишут что-то типа - "на борту BCM43143 Wi-Fi и bluetooth low energy consumption (BLE)". Это как понимать? Ну, блюпуп:) фиг с ним, а вот там действительно ВайФай есть встроенный, или это аппаратная поддержка какого-либо WiFi-адаптера? Антенна то не торчит...
И если есть, то как он работает? Можно принимать интернет по WiFi, использовать на борту для УТМ, и попутно раздавать в локалку по проводам, как роутер?
А то, у клиентки, на которой можно было-бы поэкспериментировать, как раз такая ситуация - деревенский магазинчик, интернет прилетает по WiFi "от соседа" :) . Сейчас, УТМ на центральном компе, интернет по WiFi-свистку, касса по кабелю подключена. Сейчас интернет на кассе и не нужен, достаточно локалки для УТМ, а вот с 01.07.2017....
28.02.2017 10:39
grigoriyp
 
Цитата:
baggio Алладин мягко послал с библиотеками и СДК. Сказав что мы конечно можем скомпилить за отдельные деньги ...
Вообщем он копает себе могилу...
Кстати а что там с рутокен?
Работает, но как-то без разницы - UTM требует те же самые библиотеки.
28.02.2017 10:47
OlegON
 
Цитата:
MWWRuza Сейчас интернет на кассе и не нужен, достаточно локалки для УТМ, а вот с 01.07.2017
Проще воткнуть рядом MikroTik hAP AC lite, чем комбайны собирать, имхо.
28.02.2017 12:40
baggio
 
Цитата:
MWWRuza Вчера заглянул на АлиЭкспресс. Малинка подешевела, однако :) Видимо рынок насыщается. За 2700 можно купить PI-3 с корпусом, радиаторами и адаптером питания. Остается флешку докупить, и все.
Отсюда, у меня появился интерес, с учетом, что есть на ком поэкспериментировать :)
Вопрос: везде пишут что-то типа - "на борту BCM43143 Wi-Fi и bluetooth low energy consumption (BLE)". Это как понимать? Ну, блюпуп:) фиг с ним, а вот там действительно ВайФай есть встроенный, или это аппаратная поддержка какого-либо WiFi-адаптера? Антенна то не торчит...
И если есть, то как он работает? Можно принимать интернет по WiFi, использовать на борту для УТМ, и попутно раздавать в локалку по проводам, как роутер?
А то, у клиентки, на которой можно было-бы поэкспериментировать, как раз такая ситуация - деревенский магазинчик, интернет прилетает по WiFi "от соседа" :) . Сейчас, УТМ на центральном компе, интернет по WiFi-свистку, касса по кабелю подключена. Сейчас интернет на кассе и не нужен, достаточно локалки для УТМ, а вот с 01.07.2017....
вайфай работает. отдельный встроенный адаптер.
антенна разведена на плате.
по идее можно раздавать и интернет... есть сборки под это...
можно и 3г модем воткнуть...
этож компьютер... что хотите с ним то и делаете..
были бы желание знания и время...
28.02.2017 13:55
ke3u5
 
Заберите на тест и удалите сообшение
28.02.2017 14:44
ke3u5
 
У меня не получилось.... мн кажется библиотека не отличается от той, что выложена на форуме егаис2016
01.03.2017 08:12
grigoriyp
 
Сейчас попробую.
01.03.2017 08:31
grigoriyp
 
У меня запустилась 204, сейчас попробую 205.
01.03.2017 08:42
grigoriyp
 
Пардоньте. Это апдейтер работает.
Транспортер говорит, что у него нет бюиблиотеки libtoken.so хотя она есть в /opt/jacarta.
01.03.2017 09:01
grigoriyp
 
1000 извинений. Это я туплю. У меня в скрипте запуска старые пути, в lib/x32_so, вместо /opt/jacarta/

204 и 205 работает нормально.
Пользуемся.

СПАСИБО!
01.03.2017 10:09
Rinchin
 
а где Вы берете дистрибутивы 204,205 под armhf?
01.03.2017 10:12
grigoriyp
 
Была ссылка на репозиторий убунтовский. + есть в ЛК.
Распаковываем .deb, копируем папку utm, правим конфиги, подкидываем скрипты в bin от 202-й версии - готово.
Я пробовал запускать стандартными скриптами от 204 и 205 - не получилось.
Тот, кто делает пакет под линукс - линукс видел раза 3-4, и то 4, если он ему приснился)))
В принципе оно должно было бы и само обновиться с 203 на 204, но в версии 203 был 202-й версии апдейтер, а он не умеет апдейтить... Как бы парадоксально это ни звучало(
01.03.2017 10:22
MWWRuza
 
А вот еще вопросик... При переносе УТМ на PC с компа на комп, в том числе и при установке новых версий 203-204-205, база данных подходит по структуре, и абсолютно корректно работает. Если каталог базы переписать на линуксовый УТМ, поднимется?

PS Я прекрасно понимаю, что база данных УТМ, в общем-то и не нужна, там данные хранятся максимум неделю, и можно все перезапросить/восстановить при желании, но все равно интересно? К тому-же, счетчик сквозной нумерации документов, при переустановке сбрасывается, хотя, это тоже не критично...
01.03.2017 11:12
grigoriyp
 
Вообще при переходе с 203 на 203 базу надо было принудительно удалять - иначе не запускалось. А так - нормально переходит из 203, в 204, из 204, в 205... Правда у меня винды нет, но на OpenSuse13.2 и Debian 8.7.0 - вполне нормально.
01.03.2017 11:21
grigoriyp
 
У меня винды нет, изначально utm поднялся на OpenSuse13.2, потом перекочевал вместе с базой на raspberry pi2/3. Запустилось нормально.
На точках с winXP база копировалась на raspberry и работают. Может даже где-то с win7 на raspberry.
01.03.2017 12:58
grigoriyp
 
Если кому нужно:
jacarta.tar.xz - папка с библиотеками - библиотеки сделаны нормально, через символические ссылки, а не так, как в .deb пакете - по 2 одинаковых файла с разными названиями...

utm205_without_jre.tar.xz - просто папка без папки jre, ибо 200 метров это перебор и в моих скриптах java используется системная.
Вложения
Тип файла: xz jacarta.tar.xz (2.20 Мб, 75 просмотров)
Тип файла: xz utm205_without_jre.tar.xz (27.47 Мб, 58 просмотров)
01.03.2017 16:12
Captd
 
Поставил utm 2.0.5 на Raspi выдал следующее

Код:
2017-03-01 14:44:33,945 INFO  es.programador.transport.updater.h - Запуск системы обновления
2017-03-01 14:44:34,230 INFO  es.programador.transport.updater.h - Updater version: [2.0.5b000240] changeset: [8db3d880b93f+]
2017-03-01 14:44:34,248 DEBUG es.programador.transport.a.d - Битность системы: [64]
2017-03-01 14:44:34,250 DEBUG es.programador.transport.a.d - Версия системы: [Linux]
2017-03-01 14:44:34,251 DEBUG es.programador.transport.a.d - Windows: [false]
2017-03-01 14:44:34,252 DEBUG es.programador.transport.a.d - Linux: [true]
2017-03-01 14:44:34,275 DEBUG es.programador.transport.updater.h - Для RSA будет использоваться библиотека [/opt/jacarta/libASEP11.so]
2017-03-01 14:44:34,282 INFO  es.programador.transport.a.d - Linux - Копирование библиотек отключено
2017-03-01 14:44:34,282 INFO  es.programador.transport.a.d - Linux - Копирование библиотек отключено
2017-03-01 14:44:34,283 INFO  es.programador.transport.a.d - Linux - Копирование библиотек отключено
2017-03-01 14:44:34,283 INFO  es.programador.transport.a.d - Linux - Копирование библиотек отключено
2017-03-01 14:44:34,283 DEBUG es.programador.transport.a.d - Битность системы: [64]
2017-03-01 14:44:34,285 DEBUG es.programador.transport.a.d - Нативные файла находятся здесь:[/home/it/Загрузки/utm205/utm/updater/lib/x64_so]
2017-03-01 14:44:34,337 DEBUG es.programador.transport.a.d - Создавать PKCS11 файл:always
2017-03-01 14:44:34,339 DEBUG es.programador.transport.a.d - Загрузка нативных библиотек из папки: [/home/it/Загрузки/utm205/utm/updater/lib/x64_so]
2017-03-01 14:44:34,346 DEBUG es.programador.transport.updater.h - Для JNI будет использоваться библиотека [/opt/jacarta/lib_pkcs11_jni.so]
2017-03-01 14:44:34,347 DEBUG es.programador.transport.a.b - Инициализация PKCS11. Начало
2017-03-01 14:44:34,347 DEBUG es.programador.transport.a.b - PKCS11 файл настройек: [/home/it/Загрузки/utm205/utm/updater/lib/pkcs11.cfg]
2017-03-01 14:44:34,399 DEBUG es.programador.transport.a.b - PKCS11-библиотека:/opt/jacarta/libASEP11.so
2017-03-01 14:44:34,399 DEBUG es.programador.transport.a.b - Поиск номера слота смарт-карты (ЦентрИнформ)
2017-03-01 14:44:34,423 ERROR es.programador.transport.updater.h - Ошибка запуска системы обновления
java.lang.UnsatisfiedLinkError: /opt/jacarta/lib_pkcs11_jni.so.1.0.0: /opt/jacarta/lib_pkcs11_jni.so.1.0.0: неправильный класс ELF: ELFCLASS32 (Possible cause: architecture word width mismatch)
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1824)
        at java.lang.Runtime.load0(Runtime.java:809)
        at java.lang.System.load(System.java:1086)
        at java.lang.invoke.MethodHandleImpl$BindCaller$T/453211571.invoke_V(MethodHandleImpl.java:1258)
        at ru.centerinform.transporter.pki.jni.PKCS11JNI.<init>(Unknown Source)
        at es.programador.transport.a.b.j(Unknown Source)
        at es.programador.transport.a.b.b(Unknown Source)
        at es.programador.transport.updater.Main.a(Unknown Source)
        at es.programador.transport.updater.Main.main(Unknown Source)
2017-03-01 14:44:34,427 INFO  es.programador.transport.updater.h - Завершение работы (ShutdownHook)
2017-03-01 14:44:34,427 DEBUG es.programador.transport.updater.h - Остановка работы с RSA-криптографией
2017-03-01 15:59:20,705 INFO  es.programador.transport.updater.h - Запуск системы обновления
2017-03-01 15:59:24,113 INFO  es.programador.transport.updater.h - Updater version: [2.0.5b000240] changeset: [8db3d880b93f+]
2017-03-01 15:59:24,326 DEBUG es.programador.transport.a.d - Битность системы: [32]
2017-03-01 15:59:24,343 DEBUG es.programador.transport.a.d - Версия системы: [Linux]
2017-03-01 15:59:24,352 DEBUG es.programador.transport.a.d - Windows: [false]
2017-03-01 15:59:24,355 DEBUG es.programador.transport.a.d - Linux: [true]
2017-03-01 15:59:24,430 DEBUG es.programador.transport.updater.h - Для RSA будет использоваться библиотека [/opt/jacarta/libASEP11.so]
2017-03-01 15:59:24,446 ERROR es.programador.transport.updater.h - Ошибка запуска системы обновления
java.lang.IllegalStateException: File [/opt/jacarta/libASEP11.so] not exists
        at es.programador.transport.updater.Main.a(Unknown Source)
        at es.programador.transport.updater.Main.main(Unknown Source)
2017-03-01 15:59:24,485 INFO  es.programador.transport.updater.h - Завершение работы (ShutdownHook)
2017-03-01 15:59:24,489 DEBUG es.programador.transport.updater.h - Остановка работы с RSA-криптографией
01.03.2017 16:19
Captd
 
Ругается на файл libASEP11.so, хотя он есть в папке.


Опции темы


Часовой пояс GMT +3, время: 23:16.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.