[ОТВЕТИТЬ]
Опции темы
16.03.2016 18:53  
twix
Теперь уже совсем всё хорошо. Это значит, что nginx + php-fpm работают, а косяк всплывает где-то в коде. Скорее всего, не доставлены какие-нибудь расширения похапе.
Смотри логи, и ставь всякие php-mcrypt, php-mysql, и прочее...
 
"Спасибо" twix от:
16.03.2016 19:02  
aldemko
mysql и php-mysq разные вещи ?
а нет ли стандартного набора
что бы я потом под каждый сайт не искал что не хватает ?

yum install php-mysql
потом все перезапустил
и заработал сайт
спасибо
Завтра опять почитаю и пробовать буду на 5.6 php перевести с 5.3

Кстати - это мне остается хорошенько сделать один файл domen.conf
потом просто копировать менять названия сайтов и папки ?
ну почти так же легко как с панели получается

Последний раз редактировалось aldemko; 16.03.2016 в 19:05.
 
16.03.2016 19:11  
twix
Цитата:
Сообщение от aldemko
mysql и php-mysq разные вещи ?
mysql (и пакет mysql-server) - это СУБД и средства работы с ней. php-mysql - это расширение пыха для работы с mysql.

Цитата:
Сообщение от aldemko
а нет ли стандартного набора
что бы я потом под каждый сайт не искал что не хватает ?
Общий набор, как правило, совсем небольшой: php-mysql, php-pdo, php-mcrypt (бывает нужно всяким фреймворкам). Остальное - должно быть указано в доке по CMS/Framework'у. Изначально же php ставится совсем голым. Так что даже эту "базу" нужно доустанавливать.

Цитата:
Сообщение от aldemko
Завтра опять почитаю и пробовать буду на 5.6 php перевести с 5.3
А в чём сакральный смысл сего деяния?

Цитата:
Сообщение от aldemko
Кстати - это мне остается хорошенько сделать один файл domen.conf
потом просто копировать менять названия сайтов и папки ?
ну почти так же легко как с панели получается
Да, как-то так.


ЗЫЖ Перезапускать всё каждый раз смысла нет.
Если добавился новый сайт, или изменилась конфа существующего (например, rewrite'ы добавил/поправил в конфиге nginx), то рестартовать достаточно только nginx.
Если поставил/удалил расширение php, или поменял его конфиг, то рестартуешь только php-fpm.
 
"Спасибо" twix от:
17.03.2016 02:25  
aldemko
на 5.6 хочу потому что, когда у меня был хостинг - и там можно было с панельки выбирать версию php
производительность - по крайней мере отчет системы проверки производительности битрикса, показывал больше попугаев на 5.6 чем на 5.3
хотя это могут быть только сухие цифры - которые за частую могут браться лишь по баллам, оптимально не оптимально, работа HDD , CPU и прочих параметров все равно не меняется
 
17.03.2016 06:10  
aldemko
+ в рекомендациях по битриксу нашел следующее
Код:
Крайне рекомендуется наличие акселератора PHP (OPcache, XCache, APC и другого). Рекомендуется OPcache, входит в состав PHP v5.5+.
 
 


Опции темы



Часовой пояс GMT +3, время: 09:08.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.