Форум OlegON > Ресурсы OlegON > Вопросы сервера > Программы OlegON

Оптимайзер - 7 (вопросы и обсуждения) часть вторая

02.04.2020 20:18


28.08.2017 14:21
Stels
 
Код:
PostPort=465
PostSSL=1
PostTLS=1
Код:
PostPort=465
PostSSL=1
PostTLS=0
уходит


при
Код:
PostPort=587
PostSSL=1
PostTLS=1
и
Код:
PostPort=587
PostSSL=1
PostTLS=0
Ошибка и не уходит
Код:
28.08.17 14:18:37 --  :
OLEGON-ERROR! javax.mail.MessagingException: Could not connect to SMTP host: smtp.gmail.com, port: 58
7;   nested exception is:       javax.net.ssl.SSLException: Unrecognized SSL message, plaintext conne
ction?
28.08.2017 16:05
Propil
 
Да, письма не уходят.
Но разбираться пока нет времени..
28.08.2017 17:28
OlegON
 
Странная хрень в общем, почитал, большинство, видимо, тот же STARTTLS все равно использует и на других портах, поскольку SSL давно компрометирован, и v2 и v3... Разберусь...
29.08.2017 07:58
Stels
 
Надеюсь, хотя бы завтра снова не нужно будет менять настройки почтовика ...


вчера так работало ... сегодня опять нет ...
Код:
PostPort=465
PostTLS=1
и зачем-то
PostSSL=0
автоматом установилось
29.08.2017 08:17
Stels
 
вообщем, я в конец не понимаю ..

Напишите, пожалуйста, рабочие настройки для корректной работы отправки сообщений

(интересует вариант ящика gmail.com)
29.08.2017 08:54
OlegON
 
Не меняйте ничего, сейчас попробую подключить какой-нибудь gmail. Все остальные у меня пока работают без проблем. SSL снялось, поскольку его никто не должен использовать, он компрометирован. Если у кого-то еще не работает - сообщите, менять ничего не надо.
29.08.2017 10:09
OlegON
 
В общем, разобрался.
Смотрите,
Цитата:
Порт для SSL: 465
Порт для TLS/STARTTLS: 587
вот на 465 у всех почтовиков хз что. Как и на 25.
В большинстве случаев надо использовать 587 и отключать SSL. Мне, кажется, не удалось вообще ни одного SSL-сервака найти, собственно, писал выше, почему.

Сейчас, если PostAuto=1, то при указании штатных SMTP gmail, yandex и mailru перенастройка портов на правильные произойдет автоматом.

Если какие-то еще проблемы - пишите, не ломитесь сразу все менять.
16.09.2017 11:05
Diamondne
 
Последние два дня оптимизатор ругается следующим образом (специально включил дебаг 3):

16.09.17 10:58:26 -- Filter loaded
16.09.17 10:58:26 -- Message filter : 23
OLEGON-ERROR! 16.09.17 10:58:26 -- index rebuild : java.lang.IllegalArgumentException
16.09.17 10:58:26 -- Check invalid index subpartitions
16.09.17 10:58:26 -- Message filter : 23
OLEGON-ERROR! 16.09.17 10:58:26 -- index partition rebuild : java.lang.IllegalArgumentException
16.09.17 10:58:26 -- Try to get CheckDBAUsers value
16.09.17 10:58:26 -- Try to get DropInvPB value

и пишет об этом же на почту. До этого работал нормально. В на сервере ничего не менялось, БД перезапускал, обновил яву, попробовал создать запустить задание "Полное пересоздание индексов" из СМ - тот же результат.
ОС 3.8.13-26.2.3.el6uek.x86_64
Oracle 11.2.0.3 +ASM
java version "1.8.0_144"
Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
16.09.2017 12:33
OlegON
 
Побили что-то в окружении, наверное. Предлагаю оставить только optimizer.ini и optimizer.jar, остальное все стереть. Если не поможет - потереть и optimizer.ini
17.09.2017 19:37
Diamondne
 
Цитата:
OlegON Побили что-то в окружении, наверное. Предлагаю оставить только optimizer.ini и optimizer.jar, остальное все стереть. Если не поможет - потереть и optimizer.ini
Проблема скрывалась в редакторе nano. Беру рабочий optimizer.ini, открываю его в nano и меняю несколько параметров (наглядно получилось на параметре MemoryLimit), сохраняю, запускаю и в момент, когда оптимайзер загоняет новые параметры памяти - валит эти ошибки. Снова беру исходный optimizer.ini, открываю в mcedit или vim, меняю тоже самое и ошибок не возникает.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.