[ОТВЕТИТЬ]
Опции темы
14.09.2016 14:56  
skier2
6.09 обновили УКМ. Обновление прошло с зихером - сперва обновили УКМ сервер, а потом вспомнили, что сперва по книжке надо было залить дистрибутивы на кассы, а уж потом обновлять сервер. Залили дистрибутивы в ручную и довершили обновление. Все заработало. Работало 2 дня. на третий день одна касса ушла в "ОТКАЗ" - на сервере ОФФ-лайн, что делать непонятно - ее пока в сторону. Вторая на пятый день перезагрузилась - и пишет при загрузке - ПОИСК сервера (включен режим ожидания репликации). Недолго думая, переставили УКМ на кассе - теперь, получаем при включении ту же запись, а при просмотре логов видим:
14:22:21: 0x00020008: INFO: Connector to server#0e704768: started
14:22:21: 0x00020008: INFO: NTLP#0e6d31e8: Socket 15 connected to 192.168.6.225: new channel 242242776 created
14:22:22: 0x00020008: FATAL: LOGIN: Версия новой кассы из канала 115452560 (72) не совпадает с версией сервера (71 Service Pack 1)

Смотрим в сервер - там версия 72 сп1, лицензия от нее же.

Вопрос: как исправить ситуацию? что посмотреть?
 
14.09.2016 15:08  
$piritu$
Возьмите дистрибутив 72 версии. Установите только "комплект установки линукса на кассе" (примерно так называется), потом залейте флешку со свежим установщиком (instmedia).
 
14.09.2016 15:12  
skier2
имеется ввиду - переустановить кассу? а разве не сервер некорректно обновился? на это мысль наводит строка "Версия новой кассы из канала 115452560 (72) не совпадает с версией сервера (71 Service Pack 1)"
 
14.09.2016 15:18  
$piritu$
Получается сервер не обновился? Как вариант делаете бэкап, перестанавливаете УКМ и восстанавливайте из бэкапа. Но нужно быть уверенным что база 72 версии.
 
14.09.2016 15:21  
skier2
как это проверить?
на сервере читаем:


КОЛИЧЕСТВО ТЕРМИНАЛОВ: 3
вЕРСИЯ ЛИЦЕНЗИИ: 72
ТЕКУЩАЯ ВЕРСИЯ ПРОГРАММЫ: 72001
ВЕРСИЯ УСТАНОВЛЕНА: 06.09.2016
 
14.09.2016 15:32  
$piritu$
Думаю что не работало бы, если версия базы отличалась... Банально пробовали службы перезапустить? Может глюк какой? В логах сервера нет ошибок? Логи MYSQL посмотрите.
 
14.09.2016 16:00  
skier2
можно ли сейчас попробовать переобновить сервер УКМ? может надо его просто попробовать "догнать" до нужной версии? кстати, перезапуск службы не помог
 
14.09.2016 21:05  
Никита
первый вариант
1. посмотри на кассе есть ли файлы для обновления ukmclient/upman по моему так (нет кассы под рукой)
2. если есть то запусти в директории выше ukmupman
второй вариант
1. зайти на веб морде сервера в кассы - обновление включен ли автообновление
2. зайти на кассу (нажать на имя терминала в той менюшки) и нажать старт
третий вариант
1. если файлов нету на кассе и на сервере, то можно закинуть update от 72 версии и все нужные паки на сервер
2. обновиться снова (серверная часть не обновится, а файлы для касс упадут туда куда надо)
3. проделать все из первого или второго варианта
четвертый вариант
1. перенакатить кассу с загрузочной флешки сервера
 
15.09.2016 08:17  
skier2
разобрались....до этого принесли сервер другого магазина, включили его в общую сеть, причем подсеть у него была совсем другая - чтобы никому не мешал... и почему кассы решили, что он им более подходит, чем тот, который был ранее? прописали конкретный адрес сервера в ukmclient\pc.ukm - все ожило... все рады и довольны! вот бы в школе учили (вместо чего нибудь) выводы правильные делать на основании исходных данных - знал же, что именно тот сервер сидит на 71укм.... вывод - при формировании дистрибутива для УКМ-кассы ОБЯЗАТЕЛЬНО прописывать адрес сервера... так, на всякий случай...
 
 
Опции темы



Часовой пояс GMT +3, время: 19:16.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.