Форум по программам и оборудованию > >

Mikrotik. Блокировка доступа к потоковому видео

23.09.2018 23:03


19.01.2017 07:40
OlegON
 
Собственно, начали тему здесь, но суть вопроса в заголовке.

У меня как-то и идей нет... Можно ли оставить нормальную скорость на вебе, но зарезать видео? Частоту запросов резать? Сделал queue для ограничения скорости - ругаются, что сайты медленно работают...
19.01.2017 08:24
Micle
 
только если различать трафик по какому то признаку и отправлять в разные queue
19.01.2017 08:57
OlegON
 
Может и хорошая идея, но в том и суть - как? Упростим задачу. Есть конкретный IP, как выделить или запретить ему потоковое видео с любого источника? Если закачка файлов ляжет - пофик... Но сайты должны работать. А как потоковое выделить, отделить, например, от сайта с картинками?
20.01.2017 09:21
OlegON
 
Жесть, лимит по каналу не работает... Т.е. труба, например, работает для особо терпеливых на той скорости, когда сайты уже начинают визуально тормозить. В HTTPS не залезешь, в DNS все сайты не запихнешь и у гугла они совмещаются... Все, нет решения?
21.01.2017 18:48
OlegON
 
пока не нашел ничего лучше
Код:
/ip firewall filter
add action=add-src-to-address-list address-list=download address-list-timeout=1h chain=forward connection-bytes=52428800-0 dst-address-list=baddev
/ip firewall mangle
add action=mark-packet chain=prerouting dst-address-list=baddev new-packet-mark=download passthrough=yes src-address-list=download
/queue
add max-limit=256k/256k name=Download packet-marks=download queue=default/default total-queue=default
в расшифровке, если baddev потащат больше 50Мб за соединение, то источник будет засунут в лимит 256к на час для этих же baddev
Интересует мнение других, насколько это работоспособное решение. Смущает, что некоторые соединения бывают persistent или как их, т.е. обычная HTTPS-сессия будет все тащить в один коннект, пока не оборвется.
23.01.2017 08:22
Micle
 
http 1.1 через 1 соединение несколько запросов шлёт последовательно
23.01.2017 09:16
OlegON
 
Вот я про такие случаи и говорю. Это хоть не шифрованное. А как быть админу сети? Он теперь ничего сделать не может? Вариант с установкой доверяющего сертификата на клиенте может не подходить по массе условий...
23.01.2017 09:35
Micle
 
Сам в том же "положении" сейчас. Вариант с перехватом https не работает в ряде случаев, устав бороться снёс всё к чертям, поставил считалку по IP адресам, пользакам напомнил, что видео и музыку нужно/можно с флешки. Особо не понятливых перевожу на шейпер 256|512 килобит (чаще всего безвозвратно).
23.01.2017 09:45
OlegON
 
У меня задача хуже. Качать можно, канал поделен. Нельзя развлекаловку допустить, т.е. просмотр видео.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.