01.06.2017 18:46
KirillHome
 
При включении синхронизации БП 3.0 (к примеру с ЗУП 3.0) - автоматически проставляются и не могут быть "простым путём" сняты следующие функциональные опции в БП 3.0:
  • - Учет по договорам;
  • - Расчёты в валюте и у.е;
  • - Платёжные карты;
  • - Спецодежда и спецоснастка;
  • - Возвратная тара;
  • - Импортные товары;
  • - Комплектация номенклатуры;
  • - Розничная торговля;
  • - Комиссия на закупку;
  • - Комиссия на продажу;
  • - Отгрузка без перехода прав собственности;
  • - Управление зачётом авансов и погашение задолженности;
  • - Исправительные и корректировочные документы;
  • - Фискальный регистратор;
  • - Инкассация;
  • - Алкогольная продукция;
При этом данный список оформлен в БП просто как текст (то есть на самом деле перечень функциональных опций может быть больше или меньше).

Проверил.
Снял "птичку" с "Синхронизация данных", настроил функциональность (убрав лишнее).
Всё хорошо.
Ставлю "птичку" на "Синхронизации" - всё, функциональность снова включила "лишние пункты".



Но - с этим можно бороться "другим образом" - через "Все функции" - "Константы"
Попробую расписать по пунктам (по указанным в перечне функциональным опциям):
  • - Учет по договорам;
    Константа "Вести учет по договорам"
  • - Расчёты в валюте и у.е;
    Константа "Использовать валютный учет"
  • - Платёжные карты;
    Константа "Использовать оплату по продажным картам"
  • - Спецодежда и спецоснастка;
    Константа "Ведется учет спецодежды спецоснастки"
  • - Возвратная тара;
    Константа "Ведется учет возвратной тары"
  • - Импортные товары;
    Константа "Ведется учет импортных товаров"
  • - Комплектация номенклатуры;
    Константа "Использовать комплектацию номенклатуры"
  • - Розничная торговля;
    Константа "Ведется розничная торговля"
  • - Комиссия на закупку;
  • - Комиссия на продажу;
    На самом деле это четыре функциональных опции:
    • - Продажа товаров или услуг комитентов (принципалов)
    • Константа "Осуществляется реализация товаров и услуг комитентов"
    • - Продажа товаров или услуг через комиссионеров (агентов)
    • Константа "Осуществляется реализация товаров и услуг через комиссионеров"
    • - Приобретение товаров или услуг для комитентов (принципалов)
    • Константа "Осуществляется закупка товаров и услуг комитентов"
    • - Приобретение товаров или услуг через комиссионеров (агентов)
    • Константа "Осуществляется закупка товаров и услуг через комиссионеров"
  • - Отгрузка без перехода прав собственности;
    Константа "Передача неисключительных (ограниченных) прав"
  • - Управление зачётом авансов и погашение задолженности;
    Константа "Управление зачетом авансов и погашением задолженности"
  • - Исправительные и корректировочные документы;
    Константа "Использовать корректировочные документы"
  • - Фискальный регистратор;
    Константа "Использовать фискальный регистратор"
  • - Инкассация;
    Константа "Использовать инкассацию"
  • - Алкогольная продукция;
    Константа "Продажи алкогольной продукции"


Для чего это сделано так "странно"? Думаю, для того, что бы не делить на синхронизацию БП с ЗУП и другими программами (где эти опции могут быть задействованы).

Таким образом я смог у себя отключить часть ненужных мне функциональных опций (комиссионеров, комитентов, алкоголь, импортный товар, комплектация, тара, спецодежда, расчёты в валюте, отгрузка без перехода прав собственности, Исправительные и корректировочные документы), понимая при этом, что у меня сихронизация только с ЗУП. В случае синхронизации с другими программами (УТ 11, к примеру) - сами смотрите, решайте.


Вообще, на текущий момент, такой текст в модуле менеджера обработки "Функциональность программы":


Код:
#Область ВернутьМассивИменКонстант

// Формирует массив имен констант используемых для управления функциональностью
//
Функция МассивИменКонстантФункциональности() Экспорт
	
	МассивИменКонстант = Новый Массив;
	МассивИменКонстант.Добавить("ВедетсяУчетНМА");
	МассивИменКонстант.Добавить("ВедетсяУчетОсновныхСредств");
	МассивИменКонстант.Добавить("ВедетсяУчетСпецодеждыСпецоснастки");
	МассивИменКонстант.Добавить("ВедетсяОтгрузкаБезПереходаПраваСобственности");
	МассивИменКонстант.Добавить("ИспользоватьКомплектациюНоменклатуры");
	МассивИменКонстант.Добавить("ИспользоватьОплатуПоПлатежнымКартам");
	МассивИменКонстант.Добавить("ВедетсяУчетДенежныхДокументов");
	МассивИменКонстант.Добавить("ВедетсяПроизводственнаяДеятельность");
	МассивИменКонстант.Добавить("ОсуществляетсяРеализацияТоваровУслугКомитентов");
	МассивИменКонстант.Добавить("ОсуществляетсяРеализацияТоваровУслугЧерезКомиссионеров");
	МассивИменКонстант.Добавить("ОсуществляетсяЗакупкаТоваровУслугДляКомитентов");
	МассивИменКонстант.Добавить("ОсуществляетсяЗакупкаТоваровУслугЧерезКомиссионеров");
	МассивИменКонстант.Добавить("ВедетсяРозничнаяТорговля");
	МассивИменКонстант.Добавить("ВедетсяУчетВозвратнойТары");
	МассивИменКонстант.Добавить("ВедетсяУчетИмпортныхТоваров");
	МассивИменКонстант.Добавить("ИспользоватьВалютныйУчет");
	МассивИменКонстант.Добавить("ИспользоватьПакетноеВыставлениеАктов");
	МассивИменКонстант.Добавить("ИспользоватьПлатежныеТребования");
	МассивИменКонстант.Добавить("УправлениеЗачетомАвансовПогашениемЗадолженности");
	МассивИменКонстант.Добавить("ВедетсяУчетРозничнойПродажиАлкогольнойПродукцииПива");
	МассивИменКонстант.Добавить("ИспользоватьКорректировочныеДокументы");
	МассивИменКонстант.Добавить("ИспользоватьФискальныйРегистратор");
	МассивИменКонстант.Добавить("ИспользоватьПередачуПрав");
	МассивИменКонстант.Добавить("ИспользуютсяПодарочныеСертификаты");
	МассивИменКонстант.Добавить("ИспользоватьИнкассацию");
	МассивИменКонстант.Добавить("ИспользоватьДоставкуАвтотранспортом");
	МассивИменКонстант.Добавить("ВестиУчетПоДоговорам");
	МассивИменКонстант.Добавить("ИсполняютсяОбязанностиНалоговогоАгентаПоНДС");
	МассивИменКонстант.Добавить("ИспользоватьПланированиеПлатежейПоставщикам");
	МассивИменКонстант.Добавить("ИспользоватьПланированиеПлатежейОтПокупателей");
	МассивИменКонстант.Добавить("ВедетсяУчетТаможенныхДекларацийЭкспорт");
	МассивИменКонстант.Добавить("ЗагрузкаДанныхИзТиС");
	МассивИменКонстант.Добавить("ВестиУчетМаркировкиПродукцииВГИСМ");
	
	Если ПолучитьФункциональнуюОпцию("ВестиУчетПоПодразделениям") Тогда
		МассивИменКонстант.Добавить("ИспользоватьУведомленияОКонтролируемыхСделках");
		МассивИменКонстант.Добавить("ИспользуетсяГособоронзаказ");
	КонецЕсли;
	
	Возврат МассивИменКонстант;
	
КонецФункции

// Возвращает имена констант из переданного массива, у которых значение Истина
Функция МассивИспользуемыхКонстант(МассивИменКонстант)
	
	СтрокаИменКонстант = СтрСоединить(МассивИменКонстант, ",");
	
	НаборКонстант = Константы.СоздатьНабор(СтрокаИменКонстант);
	НаборКонстант.Прочитать();
	
	МассивИспользуемыхКонстант = Новый Массив;
	
	Для Каждого ИмяКонстанты Из МассивИменКонстант Цикл
		Если НаборКонстант[ИмяКонстанты] = Истина Тогда
			МассивИспользуемыхКонстант.Добавить(ИмяКонстанты);
		КонецЕсли;
	КонецЦикла;
	
	Возврат МассивИспользуемыхКонстант;
	
КонецФункции

// Возвращает имена констант, участвующие в обменах
Функция МассивИменКонстантФункциональностиДляОбменов();
	
	МассивИменКонстант = Новый Массив;
	МассивИменКонстант.Добавить("ВедетсяУчетСпецодеждыСпецоснастки");
	МассивИменКонстант.Добавить("ВедетсяОтгрузкаБезПереходаПраваСобственности");
	МассивИменКонстант.Добавить("ИспользоватьКомплектациюНоменклатуры");
	МассивИменКонстант.Добавить("ОсуществляетсяРеализацияТоваровУслугКомитентов");
	МассивИменКонстант.Добавить("ОсуществляетсяРеализацияТоваровУслугЧерезКомиссионеров");
	МассивИменКонстант.Добавить("ОсуществляетсяЗакупкаТоваровУслугДляКомитентов");
	МассивИменКонстант.Добавить("ОсуществляетсяЗакупкаТоваровУслугЧерезКомиссионеров");
	МассивИменКонстант.Добавить("ВедетсяРозничнаяТорговля");
	МассивИменКонстант.Добавить("ВедетсяУчетВозвратнойТары");
	МассивИменКонстант.Добавить("ВедетсяУчетИмпортныхТоваров");
	МассивИменКонстант.Добавить("ИспользоватьВалютныйУчет");
	МассивИменКонстант.Добавить("УправлениеЗачетомАвансовПогашениемЗадолженности");
	МассивИменКонстант.Добавить("ИспользоватьОплатуПоПлатежнымКартам");
	МассивИменКонстант.Добавить("ВестиУчетПоДоговорам");
	МассивИменКонстант.Добавить("ИсполняютсяОбязанностиНалоговогоАгентаПоНДС");
	МассивИменКонстант.Добавить("ВедетсяУчетРозничнойПродажиАлкогольнойПродукцииПива");
	
	Возврат МассивИменКонстант;
	
КонецФункции

// Возвращает имена констант, зависимых от переданной
Функция МассивИменЗависимыхКонстант(ИмяКонстанты) Экспорт;
	
	МассивИменКонстант = Новый Массив;
	
	Если ИмяКонстанты = "ВедетсяРозничнаяТорговля" Тогда
		
		МассивИменКонстант.Добавить("ВедетсяУчетРозничнойПродажиАлкогольнойПродукцииПива");
		МассивИменКонстант.Добавить("ИспользуютсяПодарочныеСертификаты");
		
	ИначеЕсли ИмяКонстанты = "ВестиУчетПоДоговорам" Тогда
		
		МассивИменКонстант.Добавить("ИспользоватьВалютныйУчет");
		МассивИменКонстант.Добавить("ИсполняютсяОбязанностиНалоговогоАгентаПоНДС");
		
	КонецЕсли;
	
	Возврат МассивИменКонстант;
	
КонецФункции

#КонецОбласти
02.06.2017 11:06
Fomka
 
Такую же ситуацию испытал при штатной синхронизации БП 3.0 и Розница 2.2. С УТ11 думаю та же история будет.
02.06.2017 14:17
KirillHome
 
Цитата:
Fomka Такую же ситуацию испытал при штатной синхронизации БП 3.0 и Розница 2.2. С УТ11 думаю та же история будет.
Ну да, ты в бухгалтерии можешь "по глупости" закрыть функциональность, которая нужна в торговле. Вот они и перестраховались - любая синхронизация "включает всё".

Но у меня то ЗУП 3.1
Там то этого точно ничего нет

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.