[ОТВЕТИТЬ]
Опции темы
27.03.2008 16:23  
Mihon
Без проблем! находишь через яндекс модуль "rapi",
ставишь в uses. и все.
Код:
procedure TForm1.UploadButtonClick(Sender: TObject);
var
  sTemplate:TStringList;
  HDes:THandle;
  o1:Poverlapped;
  BytesWritten:DWORD;
  inttemp:longint;
begin
  sTemplate:=TStringList.Create;
  sTemplate.LoadFromFile('scanin.dat');
  cerapiinit;
  HDes := CeCreateFile ('\FLASH\scanin.dat',Generic_Write,File_Share_Write,nil,Create_Always,0,0);
  CEWriteFile(HDes,PChar(sTemplate.Text),Length(sTemplate.Text),BytesWritten,@o1);
  CECloseHandle(HDes);
  CERapiUninit;
  if BytesWritten>0 then messagedlg('Загрузка терминала успешно завершена',mtInformation,[mbok],0) else
    messagedlg('Не удалось загрузить терминал',mtError,[mbok],0);
end;
Единственный трабл - может не скопировать в память устроцства. на флэш диск без проблем.

Еще вариант - CETools, тока дениг стоит, крякнутый у китайцев на сайте лежит - . Тока там зарегиться надо. Я целый день гадал че иероглифы значат))))))))
 
10.04.2008 16:33  
саша
Спасибо попробую...
 
17.02.2016 22:56  
KirillHome
Подниму тему.
Есть текстовый файл, который готовит 1с.
Задача - передать этот текстовый файл на ТСД.

1с через ДиалогВыбораФайла в принципе видит этот путь, но не может выбрать.
Код:
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Если Диалог.Выбрать() Тогда
	Сообщить(Диалог.ПолноеИмяФайла);
    	Элемент = Диалог.ПолноеИмяФайла;
Иначе
	Сообщить("Файл не выбран");
КонецЕсли;
Результат - файл не выбран.

Подумалось, что как-то через WScript (наверное?) это можно сделать.
Но как?
Есть мысли, предложения?
 
18.02.2016 08:46  
student
Цитата:
Сообщение от KirillHome
1с через ДиалогВыбораФайла в принципе видит этот путь, но не может выбрать.
а с правами доступа на каталог/файл все в порядке ?
 
18.02.2016 08:50  
KirillHome
Цитата:
Сообщение от student
а с правами доступа на каталог/файл все в порядке ?
Да, так как через проводник Windows я прекрасно могу положить туда файл.

Проблема именно в "пути к КПК", т.к. это не
ИмяДиска:\ИмяКаталога\ИмяФайла
\\ИмяШары\ИмяКаталога\ИмяФайла

а что-то другое.
 
18.02.2016 09:01  
student
Цитата:
Сообщение от KirillHome
Да, так как через проводник Windows я прекрасно могу положить туда файл.
часто бывает что прав на "положить" недостаточно :)

и если бы дело было в пути то 1с-ка я думаю врядли бы вообще туда добралась посмотреть - она штатные апишки юзает как и проводник

Последний раз редактировалось student; 18.02.2016 в 09:04.
 
18.02.2016 09:30  
KirillHome
Во всяком случае элементарный (из учебника) пример

Код:
// Выбор файла с просмотром
ДиалогФыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ДиалогФыбораФайла.Фильтр = "Картинка (*.bmp)|*.bmp|Картинка формата jpg (*.jpg)|*.jpg"; 
ДиалогФыбораФайла.Заголовок = "Выберите файл";
ДиалогФыбораФайла.ПредварительныйПросмотр = Истина;
ДиалогФыбораФайла.ИндексФильтра = 0;
Если ДиалогФыбораФайла.Выбрать() Тогда
Сообщить(ДиалогФыбораФайла.ПолноеИмяФайла);
КонецЕсли;
не выбирает ни разу.

Пробую выбрать каталог
Код:
	// Выбор каталога
	ДиалогФыбораКаталога = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
	ДиалогФыбораКаталога.Каталог = "";
	ДиалогФыбораКаталога.МножественныйВыбор = Ложь; 
	ДиалогФыбораКаталога.Заголовок = "Выберите каталог";
	Если ДиалогФыбораКаталога.Выбрать() Тогда
		Сообщить(ДиалогФыбораКаталога.Каталог);
	Иначе
		Сообщить("Каталог не выбран");
	КонецЕсли;
При переходе "в устройство" даже не показывает каталоги (см. вложение). При попытке всё же выбрать папку - говорит об ошибке "Недопустимое имя папки". (см. вложение №2)

В общем - дело не в правах, это точно.

Для памяти - оставлю запрос в гугл, по которому хоть что-то находил (но все в основном отсылают к RAPI).
Миниатюры
Нажмите на изображение для увеличения
Название: Выбор каталога.jpg
Просмотров: 153
Размер:	85.3 Кб
ID:	7001   Нажмите на изображение для увеличения
Название: Выбор папки - ошибка.jpg
Просмотров: 133
Размер:	94.7 Кб
ID:	7002  

Последний раз редактировалось KirillHome; 18.02.2016 в 09:44.
 
18.02.2016 10:03  
student
Цитата:
Сообщение от KirillHome
В общем - дело не в правах, это точно.
тогда только через активсинг - поищи "агент плюс" у него были фри версии служб обмена для 1с-ок

либо через рапитулз (не помню откуда но лежит давно :) - см аттач)
там есть уже собранные экзешники
=====
pps - dumps active wince processes
pdblist - dumps wince databases
pdel - delete wince file
pdir - list wince directory
pmkdir - create wince directory
pget - copy file from wince
pkill - kill wince process
pmemdump - copy memory block from wince
psetmem - set RAM memory location in your device
pmemmap - list available memory blocks on wince
pput - copy file to wince
pregutl - manipulate the wince registry
regutl - manipulate the win32 registry
prun - run program in wince
dump - hexdump local file.
pdebug - capture debugoutput of processes
pdocread - raw read of m-systems DiskOnChip devices
psdread - raw read from sd card in your device
psdwrite - raw write to the sd card in your device
pnewbmp - write new bootsplash bitmap to rom
pnewbootloader - replace your bootloader
psynctime - sync time with pc.
Вложения
Тип файла: zip itsutils.zip (1.43 Мб, 38 просмотров)
 
"Спасибо" student от:
18.02.2016 10:06  
KirillHome
Я думал найти "общее решение" - для Windows CE, для Android, для Windows Phone и т.д.
Похоже, что зря я на это надеялся :)
 
18.02.2016 10:09  
student
Цитата:
Сообщение от KirillHome
Я думал найти "общее решение" - для Windows CE, для Android, для Windows Phone и т.д.
Похоже, что зря я на это надеялся :)
почему ?
если есть вифи то попробовать можно через него :) оно универсально для всех перечисленных
 
 


Опции темы



Часовой пояс GMT +3, время: 20:47.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.