[ТЕМА ЗАКРЫТА]
Опции темы
10.06.2010 16:14  
Dim
offtopic: с этим можно поспорить, конечно. принимать товар мы должны по ставке из счет-фактуры поставщика (иначе ситуация - поставщик отписывает по 10%, а мы возмещаем по 18%. можно, конечно, с налоговой и поспорить, но это займет время), а продавать так, как считаем правильным.
 
10.06.2010 17:35  
Mtirt
Принимать товар мы должны по правильной ставке, соответствующей товару.
А что там думает поставщик...
У меня бывали ситуации, когда два разных поставщика на один и тот же товар ставили разные ставки НДС.
В таком случае твой пример работает плохо...
Ну и в приведенном тобой примере остатки по ставкам НДС в бухгалтерии и в Супермаге разъезжаются в разные стороны.
 
10.06.2010 18:05  
Dim
ок... приходит СФ от поставщика со ставкой 10%. ты считаешь, что должно быть 18%. приходуешь, ставишь на возмещение 18%. распечатываешь Книгу покупок. потом приходит налоговая и придирается к 2-м вещам - как я уже говорил, что возмещается НДС больше, чем было уплачено, и несоответствие книги покупок первичке.

Налоговый кодекс, ст.171, п.5
Цитата:
Вычетам подлежат суммы налога, предъявленные продавцом покупателю и уплаченные продавцом в бюджет при реализации товаров...
 
11.06.2010 06:45  
Mtirt
Ты не прав. Я ставлю возмещение 10%(в приходной накладной есть поле ставка НДС), но приходую на карточку товара со ставкой 18%.
И отражаю все операции с этим товаром, как с товаром по ставке НДС 18%.
 
11.06.2010 06:52  
Dim
ну мы делаем аналогично. я это к тому, что при выгрузке ПН необходимо в сценарии экспорта указывать Ставка НДС из док-та, чтобы выгрузилось со ставкой 10%
 
11.06.2010 06:58  
Mtirt
НЕТ!
При выгрузке приходной накладной, надо указать карточку "Товар с НДС 18%" и в документе поставить ставку НДС 10%.
Это если учет идет по ставкам НДС.
Иначе - каша в учете.
 
11.06.2010 07:05  
Dim
неправ. согласен. причем именно так и делал - выгружал на правильную номенклатура, а ставку ставил из документа))
 
11.06.2010 07:09  
Mtirt
А правильность номенклатуры определяется как раз по налоговой группе товара :)
Как раз то, что ты в самом начале и написал...
 
18.06.2010 11:30  
PavelGS
Я делаю так:

Подключаюсь к БД из 1С:
Код:
//*******************************************
//            Подключение к БД             //
//*******************************************

Процедура ИнициализацияАДО()
	Если фЕстьСоединение=1 Тогда
		Возврат;
	КонецЕсли;
	Соединение=СоздатьОбъект("ADODB.Connection");
    НаборЗаписей=СоздатьОбъект("ADODB.Recordset");  //driver={Microsoft driver для Oracle};
	НаборЗаписей1=СоздатьОбъект("ADODB.Recordset");
	Соединение.ConnectionString="DSN=Oracle; uid=supermag;pwd=ПАРОЛЬ;";
	Соединение.ConnectionTimeout = 600;
	Соединение.CursorLocation= 3; 
	Попытка
		Соединение.Open();  
	Исключение
		Сообщить("Ошибка при инициализации АДО: "+ОписаниеОшибки()); 
		фЕстьСоединение=1;
		Возврат;
	КонецПопытки; 	
	
	фЕстьСоединение=1;
КонецПроцедуры
Делаю запрос, потом создаю документы....
Код:
//*******************************************
//  Создание документа поступление товаров //
//*******************************************
		
		Если Док.НайтиПоНомеру(пНомерДок,пДатаДок)=0 Тогда //новый
			Док.Новый();
		Иначе  //старый 
			Если фЗамена=1 Тогда
				Док.УдалитьСтроки(); 
				Док.Комментарий="";
				Док.ДатаДок=0;
				Док.Контрагент		=0;       
				Док.Договор			=0;
				Док.МестоХранения	=0;
				Док.Сч41_1			=0;  
				Док.НДСвключатьВСтоимость=0; 
				Док.НомерДокВходящий="";
				Док.ДатаДокВходящий="";
			Иначе          
				НаборЗаписей.MoveNext();
			    Продолжить;
			КонецЕсли;
		КонецЕсли;               
		
		н=н+1;
		
		Док.НомерДок		=	пНомерДок; 
		Док.ДатаДок			=	пДатаДок;
		Док.Контрагент		=	пКонтрагент; 
		Если ПустоеЗначение(пКонтрагент)=0 Тогда
			Док.Договор			=	пКонтрагент.ОсновнойДоговор;
		КонецЕсли;
        	Если  Строка(ТблМХ.каСМ) = "1938" Тогда
		Док.МестоХранения	=	МХСкладПроизводства; 
	КонецЕсли;    
	    	Если  Строка(ТблМХ.каСМ) = "2339" Тогда
		Док.МестоХранения	=	МХСкладПроизводстваТ; 
	КонецЕсли;    
	
		Док.Сч41_1			=	СчетПоКоду(ТблМХ.сч);
		Док.НДСвключатьВСтоимость=1;    
		Док.НомерДокВходящий=пНомерПоставщика;
		Док.ДатаДокВходящий=пДатаДок;  
		Док.АвторБухгалтер =""+ИмяПользователя()+" "+ТекущаяДата()+" "+ТекущееВремя();		
		Док.АвторОператор	=	пПользователь;
		Док.НоваяСтрока();
		Док.Товар		=	ВыбТовар;   
		
		Док.Количество	=	1;
		Док.Цена		=	пСумма;
		Док.Сумма		=	пСумма;
		Док.Всего		=	пСумма;  
		
		Док.ТСчет		=	СчетПоКоду(ТблМХ.сч);
		         
		попытка
			Док.Записать();
			Сообщить("Поступление товаров №"+пНомерДок+" от "+пДатаДок+": документ записан");
			ЗаписьЖурналаРегистрации("Документ записан обработкой Загрузка документов","Документ","Записан",Док.ТекущийДокумент(),2);
		Исключение
			Сообщить("Поступление товаров №"+пНомерДок+" от "+пДатаДок+": ошибка при записи: "+ОписаниеОшибки())
		КонецПопытки; 
		
		// Производство /////////////////////////////////////////////////
		Если  Строка(ТблМХ.каСМ) = "1938" Тогда
		 //Создание документа счет-фактура полученный
                Если ДокС.НайтиПоНомеру(пНомерДок,пДатаДок)=0 Тогда //новый
                        ДокС.Новый();
                Иначе  //старый 
                        Если фЗамена=1 Тогда
                                ДокС.УдалитьСтроки(); 
                                ДокС.ДатаНомерСчетаФактуры  =0;
                                ДокС.ДокументОприходования  =0;
                                ДокС.ДатаОприходования      =0;
                                ДокС.Субсчет19              =0;
                                ДокС.Контрагент             =0;
                                ДокС.Счет                   =0;
                                ДокС.Субконто1              =0;
                                ДокС.Субконто3              =0;
                                ДокС.Субконто3              =0;
                                ДокС.Всего                  =0;
                                ДокС.СуммаБезНДС20          =0;
                                ДокС.СуммаБезНДС10          =0;
                                ДокС.НДС20                      =0;
                                ДокС.НДС10                      =0;
                                ДокС.СуммаСовсемБезНДС      =0;
                                ДокС.Договор                =0;
                                ДокС.Курс                   =0;
                                ДокС.Сторно41               =0;
                                ДокС.АвторБухгалтер ="";
                                
                                
                                
                        Иначе          
                                НаборЗаписей.MoveNext();
                                Продолжить;
                        КонецЕсли;
                КонецЕсли;  
                
                
                ДокС.НомерДок   =       пНомерДок;
                ДокС.ДатаДок    =       пДатаДок;  
                ДокС.ФормироватьПроводки=1;
                ДокС.Комментарий="Авто";
                
                ДокС.ДатаНомерСчетаФактуры  =   ""+пДатаСчетФактураПоставщика+" №"+пСчетФактураПоставщика;
                ДокС.ДокументОприходования  =   Док.ТекущийДокумент();
                ДокС.ДатаОприходования      =   пДатаДок;
                ДокС.Субсчет19              =   СчетПокоду("19.3");
                ДокС.Контрагент             =   пКонтрагент;
                ДокС.Счет                   =    СчетПоКоду("60.1");
                ДокС.НазначитьТип("Субконто1","Справочник.Контрагенты");
                ДокС.Субконто1              =   пКонтрагент; 
                ДокС.НазначитьТип("Субконто2","Справочник.Договоры");
                
                Если ПустоеЗначение(пКонтрагент)=0 Тогда
                        ДокС.Субконто2              =   пКонтрагент.ОсновнойДоговор; 
                        ДокС.Договор                =пКонтрагент.ОсновнойДоговор;
                КонецЕсли;
                
                ДокС.Субконто3              =0;
                ДокС.Всего                  =пСумма;
                ДокС.НДС20                      =пНДС18;
                ДокС.НДС10                  =пНДС10;
                
                ДокС.СуммаБезНДС20      =       Окр(ДокС.НДС20*118/18,2)-ДокС.НДС20;      
                ДокС.СуммаБезНДС10      =       Окр(ДокС.НДС10*110/10,2)-ДокС.НДС10;            
                
                пРасчСумма      =       ДокС.НДС20      +       ДокС.НДС10      +       ДокС.СуммаБезНДС20      +       ДокС.СуммаБезНДС10      +       ДокС.СуммаСовсемБезНДС; 
                пРазница        =       пСумма-пРасчСумма;     
                
                Если мод(пРазница)<1 Тогда
                        Если            ДокС.СуммаБезНДС20>0 Тогда
                                ДокС.СуммаБезНДС20      =       ДокС.СуммаБезНДС20      +       пРазница;               
                        ИначеЕсли       ДокС.СуммаБезНДС10>0 Тогда  
                                ДокС.СуммаБезНДС10      =       ДокС.СуммаБезНДС10      +       пРазница;       
                        КонецЕсли;
                КонецЕсли;
                
                
                
                ДокС.СуммаСовсемБезНДС      =0;
                
                ДокС.Курс                   =1;
                ДокС.Сторно41               =1;
                ДокС.АвторБухгалтер =""+ИмяПользователя()+" "+ТекущаяДата()+" "+ТекущееВремя();
                
                попытка
                        ДокС.Записать();
                        Сообщить("Счет фактура №"+пНомерДок+" от "+пДатаДок+": документ записан");
                        ЗаписьЖурналаРегистрации("Документ записан обработкой Загрузка документов","Документ","Записан",Док.ТекущийДокумент(),2);
                Исключение
                        Сообщить("Счет фактура №"+пНомерДок+" от "+пДатаДок+": ошибка при записи: "+ОписаниеОшибки())
                КонецПопытки; 
                
                
                
		    КонецЕсли;
		
		Состояние("Обрабатываются поступления товаров за дату "+пДатаДок);
		НаборЗаписей.MoveNext();	
	КонецЦикла;
 
23.07.2010 12:50  
Carott
Цитата:
Сообщение от skier2
могу предложить обработку для стандартной 7.7 или 8.х. если будет интересно...
Доброго времени суток. интересует обработка для 8.х. Только начинаю заниматься Супермагом, а открытие скоро. На все не хватает времени))
 
 


Опции темы



Часовой пояс GMT +3, время: 17:16.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.