[ОТВЕТИТЬ]
28.05.2009 14:02
HellBoy
 
Доброго времени суток.
Недавно запустили магазин, 4 кассы. Изначально на все машины поставили УКМ с одного дистрибутива, а по сути папку SMUKM30 растиражировали на все машины. Оборудование на всех кассах одинаковое (СП101ФР-К, диспл.пок. LD202, клава Prech).
Через три дня одна касса стала тормозить при считывании и отображении на дисплей товара. Было замечено, что при загрузки программы (на черном фоне) долго тестируется Фискальный регистратор и при входе в кассовый модуль после ввода пользователя/пароля долго считывается таблица префиксов и последнего чека. Переключили ДП с СОМ3 в СОМ2, пока работает.
Через день после этого ДП на другой кассе перестал отображать информацию, постоянно горит СПАСИБО ЗА ПОКУПКУ. При физическом отключении провода от системника касса начинает тупить. Также переключили с СОМ3 на СОМ2, сутки проработала. Сегодня звонят и говорят что касса сильно тормозит. Но в отличии от случая выше вместо таблицы префиксов долго подготавливает фискальник к работе. Приехали, в cf_ini.db отключили подачу на СОМ2. Касса работает.

У себя в офисе запустили Cfview.exe (предварительно вернув подачу на СОМ2, а там

Устройство на COM1..............Фискальный регистратор (19200,N,8,1,RTS/CTS)
Устройство на COM2Фискальный регистратор (19200,N,8,1,RTS/CTS) (9600,N,8,1,RTS/CTS)
Устройство на COM3...........................................Не используется
Устройство на COM4...............................Сканер (9600,N,8,1,RTS/CTS)

при том что ФР один и весит на СОМ1.
Кто чем может помочь? Заранее спасибо.
28.05.2009 14:03
Mtirt
 
Надо настроить через интерфейс на com2 дисплей покупателя
28.05.2009 14:09
HellBoy
 
Через какой интерфейс? через конфигурацию УКМ настраивал на СОМ2, работал и перестал. Может как-то выложить файл cf_ini.opt , чтоб было видно.
28.05.2009 22:50
Bork
 
Главное меню, конфигурация, основное оборуование, сними галку с дисплея. Затем дополнительное оборудование, сними галку со второго и третьего ком портов, оставь только ФР и сканер.
Посмотри, скорее всего все будет работать нормально, кроме дисплея. %)
Если все нормально, тогда будем включать дисплеи.
Для этого нужно пониматьчто за ККМ у вас используется.
29.05.2009 06:58
HellBoy
 
В основном переферийном оборудовании галка не стоит.
Как уже писал, при освобождении 2 и 3-го портов касса работает нормально, но без дисплея, а он нужен.

Стоит IBM PC AT на LexPOS + СП101ФР-К + Preh MCI84 + LD202.

Оборудование прописывается только в cf_ini или еще где?
29.05.2009 07:54
Bork
 
Цитата:
HellBoy В основном переферийном оборудовании галка не стоит.
Как уже писал, при освобождении 2 и 3-го портов касса работает нормально, но без дисплея, а он нужен.

Стоит IBM PC AT на LexPOS + СП101ФР-К + Preh MCI84 + LD202.

Оборудование прописывается только в cf_ini или еще где?
Обрудование прописывается только в cf_ini.
Если я правильно понимаю, то LD202 у вас питается от ком порта. (проверьте нет ли у вас такого небольшого наболдажника в середине интерфейсного кабеля дисплея).
По умолчанию, у лекса подается питание в пять вольт на ком 3 и 4.
Соответственно втыкаем дисплей в третий ком. В дополнительном оборудовании ставим галку на ком 3, настройки как у сканера, тип оборудования LD202.

Включите дисплей на одной из касс и посмотрите, что получится.
29.05.2009 07:58
Vovantus
 
А если подключить ДП напрямую к ФР? Тока там напряжение может быть 12В, нуна учесть этот момент.
29.05.2009 08:20
Bork
 
Цитата:
Vovantus А если подключить ДП напрямую к ФР? Тока там напряжение может быть 12В, нуна учесть этот момент.
для ФРа нужен специальный кабель, я не зря спросил про наболдажник:)
29.05.2009 09:00
HellBoy
 
Эти дисплеи питаются по СОМ порту 12В, для этого пришлось переключать джампер в системнике. Дисплей инфу показывает но касса при этом сильно тормозит. Кстати кабель там простой СОМовский с параллельной распайкой (1-1, 2-2, и т.д.)
29.05.2009 09:03
HellBoy
 
Говорят что вроде пытались подключать, но при этом что-то не получалось.
29.05.2009 09:14
Vovantus
 
Цитата:
HellBoy Говорят что вроде пытались подключать, но при этом что-то не получалось?
Походу только одна строка текста отображалась?
29.05.2009 09:26
HellBoy
 
Не в курсе, просто сказали что не получалось. А если одна, то как на две переделать? на ДП ни одного переключателя нет.

Кстати кто знает откуда в cf_ini.opt эта "красная" бяка взялась, скорее всего из-за этого и глючит?

Устройство на COM1..............Фискальный регистратор (19200,N,8,1,RTS/CTS)
Устройство на COM2Фискальный регистратор (19200,N,8,1,RTS/CTS) (9600,N,8,1,RTS/CTS)
Устройство на COM3...........................................Не используется
Устройство на COM4...............................Сканер (9600,N,8,1,RTS/CTS)
29.05.2009 09:31
konst
 
В свое время тоже столкнулись с проблемой тормозов при подключении дисплея...
как было...
открывали магазин с 8 кассами,
LexPOS, штрих-фр-к, сканер ШК, ДП LD202
COM1 - фискальник
COM2 - сканер ШК
COM3 - дисплей покупателя
COM4 - сберовский терминал....
все собрали, настроили... - работает...
на следующий день начались дикие тормоза...
причем на 6 кассах из 8.... все перепроверили... все настройки
ничего не помогает... вобщем отключили ДП ...
прошел год, появилось время опять вернулись к этому вопросу...
подключили дисплеи - опять поймали тормоза...
установили УКМ-2 с нуля, настроили, поправили номера смен
и все заработало... и уже полгода нормально работает....
прямое сравнение cf_ini старой и новой установки так и не дало ответ на вопрос - почему...
29.05.2009 09:47
HellBoy
 
konst, а дистрибутив брали старый или новый когда переутанавливали УКМ?
29.05.2009 10:39
konst
 
когда ставили 1й раз при открытии магазина - дистрибутив был старый
и с ним были тормоза
потом обновили УКМ на этом магазине до версии 2.457 b8473D7
ставили как обычно поверх - тоже были тормоза
а потом этот же дистр. установили с 0 и все заработало..
Причем наличие тормозов не зависит от модели дисплея
мы подключали и LD202 и Firich
29.05.2009 10:49
Mtirt
 
Вот здесь, Bork всё очень точно описал.
https://olegon.ru/showpost.php?p=46452&postcount=4
У вас на com2 одновременно числятся и фискальник и дисплей покупателя.
Надо УДАЛИТЬ в настройке доп.оборудования настройки на дисплей покупателя и тормоза пропадут.
После удаления имеет смысл выйти из программы и зайти снова - убедиться, что данные действительно удалены.
Ну и к совету Bork, про то, что дисплей покупателя лучше включать на com3, так как там на него подается дополнительное питание, я думаю, тоже стоит прислушаться.
29.05.2009 12:07
HellBoy
 
Mtirt, спасибо, конечно, но дело в том, что изначально мы ставили дисплеи на СОМ3, поработали и перестали (как писал в начале), переключили на СОМ2 и один ДП еще работает, а второй и на нем перестал.

Сегодня звонят и говорят, что у них на третьей кассе тормоза и все повторяется как на второй кассе: долгое тестирование ФР при старте программы, долгая подготовка ФР и чтение последнего чека при входе в режим Кассира. При этом CF_INI.OPT показывает

Устройство на COM1..............Фискальный регистратор (19200,N,8,1,RTS/CTS)
Устройство на COM2...........................................Не используется
Устройство на COM3......................Не используется (9600,N,8,1,RTS/CTS)
Устройство на COM4...............................Сканер (9600,N,8,1,RTS/CTS)

Если в конфигураторе переключить дисплей с СОМ3 на СОМ2 то в cf_ini.opt будет

Устройство на COM1..............Фискальный регистратор (19200,N,8,1,RTS/CTS)
Устройство на COM2Фискальный регистратор (19200,N,8,1,RTS/CTS) (9600,N,8,1,RTS/CTS)
Устройство на COM3...........................................Не используется
Устройство на COM4...............................Сканер (9600,N,8,1,RTS/CTS)

НО при этом вначале все хорошо работает, читается и пробивается. от греха подальше отключил дисплей совсем, но они его хотят.
29.05.2009 12:43
Mtirt
 
Цитата:
HellBoy Устройство на COM2Фискальный регистратор (19200,N,8,1,RTS/CTS) (9600,N,8,1,RTS/CTS)
Вот эта строка говорит, что галка Фискальный регистратор, в доп.оборудовании у тебя установлена для Com2. Возможно, в данной версии УКМ2 есть ошибка и она ставится автоматом. Прибей только её. Оставь на месте дисплей покупателя.

Цитата:
HellBoy НО при этом вначале все хорошо работает, читается и пробивается. от греха подальше отключил дисплей совсем, но они его хотят.
Они его правильно хотят, так как отсутствие оборудования, перечисленного в паспорте-версии ККМ чревато санкциями налоговиков, при проверке. А если сослаться на неработоспособность дисплея, то это могут приравнять к работе на неисправной ККМ.
29.05.2009 13:00
HellBoy
 
Mtirt, а как ее прибить, если я ставлю ФР на СОМ1 а на СОМ2 ДП, там же только по одному оборудованию на порт можно повесить? Откуда он его вообще берет...
29.05.2009 13:29
HellBoy
 
Кстати, тут было время, посидел побаловался с конфигурацией оборудования, пробовал разную последовательность подключения оборудования, подключил:
СОМ1 - ФР
СОМ2 - сканер
СОМ3 - ДП,
запустил cfview, и он выдал:

Устройство на COM1..............Фискальный регистратор (19200,N,8,1,RTS/CTS)
Устройство на COM2...............................Сканер (9600,N,8,1,RTS/CTS)
Устройство на COM3..........Сканер (9600,N,8,1,RTS/CTS) (9600,N,8,1,RTS/CTS)

может все дело в кривом дистрибутиве?
29.05.2009 13:32
Mtirt
 
У тебя сейчас "кривые" настройки по com3 ...
29.05.2009 13:34
HellBoy
 
да я это и сам вижу, вопрос почему? любой порт где весит ДП приобретает кривые настройки. Это ужо пахнет кривым софтом на этот ДП.
29.05.2009 13:38
konst
 
Важная информация:
при подключении ДП через COM порт -
в конфигурации УКМ - переферийные устройства
НЕ ДОЛЖНА стоять галка - "Дисплей покупателя - подключен"
29.05.2009 13:48
Mtirt
 
Третий раз.
Специально сходила на кассу.
Дисплей покупателя должен быть настроен только один раз.
Варианты:
1. Основное оборудование - Дисплей покупателя - COM2
Дополнительное оборудование - Напротив COM2 не стоит крестик.
2. Основное оборудование - НЕ ДОЛЖНА стоять галка - "Дисплей покупателя - подключен"
Дополнительное оборудование - Напротив COM2 стоит крестик, в правой секции выбран тот тип дисплея покупателя, который ты используешь.

Как в первом, так и во втором случае, в разделе "Дополнительное оборудование" лучше максимально убрать настройки.
29.05.2009 20:49
HellBoy
 
Konst? он и не стоит, проверял.

Mtirt, спасибо что проверили на практике, но у нас точно подключение по второму варианту с настройками по умолчанию для СОМ портов(9600,8,нет,1), в других магазинах работает а в этом нет.*181

Может так будет понятней

Тип ККМ............................................................IBM PC AT
Количество шрифтов для VGA........................................Два шрифта
Тип принтера чеков.................................................СП101ФР-К
Порт для печати чеков.............................................Неизвестно
Порт денежного ящика...............................Принтер/Фиск. регистратор
Тест денежного ящика.....................................................Нет
Дисплей покупателя.......................................................Нет
Подсветка дисп. покупателя...............................................Нет
Инвертирование дисплея...................................................Нет
Контраст дисп. покупателя...............................................100%
Порт дисплея покупателя.................................................COM1
Прошивка русской кодировки..............................Прошит в Сервис-Плюс
Расширенный буфер клавиатуры.............................................Нет
Тип клавиатуры...................................................Неизвестный
Заставка экрана.....................................................Выключен

ДОПОЛНИТЕЛЬНЫЕ ПОСЛЕДОВАТЕЛЬНЫЕ УСТРОЙСТВА

Устройство на COM1..............Фискальный регистратор (19200,N,8,1,RTS/CTS)
Устройство на COM2Фискальный регистратор (19200,N,8,1,RTS/CTS) (9600,N,8,1,RTS/CTS)
Устройство на COM3...........................................Не используется
Устройство на COM4...............................Сканер (9600,N,8,1,RTS/CTS)
Устройство на COM5...........................................Не используется
Устройство на COM6...........................................Не используется
Устройство на COM7...........................................Не используется
Устройство на COM8...........................................Не используется
29.05.2009 21:27
Bork
 
Цитата:
HellBoy Konst? он и не стоит, проверял.

Mtirt, спасибо что проверили на практике, но у нас точно подключение по второму варианту с настройками по умолчанию для СОМ портов(9600,8,нет,1), в других магазинах работает а в этом нет.*181

Может так будет понятней

Тип ККМ............................................................IBM PC AT
Количество шрифтов для VGA........................................Два шрифта
Тип принтера чеков.................................................СП101ФР-К
Порт для печати чеков.............................................Неизвестно
Порт денежного ящика...............................Принтер/Фиск. регистратор
Тест денежного ящика.....................................................Нет
Дисплей покупателя.......................................................Нет
Подсветка дисп. покупателя...............................................Нет
Инвертирование дисплея...................................................Нет
Контраст дисп. покупателя...............................................100%
Порт дисплея покупателя.................................................COM1
Прошивка русской кодировки..............................Прошит в Сервис-Плюс
Расширенный буфер клавиатуры.............................................Нет
Тип клавиатуры...................................................Неизвестный
Заставка экрана.....................................................Выключен

ДОПОЛНИТЕЛЬНЫЕ ПОСЛЕДОВАТЕЛЬНЫЕ УСТРОЙСТВА

Устройство на COM1..............Фискальный регистратор (19200,N,8,1,RTS/CTS)
Устройство на COM2Фискальный регистратор (19200,N,8,1,RTS/CTS) (9600,N,8,1,RTS/CTS)
Устройство на COM3...........................................Не используется
Устройство на COM4...............................Сканер (9600,N,8,1,RTS/CTS)
Устройство на COM5...........................................Не используется
Устройство на COM6...........................................Не используется
Устройство на COM7...........................................Не используется
Устройство на COM8...........................................Не используется
Так, давайте уже заканчивать с cf_ini.opt. Кладите сюда cf_ini.db.
D конце концов непонятно что за версия, cf_view тоже может глючить.
30.05.2009 11:46
akonev
 
Цитата:
HellBoy Mtirt, спасибо что проверили на практике, но у нас точно подключение по второму варианту
по первому варианту для связки lexpos (IBM PC AT в "кассовой машине") + СП101ФР-К + LD202 прописать в конфигурации вообще не даст.

в cf_ini.opt смотреть заканчивай. я попробовал на свежеустановленном 2.456B build 7A4C52 - именно так, как у тебя (фискальник с двумя комплектами настроек порта), он и показывает любой ДП, подключенный по второму варианту. а если убрать с первого порта фискальник - на первый напишет просто "не используется", а на второй "не используется" с параметрами порта.

попробуй уже подключить эту чуду к фискальнику, для разнообразия.
"пробовали, не получилось. но как именно не получилось, не знаю" - это не лучший вариант эксперимента.
если хоть как-то отзовется - надо будет в самом фискальнике переключить ДП с BA63 (по умолчанию) на LD202
30.05.2009 23:07
Bork
 
Цитата:
Andrew_Konev по первому варианту для связки lexpos (IBM PC AT в "кассовой машине") + СП101ФР-К + LD202 прописать в конфигурации вообще не даст.

в cf_ini.opt смотреть заканчивай. я попробовал на свежеустановленном 2.456B build 7A4C52 - именно так, как у тебя (фискальник с двумя комплектами настроек порта), он и показывает любой ДП, подключенный по второму варианту. а если убрать с первого порта фискальник - на первый напишет просто "не используется", а на второй "не используется" с параметрами порта.

попробуй уже подключить эту чуду к фискальнику, для разнообразия.
"пробовали, не получилось. но как именно не получилось, не знаю" - это не лучший вариант эксперимента.
если хоть как-то отзовется - надо будет в самом фискальнике переключить ДП с BA63 (по умолчанию) на LD202
Только кабьель возьми с наболдажником, а то спалишь дисплей нафиг.
31.05.2009 09:46
konst
 
Выкладываю архив с двумя CF_ini
old - до переустановки УКМ - дисплей не работает, вернее работает
но УКМ жутко тормозит
new - после переустановки УКМ - все работает как часы...
Вложения
Тип файла: 7z cf_ini.db.7z (10.8 Кб, 65 просмотров)
01.06.2009 05:42
HellBoy
 
Так как его спалишь, если он и так на 12В питается?

Я б его прикрепил, но судя по правам не могу этого делать.


Опции темы


Часовой пояс GMT +3, время: 07:19.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.