[ОТВЕТИТЬ]
27.10.2009 13:09
SeverBap
 
Подскажите, как написать отчет по получению данных за один час (нужно получитть количество чеков и общую сумму продажи) из кристалла?
посмотрел примеры в руководстве по обмену данными меня просто запутало все!
как я понял там нужно получить неонлайновые отчеты через интерфейс IOperDay.
кто нибудь такое делал?
28.10.2009 12:56
SeverBap
 
Написал пока такое:
Сообщить("Получение данных из кристалл сет");
Если Не КристалСетЗагружен Тогда
Сообщить("Режим файловый! - продолжение не возможно!",СтатусСообщения.ОченьВажное);
Возврат;
КонецЕсли;
МоментаОтчета=НачалоДня(НачПериода);
Пока МоментаОтчета<=КонецДня(КонПериода) Цикл
Состояние(Строка(МоментаОтчета));
МоментаОтчета=МоментаОтчета+3600;
ОперацииДанными=КристалСет.Operday[МоментаОтчета];
Если Не ОперацииДанными.Ready Тогда
Прервать;
КонецЕсли;
Сообщить(Строка(ОперацииДанными.RepChequePos(Ложь)));
КонецЦикла;
05.11.2009 18:09
SeverBap
 
сколько надо заплатить что бы вы мне что-:Laie_19:нибудь подсказали?
05.11.2009 18:20
Назым
 
Можно подробнее:

1. Какой фронт? Какой Бэк?
2. В какой из них нужно получить отчет?
3. Из какой из них должна производиться выборка для отчета?
4. Хорошо было бы руководство сюда выложить , о которой выше упоминалось
06.11.2009 08:22
Dimon
 
Цитата:
SeverBap сколько надо заплатить что бы вы мне что-:Laie_19:нибудь подсказали?
прости даже ума не приложу, может кто из кодеров поможет
06.11.2009 12:06
SeverBap
 
:Elffy_5: вообщем руководство называется: "Установка и настройка комплекса SET Retail. Обмен данными. Руководство системного администратора (версия 5)" в электронном варианте я не нашел в нете! *94
06.11.2009 12:26
Dimon
 
Цитата:
SeverBap :Elffy_5: вообщем руководство называется: "Установка и настройка комплекса SET Retail. Обмен данными. Руководство системного администратора (версия 5)" в электронном варианте я не нашел в нете! *94
у меня по моему где то есть нужно?
06.11.2009 13:48
Dimon
 
Цитата:
SeverBap выложи!
сейчас файл поместят в хранилище, называется CashServ.
09.11.2009 15:54
SeverBap
 
Ошибка в строке:
ОперацииДанными=КристалСет.Operday[МоментаОтчета];
09.11.2009 21:22
Назым
 
Цитата:
SeverBap Ошибка в строке:
ОперацииДанными=КристалСет.Operday[МоментаОтчета];
А подробнее ошибку расписать?
10.11.2009 10:09
SeverBap
 
{Форма.ОсновнаяФорма(12)}: Поле объекта не обнаружено (Operday)
ОперацииДанными=КристалСет.Operday[МоментаОтчета];

Да еще вот что обещали выслать полное описание встроеного языка по кристаллу - я так думаю может что-нибудь там и нарою! А то я там их достал :pooh_door: вот и отписались они!
10.11.2009 10:12
Mtirt
 
А где ты создаешь COM-объект КристалСет?
В приведенном тобой коде этого нет...
10.11.2009 10:19
SeverBap
 
Вообщем ее создавать не нужно, так как она уже загружена будет при запуске конфигурции "SM Complex Проф 8.02.035 (Сборка 10.16) Торговый Центр + мерчендайзинг" - типовая конфигурация с поддержкой setretail (Кристалл сет)

Примечание: в этой конфигурации предусмотрен обмен данными между кристаллом и 1с но только в разрезе выгрузки данных (выгрузка товара на кассы и весы) в кристал (через обмен dbf) и загрузка Z-отчета все что требовалось от ее, а мне надо отчет полного взаимодействия 1С и кристалла
16.11.2009 15:58
SeverBap
 
:viannen_55: Вообщем так: все необходимые данные лучше всего взять из отчета (уже один раз выгрузил и отработал всю структуру заложенную в 1С правильно) который из группы отчетов "Отчеты по чекам" - заголовки чеков ("Его обозначение: repchequehead"), в котором меня интересуют поля dateoperation и summa, сейчас в демо режиме формируются диаграммы по количеству чеков и общей суммы с шагом 1 Час. веду разработку итогового листа по общим итогам за интервал неделя!:beach:
16.11.2009 17:36
vitamin
 
Мы пользуем 1С-Рарус, у них хорошо реализован обмен между сетом и 1с через ком объекты. могу попросить программера выдернуть обработку "анализ оперативных продаж". но в ней почасового просмотра нет, кажись.но во всяком случае можно ее поковырять
если надо выложу.
17.11.2009 11:06
SeverBap
 
Выложи, напишу как надо, а то что-то меня стремает постоянно делать выгрузку через DBF!
17.11.2009 16:32
vitamin
 
чет я не вкурил как тут вложение делать. кстати, а нахрен вам все делать через кристал. запрашиваем напрямую в SQL.
17.11.2009 17:35
SeverBap
 
Тогда подскажи как? :connie_explosion:
17.11.2009 19:02
vitamin
 
тк 1c языка не знаю, то разные отчеты ваял на access, язык почти от sql не отличается
отчет оперативные продажи 1С
upload/SQL%D0%9F%D1%80%D0%BE%D0%B4%D0%B0%D0%B6%D0%B8%D0%9F%D0%BE%D0%9A%D0%B0%D1%81%D1%81%D0%B0%D0%BC.erf
отчет продажи по кассам 1С
upload/SQL%D0%9F%D1%80%D0%BE%D0%B4%D0%B0%D0%B6%D0%B8%D0%9F%D0%BE%D0%9A%D0%B0%D1%81%D1%81%D0%B0%D0%BC.erf
19.11.2009 14:57
SeverBap
 
Там интересного нет что ты скинул*159
23.11.2009 11:04
SeverBap
 
нет ничего так все процедуры в другом месте (глобальном или общем) *04 может подскажешь что за конфа?
25.11.2009 11:21
vitamin
 
1C-Рарус ТКПТ v8 (8.1.15.01)
подключил программера, обещался помочь чем может.
ЗЫ рарусы пользуют модели оборудования, свою внешнюю утилиту, в которой прописывают все параметры подключаемых устройств. для кристалла это настройки на скуль и сколько касс.
04.03.2010 15:02
Sergik_D
 
Разобрался ? Пиши если что в асю 230303142. У меня такая же конфа за основу взята была.
17.03.2010 16:56
vitamin
 
Вышел 79 релиз ритейла, в нем есть обработка для обмена с 1С:торговля. кто хочет посмотреть?
29.05.2010 00:20
Snoring
 
Цитата:
vitamin Вышел 79 релиз ритейла, в нем есть обработка для обмена с 1С:торговля. кто хочет посмотреть?
Ну кто так рекламирует? Надо же хоть показать что-нибудь, например доку.
upload/temp/1c-coupling.rar
Опции темы


Часовой пояс GMT +3, время: 04:36.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.