[ОТВЕТИТЬ]
Опции темы
03.11.2009 10:54  
sergus
Цитата:
Сообщение от Назым
Как варинат на каждую упаковку создать элемент справочника Номенклатура с типом Набор. При считывании штрихкода набор в документ заливаются все состоявляющие набора в том количестве, в котором вы укажаете в составе набора.
А ты сможешь подробно описать как это сделать. Я то я не знаю как.
Если не сложно напиши по действиям. Что то в роде того " справочники, номенклатура, новый, вкладка штрих коды, ну и тд."
 
03.11.2009 16:42  
Назым
Цитата:
Сообщение от sergus
А ты сможешь подробно описать как это сделать. Я то я не знаю как.
Если не сложно напиши по действиям. Что то в роде того " справочники, номенклатура, новый, вкладка штрих коды, ну и тд."
Сейчас нет под рукой 1С. Позже напишу
 
03.11.2009 23:54  
Назым
1. Справоники - Номенклатура - Номенклатура
2. Действия - Добавить
3. Заполняем поле Наименование
4. В поле Вид номенклатуры выбираем вид Набор (предварительно там надо создать данный элемент с типом Набор)
5. На закладке Штрихкоды добавляем новый внутренний штрихкод (если нет заводского)
6. На закладке Комплектующие заполняем табличную часть теми элементами, которые составляют упаковку одежды и в том количестве, в котором они там лежат.
7. Жмем ОК
7. Теперь печатаем штрихкод набора
8. И пробуем в документе продажи сканером штрихкода пикнуть и смотрим, что получилось (этот пункт не проверял, нет под рукой сканера)

В пункте 8 есть сомнения, что правильно обработается набор. А если через Подбор его в документ кинуть, то увидишь, что вместо набора туда попадет вся табличная часть Коплектующих.

Ну вот. Отпишись, как протестируешь.
 
04.11.2009 01:22  
Назым
Скорее всего предыдущий пост не прокатит. Штрихкоды обрабатываются по-иному. На скорую руку сделал решение конфигурированием:

Цитата:
Если Не РезультатЗапроса.Пустой() Тогда
РезультатЗапроса = РезультатЗапроса.Выбрать();
РезультатЗапроса.Следующий();
Если ТипЗнч(РезультатЗапроса.Владелец) = Тип("СправочникСсылка.ИнформационныеКарты") Тогда
Ответ = Клиент.СШКИнформационнаяКарта(РезультатЗапроса.Владелец, СШК);
Если Ответ Тогда
Возврат Результат;
КонецЕсли;
Иначе // Если ТипЗнч(РезультатЗапроса.Владелец) = Тип("СправочникСсылка.Номенклатура")
//Ответ = Клиент.СШКНоменклатура(РезультатЗапроса.Владелец,
// РезультатЗапроса.ХарактеристикаНоменклатуры,
// РезультатЗапроса.СерияНоменклатуры,
// РезультатЗапроса.Качество,
// РезультатЗапроса.ЕдиницаИзмерения,
// 1,
// СШК);
Ответ = Клиент.СШКНоменклатура(РезультатЗапроса.Владелец,
РезультатЗапроса.ХарактеристикаНоменклатуры,
РезультатЗапроса.СерияНоменклатуры,
РезультатЗапроса.Качество,
РезультатЗапроса.Владелец.ЕдиницаХраненияОстатков, //Вот здесь говорим, чтобы брал единицу в штуках
РезультатЗапроса.ЕдиницаИзмерения.Коэффициент, //а здесь говорим, чтобы количество проставлял из коэффициента считанного штрихкода
СШК);

Если Ответ Тогда
Возврат Результат;
КонецЕсли;
КонецЕсли;
КонецЕсли;
Всего лишь пару строчек подправить и готово решение твоей задачи.

Пиши какой у тебя релиз конфигурации
 
04.11.2009 01:52  
Назым
Логика стандартного решения:

При считывании штрихкода, модуль подставляет в документ единицу измерения штрихкода, количество равное 1

Логика измененного решения:

При считывании штрихкода, модуль подставляет в документ Единицу хранения остатков номенклатуры (значит она должна быть у тебя в шт.) , количество равное коэффициенту считанного штрихкода.
 
05.11.2009 10:07  
sergus
Цитата:
Сообщение от Назым
Логика стандартного решения:

При считывании штрихкода, модуль подставляет в документ единицу измерения штрихкода, количество равное 1

Логика измененного решения:

При считывании штрихкода, модуль подставляет в документ Единицу хранения остатков номенклатуры (значит она должна быть у тебя в шт.) , количество равное коэффициенту считанного штрихкода.

Ща попробую отпишу что вышло.
 
05.11.2009 10:36  
sergus
Цитата:
Сообщение от Назым
1. Справоники - Номенклатура - Номенклатура
2. Действия - Добавить
3. Заполняем поле Наименование
4. В поле Вид номенклатуры выбираем вид Набор (предварительно там надо создать данный элемент с типом Набор)
5. На закладке Штрихкоды добавляем новый внутренний штрихкод (если нет заводского)
6. На закладке Комплектующие заполняем табличную часть теми элементами, которые составляют упаковку одежды и в том количестве, в котором они там лежат.
7. Жмем ОК
7. Теперь печатаем штрихкод набора
8. И пробуем в документе продажи сканером штрихкода пикнуть и смотрим, что получилось (этот пункт не проверял, нет под рукой сканера)

В пункте 8 есть сомнения, что правильно обработается набор. А если через Подбор его в документ кинуть, то увидишь, что вместо набора туда попадет вся табличная часть Коплектующих.

Ну вот. Отпишись, как протестируешь.
Этот способ у меня по чему то даже и с подбором не заработал.
А вот второй способ я даже и не понял. А так спасибо за те варианты которые ты предлагал.
 
05.11.2009 11:33  
Назым
Какой релиз конфигурации?
 
05.11.2009 11:35  
Назым
По первому способу, покажи скриншоты всех настроек, которые указаны в моих пунктах
 
05.11.2009 14:47  
sergus
1с 8.1 управление торговлей 10.3

По поводу первого способа то делал я так: Зашёл в номенклатуру, создал папку "комплектующее", в ней добавляю товар к примеру "кофточка 1", "кофточка 2", "кофточка 3", потом выхожу из этой номенклатуры, захожу в "sc 101 Кофточка для девочек 3шт в упак". В ней я захожу во вкладку "комплектующее", жму добавить, и выбираю "кофточка 1", жму ещё раз добавить, выбираю "кофточка 2", и т.д. Так как штрих код уже установлен его я и не трогаю. Далее я жму кнопочку записать. Лезу в документы в пункт счёт на оплату покупателям, создаю новый, забиваю все реквизиты, жму на иконку "подбор" и выбираю "sc 101 Кофточка для девочек 3шт в упак".
Исход получается таким
Номенклатура | Количество | Коэффициент | цена за шт.| Сумма |
Sc 101 Кофт.1 уп................|............3.......|.......100р....|..300р..|

И ни чего больше =(

Но ведь как я понял, мне этот способ и не подойдёт, если даже и заработает. Так как с ним сканер не ладит.:hang1:
 
 


Опции темы



Часовой пояс GMT +3, время: 02:58.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.