[ОТВЕТИТЬ]
27.01.2010 17:09
shadow
 
Собственно по сабжу. Проапдейтились до версии 1,027 SP2 в сентябре 2009 года. Оракл 9i. После этого начались проблемы с устройствами, которые подключаются через Com – порты (Весы Масса-К, ручные сканеры, ТСД Denso 8000BHT). Супермаг, при обращении к разделу настройки оборудования или, например, в момент загрузки весов, или выгрузки/загрузки терминала наглухо зависает. Причем можно запустить 2ю сессию Супермага, до доступ к этом разделу закрыт. А 1ю сессию не закроешь никак –нельзя снять задачу. Помогает только рестарт компа через кнопку Reset. Проблема проявляется не всегда – но очень часто. Сначала подумал, что это проблема в платах расширения Com –портов, но когда проблема повторилась во ВСЕХ МХ, где используется подобное оборудование, то стало понятно. что проблема в софте. До апдейта все работало как часы и такого не наблюдалось. У кого может было что-то подобное и как вышли из ситуации.. Буду благодарен любой информации
27.01.2010 17:14
shadow
 
XP Proff. при апдейте мы систему не переустанавливали.
27.01.2010 17:15
Propil
 
пока одно, что заметил - сканер ШК, подключенный к com-порту на рабочем месте оператора "слетел" после установки 1.027.2
Пришлось его переопределить
Работает
27.01.2010 17:21
OlegON
 
ХР с каким сервиспаком? То, что не дает несколько сессий запустить - нормально, доступ к COM - эксклюзивный. Есть подозрения, что :
1) Стоят какие-то драйвера оборудования
2) COM-железки дешевые и что-то в них криво эмулируется софтом
3) Какое-то лишнее оборудование на одном и том же порту
4) Супермаг теряет записи реестра (как и настройки кнопок)
27.01.2010 17:23
shadow
 
1) XP SP3 обновляем регулярно
2) ну дешевые и что -раньше работали 4 года без проблем, а сейчас нет..
3) нет все четко прописано. пересечений нет.
4) это я уже не знаю.... че делать то?
27.01.2010 18:16
Dim
 
а если теряются ветки реестра - это не из той же оперы, что и слетание настройки панелей из соседней ветки?
27.01.2010 19:22
shadow
 
я эту ветку прочитал сразу же... у нас такого не проявлялось и не наблюдалось
27.01.2010 19:35
konst
 
COM порты бывают интегрированные в мат. плату и
дополнительные мультикарты с COM портами

1. проблемы проявляются и с теми и с другими?
2. можно сделать так чтобы на компе остались только родные порты и потестить будут с ним глюки или нет...
3. мы используем обычно мультяхи на чипах NetMos... когда то словили тормоза
нашли драйвер с которым все работает нормально...
используем весы CAS и Масса-К, сканера ШК (только RS) проблем не было замечено (правда версия у нас 1.027.1 SP3)
27.01.2010 19:51
baggio
 
1. установить Netmos special Driver
2. уменьшить буферы FIFO
3. затем мониторить что с ком портом происходит... возможно стоит поставить програмную заглушки COM-COM .Была в теме про эмулятор фискальника...
28.01.2010 13:58
shadow
 
про буферы ниче не могу сказать -проверю.
платы внешние, на чипах NetMos, дрова родные. мы систему НЕ ПЕРЕУСТАНАВЛИВАЛИ, драйвера тоже ,все работало нормально до апдейта.
как замониторить, что происходит с портом?
28.01.2010 17:00
shadow
 
уменьшил буферы немного (на четверь). пока вроде нормально, но лучше пару дней статистику еще обрать. я еще в С+ закинул тот же вопрос:
цитата:
**********************************************
А так же на имеющихся попытаться использовать USB-COM переходник. Например, модели: TU-S9. Именно такие я рекомендовал последнее время нашим клиентам.
Ну и переход на 1.27.2 я бы тоже рассмотрел как шаг к решению проблемы, все же 27 версия была первой "ласточкой" которая стала использовать net.framework.
**************************

я про переходникик както даже не задумывался. надо испытать эти штуки
05.02.2010 16:46
shadow
 
Уменьшил буферы ФИФО в COM-портах на четверть от максимлаьного.
проблема за 2 недели больше не возникала.
Спасибо baggio за дельный и совет - решение правильно подсказал! Работает!
вопрос исчерпан.
Опции темы


Часовой пояс GMT +3, время: 03:41.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.