[ОТВЕТИТЬ]
19.03.2010 11:08
Назым
 
Вот код, которым пытаюсь подключиться

Цитата:
СтрокаСоединения = "DRIVER={MySQL ODBC 3.51 Driver};OPTION=3;DATABASE=UKM_Server;PWD=***;PORT=4567;SERVER=192.168.1.102;UID=****";
SQL = new COMОбъект("ADODB.Connection");
SQL.ConnectionString = СтрокаСоединения;
Попытка SQL.Open() Исключение Сообщить(ОписаниеОшибки());возврат;
КонецПопытки;
Есть сомнения по поводу правильного указания параметров:

DATABASE, PORT

Эти данные беру из УКМ-4 в разделе Администрирование - Сервер
19.03.2010 11:09
Назым
 
При отладке ошибка:

Цитата:
{Форма.Форма(8)}: Ошибка при вызове метода контекста (Open): Произошла исключительная ситуация (Microsoft OLE DB Provider for ODBC Drivers): [MySQL][ODBC 3.51 Driver]Can't connect to MySQL server on '192.168.1.102' (10061)
19.03.2010 11:12
OlegON
 
А
Цитата:
telnet 192.168.1.102 4567
получается?
19.03.2010 11:15
Назым
 
Цитата:
OlegON А получается?
О, это из командной строки?
19.03.2010 11:16
Назым
 
На telnet ругается, не удалось подключиться.

Хм, где посмотреть имя базы и порт на УКМ-4?
19.03.2010 11:17
OlegON
 
Да, самый простой и надежный способ попробовать подключиться на удаленный порт - протелнетить его. Заодно и скажет, что за ошибка. Порт, кстати, нестандартный, я не знаю, какой он у УКМа, но по умолчанию у мускула 3306
19.03.2010 11:18
OlegON
 
Зайди на сервер с базой и скажи
Цитата:
netstat -a
еще не вариант, что у тебя настроены удаленные подключения к базе.
19.03.2010 11:23
Назым
 
Цитата:
OlegON Зайди на сервер с базой и скажи
еще не вариант, что у тебя настроены удаленные подключения к базе.
netstat -a выдал список активных подключений их там масса. Что дает эта инфорация?

Как проверить настроено ли удаленное подключение?
19.03.2010 11:25
Назым
 
поменял порт на 3306. Теперь выдает

Цитата:
{Форма.Форма(8)}: Ошибка при вызове метода контекста (Open): Произошла исключительная ситуация (Microsoft OLE DB Provider for ODBC Drivers): [MySQL][ODBC 3.51 Driver]Access denied for user 'expert'@'WINXPSP3-PC' (using password: YES)
19.03.2010 11:28
Назым
 
Кстати на telnet 192.168.1.102 3306 выдает абрукадабру, потом пауза и подключение утеряно
19.03.2010 11:38
Mtirt
 
47 версия?
Там, по-умолчанию, отключена возможность внешних подключений.
19.03.2010 11:39
Назым
 
Цитата:
Mtirt 47 версия?
Там, по-умолчанию, отключена возможность внешних подключений.
44 сп 3
19.03.2010 11:39
Назым
 
А вот поиском нарыл:

Цитата:
Ошибка: 1044 SQLSTATE: 42000 (ER_DBACCESS_DENIED_ERROR)

Сообщение: Для пользователя '%s'@'%s' доступ к базе данных '%s' закрыт
Получается нет доступа
19.03.2010 11:42
Mtirt
 
Так под root попробуй подключиться...
19.03.2010 11:44
Назым
 
Цитата:
Mtirt Так под root попробуй подключиться...
Там пароль какой?

Вспомнил xxxxxx
19.03.2010 11:44
Mtirt
 
Никакой. Т.е. пустой пароль.
19.03.2010 11:46
Назым
 
Поробовал, то же самое выходит. root и xxxxxx
19.03.2010 11:49
Mtirt
 
Не надо хххххх, просто не указывай пароль...
19.03.2010 11:57
Назым
 
Цитата:
Mtirt Не надо хххххх, просто не указывай пароль...
Вот результат

Цитата:
{Форма.Форма(8)}: Ошибка при вызове метода контекста (Open): Произошла исключительная ситуация (Microsoft OLE DB Provider for ODBC Drivers): [MySQL][ODBC 3.51 Driver]Access denied for user 'root'@'%' to database 'ukm_server'
19.03.2010 12:20
Mtirt
 
Приведи полностью строку подключения.
19.03.2010 12:24
Назым
 
Цитата:
Mtirt Приведи полностью строку подключения.
Вот полная строка..............

Цитата:
DRIVER={MySQL ODBC 3.51 Driver};OPTION=3;DATABASE=UKM_Server;PORT=3306;SERVER=192.168.1.102;UID=root
19.03.2010 12:26
Mtirt
 
а если добавить PWD='';
19.03.2010 12:35
Назым
 
Цитата:
Mtirt а если добавить PWD='';
Поменял. Результат тот же

Цитата:
"DRIVER={MySQL ODBC 3.51 Driver};OPTION=3;DATABASE=UKM_Server;PORT=3306;SERVER=192.168.1.102;UID=root;PWD="
19.03.2010 12:37
Mtirt
 
Меня смущает название базы. Я всегда считала, что база называется ukmserver.
А у тебя там зачем-то подчеркивание...
19.03.2010 12:38
kadr
 
А любым клиентом для MySQL ты можешь подключиться к базе под указанным пользовтаелем? Ну это чтобы понять траблы в ODBC драйвере или все же в мускуле запрещен доступ пользователю
19.03.2010 13:58
Назым
 
Попытался подключиться клиентом. Пишет то же самое
Цитата:
An error occured while performing the operation:
An error occured while establishing the connection:
Type: java.sql.SQLException Error Code: 1044 SQL State: 42000
Message:
Access denied for user 'root'@'%' to database 'ukm_server'
19.03.2010 13:59
Mtirt
 
ИМЯ БАЗЫ?
Выше я написала - UKMSERVER
19.03.2010 14:03
Назым
 
Цитата:
Mtirt ИМЯ БАЗЫ?
Выше я написала - UKMSERVER
Прости, Mtirt. Я почему-то уперся, будучи уверенным, что у меня база так называется. Написал имя базы UKMSERVER. Подключение прошло успешно
19.03.2010 14:04
Mtirt
 
Успешно и из 1с и из любого клиента?
19.03.2010 14:09
Назым
 
УРА! Добился. Неправильно было указано имя базы. Вот результирующий текст

Цитата:
ТекстЗапроса = "Select * from trm_in_classifclients";

/// ADODB соединение надо чтоб драйвер был именно 3.51
СтрокаСоединения = "DRIVER={MySQL ODBC 3.51 Driver};OPTION=3;DATABASE=UKMServer;PORT=3306;SERVER=192.168.1.102;UID=root;PWD=";
SQL = new COMОбъект("ADODB.Connection");
SQL.ConnectionString = СтрокаСоединения;
Попытка SQL.Open() Исключение Сообщить(ОписаниеОшибки());возврат;
КонецПопытки;

SQLcmd = New COMОбъект("ADODB.Command");
SQLcmd.ActiveConnection = SQL;
SQLcmd.CommandText = ТекстЗапроса;
тз = Новый ТаблицаЗначений;
мойЗапрос = Новый COMОбъект("ADODB.Recordset");
мойЗапрос.Open(SQLcmd);
КолвоКолонок = мойЗапрос.Fields.Count();


для ш = 0 По КолвоКолонок-1 Цикл
Если тз.Колонки.Найти(мойЗапрос.Fields.Item(ш).name) = Неопределено Тогда
тз.Колонки.Добавить(мойЗапрос.Fields.Item(ш).name);
КонецЕсли;
конецЦикла;
Пока не мойЗапрос.Eof() Цикл
Стр = тз.Добавить();
для ш = 0 По КолвоКолонок-1 Цикл
Стр[мойЗапрос.Fields.Item(ш).name] = мойЗапрос.Fields.Item(ш).value;
КонецЦикла;
мойЗапрос.MoveNext();
КонецЦикла;
мойЗапрос.Close();
Вот только кириллицу не понимает. Вместо русских символов в ТЗ вопросики (?)


Опции темы


Часовой пояс GMT +3, время: 09:25.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.