[ТЕМА ЗАКРЫТА]
Опции темы
29.11.2010 19:40  
Stels
Цитата:
Сообщение от MirProd
Например так:
Код:
select * from supermag.smstoreunits where trim(translate(barcode, '0123456789',' ')) is not null
ага, спасибо, вычислил.

арт 20964 шк к46018052
арт 27446 шк к460700224166
('к' похоже русская)

Цитата:
Сообщение от OlegON
Если найдешь - скажи, я себе его добавлю, чтобы потестировать.
Олег, убиваю шк? или пока оставить ... потестишь?
 
29.11.2010 21:08  
OlegON
Да вот если бы все так просто было...
Не оно это... Я себе впилил эти штрихкоды, не падает, выбирает нормально...
Как бы его найти...
Поправил еще вариант поиска. Если не поможет - попробуй экспортнуть табличку штрихкодов? Я себе ее волью, нечисто дело...
 
04.12.2010 13:51  
Stels
Эти ШК удалил - ошибки больше не приходят
в отчёте
Неправильные штрихкоды
Не обнаружены
 
04.12.2010 14:51  
OlegON
Возможно, что это были они, но какие-то непечатные символы залезли вместе с буквами...
 
07.12.2010 15:59  
AlexeyK
Помогите пожалуйста оптимайзер подключается с ошибкой:

07.12.10 15:10:24 -- Optimizer for Oracle bases console version 4.10
07.12.10 15:10:24 -- C:\optimizer4
07.12.10 15:10:24 -- Master server: olegon.no-ip.org
07.12.10 15:10:24 -- DB server: goodserv
07.12.10 15:10:24 -- DB name: GOODCO
07.12.10 15:10:26 -- Requested commands:o
07.12.10 15:10:26 -- Commands accepted
07.12.10 15:10:29 -- OLEGON-ERROR! : Conn:goodserv:GOODCO:java.sql.SQLException: Исключение ввода/вывода: The Network Adapter could not establish the connection
07.12.10 15:10:32 -- OLEGON-ERROR! : Conn:goodserv:GOODCO:java.sql.SQLException: Исключение ввода/вывода: The Network Adapter could not establish the connection
07.12.10 15:10:34 -- OLEGON-ERROR! : Conn:goodserv:GOODCO:java.sql.SQLException: Исключение ввода/вывода: The Network Adapter could not establish the connection
07.12.10 15:10:34 -- Parameters table created...
07.12.10 15:10:36 -- OLEGON-ERROR! : Conn:goodserv:GOODCO:java.sql.SQLException: Исключение ввода/вывода: The Network Adapter could not establish the connection

Сама база работает нормально
 
07.12.2010 16:08  
John Doe
На сервере запускаешь? Антивирусы? Прочая помойка?
Не удается подключиться к твоей базе.
 
07.12.2010 16:16  
AlexeyK
Цитата:
Сообщение от John Doe
На сервере запускаешь? Антивирусы? Прочая помойка?
Не удается подключиться к твоей базе.
да на сервере стоит 2003.
к базе подключаемся без проблем.
 
07.12.2010 16:20  
John Doe
Еще раз. Запускаешь на сервере? Оптимизатору не удается подключиться к твоей базе.
 
07.12.2010 16:25  
AlexeyK
Цитата:
Сообщение от John Doe
Еще раз. Запускаешь на сервере? Оптимизатору не удается подключиться к твоей базе.
Оптимизатор запускается на сервере (Win2003) где лежит сама база.
Я понимаю, что оптимизатор не может подключиться к базе, только не могу понять почему, когда все другие программы подключаются без проблем.
 
07.12.2010 17:00  
John Doe
Listener на стандартном порту? Покажи строку запуска, пароль забей на что-нибудь.
 
 


Опции темы



Часовой пояс GMT +3, время: 12:39.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.