13.04.2016 22:30
OlegON
 
Немного подзапарил меня dnf своими желаниями периодически обновлять репозитории, причем, именно тогда, когда я полез что-то срочно поставить.

Что сделано:
1) в .bashrc
Код:
alias dnf="dnf --cacheonly"
2) в /etc/anacrontab раз в день
Код:
dnf --refresh check-update
3) в /etc/dnf/dnf.conf
Код:
fastestmirror=true
deltarpm=true
на самом деле deltarpm=false, поскольку не хочу налететь на какой-то глюк с дельтами... Но в целом лучше так.

4)
Код:
systemctl stop dnf-makecache.timer
systemctl stop dnf-makecache.service
systemctl disable dnf-makecache.timer
systemctl disable dnf-makecache.service
01.09.2020 13:35
OlegON
 
вот, как сейчас у меня настроено в /etc/dnf/dnf.conf

[main]
gpgcheck=true
installonly_limit=2
clean_requirements_on_remove=true
best=false
skip_if_unavailable=true
max_parallel_downloads=10
fastestmirror=true
deltarpm=false
keepcache=false
ip_resolve=4
country=ru
metadata_expire=-1
metadata_timer_sync=0
#exclude=kernel*

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.