15.09.2020 08:15
OlegON
 
У меня два варианта проверки обновления Mikrotik. Один - для основного устройства, которое считается продуктивом, просто уведомляет:
Код:
/system package update
check-for-updates once
:delay 3s;
:if ( [get status] = "New version is available") do={
/tool e-mail send to="support@olegon.ru" subject="New router firmware is available" \
body="$[/system clock get date] $[/system clock get time] \n \
Mikrotik $[/system package update get installed-version] -> $[/system package update get latest-version]\n \
!!!"
}
Второй вариант - на моем домашнем вайфае, с автоматическим обновлением:
Код:
/system package update
check-for-updates once
:delay 1s;
:if ( [get status] = "New version is available") do={
/tool e-mail send to="support@olegon.ru" subject="WiFi upgraded" \
body="$[/system clock get date] $[/system clock get time] \n \
!!!"
install;
}
и обновление прошивки, стоит по ночам ежедневно для всех устройств.
Код:
:log info "Checking firmware...";
/system routerboard
:if ([get current-firmware] != [get upgrade-firmware]) do={
     :log info "Updating firmware";
     upgrade;
     :delay 5s
     /system reboot
     } else={
     :log info "No update."
     }

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.