Форум OlegON > Программы и оборудование для автоматизации торговли > Кассовые программы > УКМ-4

Ошибка сериализации: отсутствует параметр params в XML

27.11.2020 15:20


28.10.2020 12:05
MrSTEP
 
Всем привет!

Последние дни разворачиваю УКМ-сервер для нового магазина. Вчера вечером остановился на том, что подключил дочерний сервер к СГО, все данные успешно отреплицировались. Сегодня решил сделать копию файлов БД на дочернем сервере, чтобы продолжить настройку, но после копирования заметил, что служба УКМ сервер не хочет запускаться, а в логе мелькает вот эта запись:
Код:
11:54:03.315: 0x000018c8: INFO: DatabaseCutDown: Процесс загрузки параметров.
11:54:03.315: 0x00002f30: INFO: internal_accounting: started
11:54:03.316: 0x000018c8: FATAL: Global: Ошибка сериализации: отсутствует параметр params в XML
Вроде ничего фатального сделать не мог, вчера все работало.. В чем может быть загвоздка, что можно предпринять?
Вложения
Тип файла: zip ukmsrvr-2020-10-28.zip (7.8 Кб, 3 просмотров)
28.10.2020 14:46
DMaslov
 
Цитата:
MrSTEP Сегодня решил сделать копию файлов БД на дочернем сервере, чтобы продолжить настройку
Перед копированием остановили обе службы - "УКМ сервер" и "MySQL" ?

Хотя, если запускаете на тех же _исходных_ файлах, которые копировались, разрушений в БД быть не должно.

Может быть, если СМ переустановить и переподключить к СГО, проблема и решится.

Правка: DMaslov, 28.10.2020 14:50
29.10.2020 00:20
MrSTEP
 
Цитата:
DMaslov Перед копированием остановили обе службы - "УКМ сервер" и "MySQL" ?
Да, обе. Но тем не менее, вышло именно так.

При том, что апач работает и в настройках сервера я могу ковыряться. Но я заметил, что не работает страница Удаление чеков.

Цитата:
DMaslov Может быть, если СМ переустановить и переподключить к СГО, проблема и решится.
Попробую чистую базу подкинуть. Кстати, перед этим на СГО надо отключать текущий (поломанный) сервер?
Миниатюры
Нажмите на изображение для увеличения
Название: image001.png
Просмотров: 3
Размер:	12.7 Кб
ID:	11100   Нажмите на изображение для увеличения
Название: image002.png
Просмотров: 6
Размер:	35.5 Кб
ID:	11101   Нажмите на изображение для увеличения
Название: image003.png
Просмотров: 3
Размер:	33.6 Кб
ID:	11102  
29.10.2020 01:13
MrSTEP
 
Подкинул чистую базу, УКМ сервер запустился. Сделал подключение к СГО, поймал в логах надпись, что подключен другой сервер. Отключил на СГО старый, разрешил подключение нового, в СМ снова прилетели все данные. Остановил, сделал такой же бэкап файлов БД, как и днем, запустил обратно - все в порядке.

Что могло пойти не так днем - ума не приложу. Главное ведь, не на базу ругается, а на XML.. Где он его вообще взял?..
30.10.2020 18:05
XaosLord
 
В БД некоторые параметры хранятся в виде XML
Какой-то важный параметр оказался битым или отсутствующим - вот и ошибка

Не осталось БД, где ошибка была?
Выложите куда-нибудь. Будет время, посмотрю, что могло случиться.
02.11.2020 09:06
MrSTEP
 
Вам наверно лучше в виде дампа? На проблемном сервере mysql версии 5.6.17
03.11.2020 11:56
XaosLord
 
Всё равно
Можно и в бинарном виде - целиком папку data. Главное указать ОС и версию MySQL
11.11.2020 12:52
MrSTEP
 
Извиняюсь за задержку, не спешил за ненадобностью. Теперь выкладываю просто ради интереса, чтобы понять, что не так.
ОС Windows 7 x64, MySQL 5.6.17

Так, ссылку на Google Drive вставить не дает, а на странице https://storage.olegon.ru/upload.php получаю ошибку 404.
12.11.2020 16:32
MrSTEP
 
Цитата:
OlegON Спасибо, поправил :)
Даже тут умудряюсь баги находить, фантастика))

Ладно, залью архив сюда.
ОС Windows 7 x64, MySQL 5.6.17
Вложения
Тип файла: zip data_broken.zip (24.82 Мб, 1 просмотров)

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.