Форум OlegON > Программы и оборудование для автоматизации торговли > Кассовые программы > УКМ-4

Проблема с обновлением до 100 версии УКМ-4 : УКМ-4

28.11.2021 2:45


16.11.2021 13:45
Starter
 
Пытался обновить (с версии 96) до 100-й.
В процессе постоянно падает

== "C:\Program Files\ukmserver\ukmupman\temp_unpack\up.cmd"
===================================
EXECUTING: common-srv-dat.cmd
==== supermag-ukm4-prerequisites-install.exe started ===================
return code prerequisites 8
===================================
ERROR: "C:\Program Files\ukmserver\ukmupman\temp_unpack\up.cmd" failed
===================================

Его как то предварительно устанавливать нужно ? ( supermag-ukm4-prerequisites-install.exe ) ?
16.11.2021 13:54
GreenCapsul
 
Либо попробуй запустить обновление от админа, либо предварительно запусти "supermag-ukm4-prerequisites-install.exe" тоже от имени админа.
Чаше всего падает из-за проблем с правами. А если будет установлен заранее обновлятор увидит уже установленный преинстал, и пропустит этот шаг
16.11.2021 13:55
OlegON
 
Если начало падать из-за приседаний под админа и нет - сходу тогда отключай UAC, потому, что иногда не падает, а глючит молча, но с последствиями.
16.11.2021 14:05
Starter
 
Да от имени админа и запускал всегда. с 96 версии в итоге обновилось.
С 94-й - ставишь вначале этот пакет, попутно пару раз перезагружаясь, он устанавливается. В процессе установки - установленная 100-я версия удаляется из программ, ставится 95-я, а 100-я в процессе обновления установиться не может.
Кто-нибудь уже до 100-й обновлял, не сталкивался с похожим поведением ?
16.11.2021 14:26
Starter
 
UAC, разумеется, отключен. И через реестр тоже отключен.
В итоге, пришлось через промежуточную обновляться..

Вначале обновился до 99-й, потом перезагрузка (на всякий случай), потом до 100 сп1.
16.11.2021 21:28
Starter
 
Цитата:
Starter потом перезагрузка (на всякий случай)
Попробовал без перезагрузки - получил ошибку.
Дальше интереснее - попрообовал с 99 обновить до 100 (с перезагрузкой) - в процессе обновления сервер сам перезагрузился. Разумеется, обновление не получилось. Зато supermag-ukm4-prerequisites установился версии 100. Какая прелесть - перезагружать сервер в процессе обновления.... Вспоминается отрывок из 72 метров: "Э-э… что-то недодумали наши ученые… с очисткой… м-да, недодумали...."
В итоге установилось. получилась процедура - обновляем до 99, перазагружаемся, устанавливаем supermag-ukm4-prerequisites из дистрибутивов 100-й версии (поищите в архиве обновления). Снова перезагружаемся. обновляем до 100-й версии. Прямо вспомнились старые добрые времена. Справедливости ради - из 4 серверов перезагружалось в процессе установки на 2-х, видимо, зависит от того, насколько Windows обновлена.
18.11.2021 13:37
_Sergey_
 
Цитата:
Starter Попробовал без перезагрузки - получил ошибку.
Дальше интереснее - попрообовал с 99 обновить до 100 (с перезагрузкой) - в процессе обновления сервер сам перезагрузился. Разумеется, обновление не получилось. Зато supermag-ukm4-prerequisites установился версии 100. Какая прелесть - перезагружать сервер в процессе обновления.... Вспоминается отрывок из 72 метров: "Э-э… что-то недодумали наши ученые… с очисткой… м-да, недодумали...."
В итоге установилось. получилась процедура - обновляем до 99, перазагружаемся, устанавливаем supermag-ukm4-prerequisites из дистрибутивов 100-й версии (поищите в архиве обновления). Снова перезагружаемся. обновляем до 100-й версии. Прямо вспомнились старые добрые времена. Справедливости ради - из 4 серверов перезагружалось в процессе установки на 2-х, видимо, зависит от того, насколько Windows обновлена.
Мне в тех поддержке сказали обязательно сначала нужно установить supermag-ukm4-prerequisites, только потом обновляться с 97 версии. Еще не пробовал, жду лицензии.
18.11.2021 14:52
Ferus
 
Обновление завершается ошибкой на пакете 00099000.dat

Код:
EXECUTING: common-srv-dat.cmd
==== ukmserver-upgrade.sql started ==========================
Warning: Using a password on the command line interface can be insecure.
ERROR 1305 (42000) at line 51 in file: 'ukmserver-upgrade.sql': PROCEDURE ukmserver.wbn_clearsessions does not exist
===================================
ERROR: "C:\Program Files\ukmserver\ukmupman\temp_unpack\up.cmd" failed
===================================
2021/11/18 15:46:12|
2021/11/18 15:46:12|---- ERROR ----
2021/11/18 15:46:12|
2021/11/18 15:46:12|ERROR: Failed to process package 00099000.dat.s.zip. "C:\Program Files\ukmserver\ukmupman\temp_unpack\up.cmd" failed
19.11.2021 09:09
MrSTEP
 
Да, с недавних пор обновление стало прерываться перезагрузкой, если пакет prerequisites не установлен. Так что теперь заранее ищу в архивах этот файл, ставлю его вручную, перезагружаю. а потом обновляю сам УКМ. Позавчера на СГО обновлялся с 96сп1 до 100сп1, всё прошло гладко, в один заход. Магазины пока не трогал (на одном новом сразу установил версию 100).
19.11.2021 09:15
Ferus
 
Цитата:
MrSTEP prerequisites
Ставил, к сожалению не помогло

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.