Форум по программам и оборудованию > > >

Релиз кассового ПО на базе Ubuntu 18.04 (без поддержки процессингов ГазПромБанк и Аркус)

14.11.2019 20:43


20.10.2019 14:57
newkid
 
Тихо и незаметно 15.10.2019 вышел релиз Artix POS 4.6.140, который был ознаменован переходом на дистрибутив Ubuntu 18.04LTS Server x64.


Дистрибутив

Из интересного дисрибутив перешел сразу на 64 бит архитектуру, в связи с чем есть небольшой косяк при обновлении вылезает ошибка

E: Не удалось получить httр://update.artix.su/bionic/dists/artix-4.6.140-5/artix/binary-i386/Packages 404 Not Found [IP: 185.76.147.109 80]


надо файл /etc/apt/sources.list.d/artix.list
Код:
deb  http://update.artix.su/bionic artix-4.6.140-5 artix main contrib
Надо поменять на
Код:
deb [arch=amd64] http://update.artix.su/bionic artix-4.6.140-5 artix main contrib
Пока времени на дальнейшее иследование не было, кто уже развернул поделитесь впечатлениями.

Правка: newkid, 20.10.2019 15:04
22.10.2019 09:16
BigWolf
 
Пробовал сегодня на этот же релизе под bionic. Вроде все работает.
25.10.2019 10:39
Goldmen
 
Подскажите как обновится с Ubuntu 14.04.5 LTS (GNU/Linux 4.17.6-custom i686) до Ubuntu 18.04LTS без каких либо последствий?
Какие конкретно команды нужно последовательно вводить в командную строку?
Или же я могу установить эти обновления на Ubuntu 14.04.5 LTS и все будет работать?
26.10.2019 11:27
newkid
 
Цитата:
Goldmen Подскажите как обновится с Ubuntu 14.04.5 LTS (GNU/Linux 4.17.6-custom i686) до Ubuntu 18.04LTS без каких либо последствий?
Какие конкретно команды нужно последовательно вводить в командную строку?
Или же я могу установить эти обновления на Ubuntu 14.04.5 LTS и все будет работать?
В данном случае, практически никак, это вызовет большие проблемы. Мало того что надо перескачить через 2 lts релиза таки поменялась архитектура с i386 на amd64, по хорошему надо сделать дамп бд и сохранить настройки, затем заново установить дистрибутив и попробовать восстановить настройки и развернуть базу, но не факт что получиться.
27.10.2019 22:15
Lanxorn
 
Цитата:
Goldmen Подскажите как обновится с Ubuntu 14.04.5 LTS (GNU/Linux 4.17.6-custom i686) до Ubuntu 18.04LTS без каких либо последствий?
Какие конкретно команды нужно последовательно вводить в командную строку?
Или же я могу установить эти обновления на Ubuntu 14.04.5 LTS и все будет работать?
А вам принципиально переходить на Ubuntu 18.04?
Обновление Артикса есть как на 14.04 так и на 18.04. Не думаю, что скоро закончат с обновлениями Артикса под 14.04
А если реализовывать, то только переносом БД, как посоветовали выше. В maintainer сделать дамп и перенести на новый релиз, там восстановить дамп.
28.10.2019 05:48
BigWolf
 
Цитата:
Goldmen Подскажите как обновится с Ubuntu 14.04.5 LTS (GNU/Linux 4.17.6-custom i686) до Ubuntu 18.04LTS без каких либо последствий?
Какие конкретно команды нужно последовательно вводить в командную строку?
Или же я могу установить эти обновления на Ubuntu 14.04.5 LTS и все будет работать?
ДД.
Обновитесь на ближайший к 18-ке релиз на 14 УБУНТЕ и дальше, как было описано выше, через переустановку на 18ку и заливку конфигов и БД на 18-ку (такого же или наиболее близкого релиза). Это позволит избежать проблем в расхождениях в структуре БД.
29.10.2019 07:44
BigWolf
 
Выпустили релиз 4.6.141-2 в котором исправлена данная проблема.
29.10.2019 10:30
Vintiknef
 
Наиболее быстрый способ обновления с 10,04 на 14,04 был через снятие дампа и его восстановление. Обновляться "на лету" у нас не получилось.
Скорее всего с 14 на 18 будут такие же грабли.
По поводу поддержки 14,04 мне кажется, что она еще будет года 3.

Все новые устанвки кассы лучше все-таки делать на 18 уже.
29.10.2019 13:39
Lanxorn
 
Попробовал вкорячить 18.04 на CheckWay POS55. К сожалению не взлетел.
Код:
This kernel requires an x86-64 CPU, but only detected an i686 CPU.
Unable to boot
30.10.2019 05:05
BigWolf
 
Цитата:
Goldmen Подскажите как обновится с Ubuntu 14.04.5 LTS (GNU/Linux 4.17.6-custom i686) до Ubuntu 18.04LTS без каких либо последствий?
Какие конкретно команды нужно последовательно вводить в командную строку?
Или же я могу установить эти обновления на Ubuntu 14.04.5 LTS и все будет работать?
Цитата:
Lanxorn Попробовал вкорячить 18.04 на CheckWay POS55. К сожалению не взлетел.
Код:
This kernel requires an x86-64 CPU, but only detected an i686 CPU.
Unable to boot
Бионика работает только на x64 процессорах.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.