05.06.2019 07:02
W03LN
 
Приветствую.
Почему-то стандартный импорт 4 не грузит отделы и остатки, в логах сервера
Код:
stocks(0), items_stocks(0), items_remain_journal(0), items_remain(0)
Хотя в таблицах данные присутствуют
Код:
INSERT INTO `stocks` VALUES ('1001',14,0,'Склад',13,0);
INSERT INTO `items_stocks` VALUES ('1001','00001',14,13,0);
INSERT INTO `items_remain` VALUES ('1001','00001',100.0000,NULL,13,0);
Классификатор, товар, цену, штрихкоды и налоги загружает без проблем.
Подскажите, что ему надо? уже всю голову сломал
06.06.2019 05:40
W03LN
 
Даже поставил сервер на стенд с нуля (install) и всё равно не хочет принимать эти данные. Ошибок конвертора нет.
Может как то можно расширенный лог посмотреть?
06.06.2019 15:11
W03LN
 
Такое ощущение, что на уровне ядра это не конвертится. Обидно. Скоро переходить на новый функционал по продаже маркированных товаров, а элементарных удобных вещей нет. Жаль. Я думал, что фронтол - бабосы по надо и не надо гребёт....
10.06.2019 10:44
УКМ_эксплуатант_2
 
Я вот так гружу - все отлично проходит:
Цитата:
Insert into stocks(store,id,owner,name,version,deleted) values ("003",1,0,"Основной отдел",22,0);
Insert into stocks(store,id,owner,name,version,deleted) values ("003",2,0,"Первый дополнительный",22,0);
Insert into stocks(store,id,owner,name,version,deleted) values ("003",3,0,"Второй дополнительный",22,0);
INSERT INTO items (id,name,measure,measprec,version,deleted,classif,tax) values('Z0000','Тестовый товар для проверки загрузки','ШТ',0,22,0,284,4);
INSERT INTO items_remain (store,item,remain,version,deleted) values ("003",'Z0000',10000,22,0);
INSERT INTO pricelist_items (pricelist,item,price,minprice,version,deleted) values (1,'Z0000',1.00,0,22,0);
INSERT INTO items_stocks (store,item,stock,version,deleted) values ("003",'Z0000',3,22,0);
10.06.2019 13:02
УКМ_эксплуатант_2
 
Извиняюсь за очевидный вопрос: а есть после указанных инсертов строчка
Цитата:
insert into `signal` VALUES('incr',13);

Вопрос дурацкий, но у меня раз было, что пихаю данные с version=100, а в signal - записал 101. Тоже не грузилось
10.06.2019 14:01
W03LN
 
Цитата:
УКМ_эксплуатант_2 Извиняюсь за очевидный вопрос: а есть после указанных инсертов строчка



Вопрос дурацкий, но у меня раз было, что пихаю данные с version=100, а в signal - записал 101. Тоже не грузилось
да, только я полную загрузку делаю cumm и переменная version такая же (даже вручную пробовал вставлять данные для одной карточки).
Мысли кое-какие есть, но щас недосуг. Если получиться - обязательно отпишусь
10.06.2019 14:09
W03LN
 
Цитата:
УКМ_эксплуатант_2 Я вот так гружу - все отлично проходит:
А версия УКМ какая?
У меня 81 сп 12
10.06.2019 14:26
УКМ_эксплуатант_2
 
83сп3

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.