Форум OlegON > Программы и оборудование для автоматизации торговли > Оборудование > Онлайн-кассы > ККТ АТОЛ

ФР Атол и "Запретительный режим" продажи маркированных товаров : ККТ АТОЛ

23.04.2024 18:17


22.03.2024 07:07
Артем2023
 
Добрый день. Подскажите, как нужно передавать в ККМ Атол, чтобы корректно заполнить теги 1262, 1263, 1264, 1265 и 1260. пытаемся из 1с7 передать теги 1262, 1263, 1264, 1265 перед регистрацией позиции, не понятно тег 1260 формирует сама ККМ или нужно его тоже передавать, но в какой момент? То что описано в документации атола, у нас не работает.
22.03.2024 07:36
volk13
 
Цитата:
Артем2023 пытаемся из 1с7 передать
как-то так:
Цитата:
.......
fptr.setParam(1262, "030");
fptr.setParam(1263, "21.11.2023");
fptr.setParam(1264, "1944");
fptr.setParam(1265, Знач_1265);

Если fptr.utilFormTlv() = 0 Тогда
Тег1260 = fptr.getParamString(fptr.LIBFPTR_PARAM_TAG_VALUE);
// используем getParamString, т.к. getParamByteArray 1С 7.7 не поддерживает
Иначе
// обрабатываете ошибку..
....
fptr.cancelReceipt();
КонецЕсли;

.........

fptr.setParam(fptr.LIBFPTR_PARAM_MARKING_CODE, текКодМаркировки);
fptr.setParam(fptr.LIBFPTR_PARAM_MARKING_CODE_STATUS, Статус);
fptr.setParam(fptr.LIBFPTR_PARAM_MARKING_PROCESSING_MODE, 0);
......

// регистрируем каждую позицию чека
fptr.setParam(fptr.LIBFPTR_PARAM_COMMODITY_NAME, ТекущееНаименованиеТовара);
......

//записываем комплексный атрибут (именно тут)
Если ПустоеЗначение(Тег1260) = 0 Тогда
fptr.setParamStrHex(1260, Тег1260);
КонецЕсли;

РезультатРегистрации = fptr.registration();
22.03.2024 11:08
Артем2023
 
Цитата:
volk13 как-то так:
Огромное спасибо, получилось.

Подскажите, в этой конструкции:
Цитата:
Если fptr.utilFormTlv() = 0 Тогда
Тег1260 = fptr.getParamString(fptr.LIBFPTR_PARAM_TAG_VALUE); // используем getParamString, т.к. getParamByteArray 1С 7.7 не поддерживает
Иначе
// обрабатываете ошибку..
....
fptr.cancelReceipt();
КонецЕсли;
В случае чего fptr.utilFormTlv() может быть не 0?
22.03.2024 11:26
volk13
 
Цитата:
Артем2023 В случае чего fptr.utilFormTlv() может быть не 0?
не знаю, просто задана стандартная проверка, чтобы ФР не завис в случае чего...
И лучше создайте отдельную тему, (т.к. тут тема не про Атол, а про УКМ WIN) чтобы не засорять чужую тему.
Часовой пояс GMT +3, время: 18:17.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.