26.07.2019 10:08
Honey12345
 
Добрый день. Имеем два рабочих. На обоих установлены сканеры 1100i и параллельно подключены к ПК и табло рабочего места.
Все отлично работало, код передавался на ПК и отображался на табло. Сканер 1 был сброшен в настройки по умолчанию.
После этого настроен следующим образом :

1. Enable Codabar
2. Label ID Transmition : Disable
3. Disable Start/Stop Char Transmition
4. Set Prefix 02
5. Set Suffix 03

После этого данные на компьютер передаются, а на табло рабочего места не отображаются.
Проблема в каких то настройках сканера. В каких выяснить пока не вышло.
Обратились к тем кто настраивал в 2012 году, но они подсказали вышеописанные настройки.
Хотел считать настройки с рабочего сканера, чтобы сравнить, но при использовании кабеля 90A052267 ПО Scanalyzer не определяет устройство.
В Инструкции написано что нужно использовать special RS-232 Testport cable designed for your scanner model.
В руководстве по сканеру описана только стандартная распиновка кабель.
Подскажите какую опцию нужно включить чтобы сканер отображал на табло или подскажите распиновку кабеля чтобы можно было посмотреть настройки и сравнить.
С Уважением Дмитрий.
26.07.2019 11:10
grannie
 
Кабель такой
8-0751-04
Magellan 1000i, 1100i, 1400i RS-232 programming cable for Magellan OSP – Connects to scanner via the scanner’s host port and to the host PC via RS-232 DB9 port. Requires external power supply.

Распиновка есть, но что-то загрузка в хранилище глючит, не приложить
29.07.2019 01:03
Honey12345
 
Огромное спасибо, буду пробовать!
29.07.2019 08:56
Honey12345
 
Еще раз Добрый день. Спаял кабель по выложенной разводке. На чертеже сказано, что подходит к MGL 1000i, у меня же 1100i это равнозначно?
Схему распайки проверил 3 раза, и еще попросил второго инженера проверить. Распаял все верно. Но сканер все равно не определяется.
При нажатии на кнопку Connect to Scaner - сканер пикает 1 раз зажигает красные светодиоды по периметру и через 5 секунд выбрасывает окно о том что
сканер не опознан. Сканер сбрасывал в дефолт с помощью штрихкода, тот же эффект. Может еще какой то хитрый ход нужен ?

Последовательность действий следующая.
1. подаю питание на сканер.
2. Ввод штрих кода сброса в заводские установки.
3. Установка интерфейся в RS-232 -STD
4. Установка четности. (так как параметры в Scanalyzer стоит в even)
5. Отключение питания
6. Подключение к Com порту ноутбука
7. Подключение питания. (сканер зажигает верхнюю зеленую лампочку, мигает ей один раз и стоит в режиме ожидания, коды не считываются)
8. Запускаю Scanalyzer, Жму Connect to Scaner - сканер пикает 1 раз, включает красные светодиоды по периметру и выдает окно об ошибке подключения.

И второй вопрос. Когда первый раз установил Scanalyzer, опции настройки Com порта были доступны, а сейчас не доступны для изменения (9600,8,even,1) и поменять нельзя,
это нормально ?
30.07.2019 04:24
Honey12345
 
Спасибо. Все сработало, использовал другое программное обеспечение Magellan OSP. Оно без проблем видит сканер и можно считать параметры.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.