Форум OlegON > Компьютеры и Программное обеспечение > Сеть > Сетевое оборудование > MikroTik

Mikrotik. Как оптимально настроить Wi-Fi сеть. Советы и рекомендации.

23.10.2020 8:16


13.09.2018 11:07
OlegON
 
Достаточно долго вожусь с настройками, призываю поделиться какими-то неочевидными вещами.

1. Как оценивать. Я ориентируюсь на качество клиентского сигнала, который показывается в показателе Overall Tx CCQ. Ваша задача настроить так, чтобы этот показатель не опускался ниже 90%. Для тех, кто любит картинки, можно смотреть в закладку Quick set, где по каждому клиенту график рисуется, можно выделить отстающих и делать выводы, кто тянет показатель вниз и почему.

2. Не стремитесь захреначить мощность сигнала в потолок. Это заглушит совсем рядом находящиеся устройства и слишком далеко расположенные со слабым сигналом. Кстати, default, судя по всему, расчитан именно на максимум, чтобы доставать до дальних рутеров. Я поставил all rates fixed в значении 10. Работает куда лучше более мощных значений и default.

3. Band надо поставить в максимально узкие значения. Если все устройства поддерживают N (нет совсем древних), то поставьте 2GHz-only-N.

4. Channel Width поставьте в 20Mhz, я по доброте душевной ставил 20-40, хотя, как выяснилось, 40MHz даже в стандарт включать не хотели. Качество сигнала чуть ли не вдвое лучше стало, когда убрал 40.

5. Adaptive Noise Immunity - ap and client mode

6. Hw. Protection Mode - тут все зависит от того, где расположены клиенты. Если клиенты находятся в радиусе досягаемости Wi-Fi каждого, то можно поставить none, если нет - cts rts, что немного нагрузит рутер, поскольку ему придется управлять очередью клиентов самому. Например, если, как у меня, рутер висит на стене здания и клиенты (С) находятся только с одной стороны рутера (Р): (Р)--(С1)---(С2)-----(С3), то ставим none.
Если какой-то столб в центре помещения и рутер на нем висит, а клиенты вокруг: (С1)---(С2)---(Р)---(С3)---(С4) - то клиенты 1 и 4 могут не видеть друг друга, потому - cts rts
06.01.2019 09:30
OlegON
 
Еще вариант настроить Noise Floor Threshold, что может помочь с удаленными от рутера клиентами. Здесь необходимо соблюдать баланс, поскольку при слишком большом значении рутер будет возиться с кучей мусора, при слишком маленьком - сигнал от дальних клиентов будет приниматься за шум, т.е. начнутся ретрейны и обрывы.
18.09.2020 10:11
OlegON
 
Рекомендую ограничивать Frame Lifetime.
Суть параметра в следующем: отправляете пакет и рутер пытается его отправить. Варианта два, либо он будет пытаться отправить его до посинения (отвала линка), либо после Frame LifeTime сознается софту, что не получилось. У меня отвал линка нескоро происходит, а софту бы лучше знать сразу, что помехи на линии, чтобы послать то, что нужно. Например, всякие голосовые звонки через телегу и прочее. Поэтому я себе поставил лимит в 2 секунды. У меня еще и вебморда самого микротика перестала отваливаться, видимо, старые пакеты не перепосылаются. И исчезли непонятные подвисания сети.
20.09.2020 11:35
OlegON
 
Не ставьте compression...

Вот, в итоге, текущий вариант для дома (HAP ac)... Стабильно работает и т.п.

Код:
/interface wireless set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode antenna-gain=0 arp=reply-only band=2ghz-onlyn basic-rates-a/g=48Mbps,54Mbps basic-rates-b="" channel-width=20/40mhz-XX country=russia disabled=no disconnect-timeout=15s distance=indoors frame-lifetime=500 frequency=auto ht-basic-mcs=mcs-8,mcs-9 ht-supported-mcs=mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15 hw-protection-mode=rts-cts hw-retries=10 installation=indoor max-station-count=20 mode=ap-bridge name=wifi2 ssid=СИД2 station-roaming=enabled supported-rates-a/g=48Mbps,54Mbps supported-rates-b="" wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
/interface wireless set [ find default-name=wlan2 ] adaptive-noise-immunity=ap-and-client-mode antenna-gain=0 arp=reply-only band=5ghz-onlyac channel-width=20/40/80mhz-XXXX country=russia disabled=no disconnect-timeout=5s distance=indoors frame-lifetime=500 frequency=auto hw-protection-mode=rts-cts hw-retries=10 installation=indoor max-station-count=20 mode=ap-bridge name=wifi5 ssid=СИД5 station-roaming=enabled wireless-protocol=802.11 wps-mode=disabled
/interface wireless nstreme set wifi2 enable-polling=no framer-policy=best-fit
/interface wireless nstreme set wifi5 enable-polling=no framer-policy=best-fit
/interface wireless security-profiles set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" group-key-update=1d mode=dynamic-keys radius-mac-caching=1h supplicant-identity=MikroTik wpa-pre-shared-key=ПАРОЛЬ wpa2-pre-shared-key=ПАРОЛЬ

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.