23.07.2020 17:01
DMaslov
 
Винда 10.
Установил Mobile device center, запускаю. Он висит некоторое время, вылетает. В журнале ругань про COM.
Вспоминаю, что ему нужна .net. Смотрю в "программы и компоненты", не вижу .net.
Качаю .Net 4.7.2, устанавливаю. Теперь Mobile device center не показывает даже splash screen.

Чего делаем дальше?
Миниатюры
000.png   111.png  
23.07.2020 17:05
OlegON
 
я бы ещё поставил разные варианты VC библиотек, а если не поможет - переустановил бы центр заново...
23.07.2020 17:24
DMaslov
 
Заглянул в "программы и компоненты", vcredist уже была куча, установил еще раз.

Снова появился splash screen, ошибка та же "Регистрация сервера {373E19B5-76AA-46D5-93A9-2E39A99B39B2} DCOM не выполнена за отведенное время ожидания."
Миниатюры
222.png  
23.07.2020 17:51
OlegON
 
Я про переустановку самого центра... Бывает, что из-за отсутствующих компонентов не проходит нормально сам процесс установки...
24.07.2020 07:08
Mtirt
 
Мне недавно помогло вот это:
24.07.2020 09:14
DMaslov
 
Как часто бывает, проще взять чистую виртуалку, на которой все нормально работает.

Есть два терминала M3 BLACK. Оба работали.

Один из них при установке в кроватку пишет «User authenticated», но на экране компьютера сообщение.

Вчера работал на WindowsXP+ActiveSync, сегодня этот проблемный терминал подключил к другому компьютеру с Windows7+MobileDeviceCenter – проблема не наблюдается.
Миниатюры
1.png  
24.07.2020 11:57
Cifer4th
 
Зачем вам эти MS "приблуды", когда есть замечательный PocketPC?)
24.07.2020 12:13
baggio
 
1. dot net 3.5 переставить.
2. удалить устройство из диспетчера устройств как правило после этого глюки проходят...
24.07.2020 12:39
DMaslov
 
Цитата:
замечательный PocketPC?
С ним работает обмен данными СуперМага с терминалами?

Цитата:
dot net 3.5 переставить.
Если более новая версия стоит (4.7) - надо и старую 3.5 ставить? Вот на этой виртуалке 4.7, и проблем с установкой MobileDeviceCenter не возникло.

Цитата:
удалить устройство из диспетчера устройств
О каком устройстве речь?
24.07.2020 12:47
DMaslov
 
Помогла рекомендация Mtirt.

Цитата:
Если после установки Windows 10 Creators Update от Microsoft у Вас не запускается Центр Устройств Windows Mobile, то можно исправить это, воспользовавшись одним из следующих способов:

Способ 1

Нажимаем «Win»+ R и вводим «services.msc». Нажимаем Enter для запуска.



Ищем службу «Возможности подключения устройств на платформе Windows Mobile».



Щёлкаем правой кнопкой мыши по этой службе и выбираем «Свойства».
Переходим на вкладку «Вход в систему» и ставим флажок напротив «Вход с системной учётной записью».



Теперь делаем то же самое с службой «Возможности подключения устройств на платформе Windows Mobile-2003».



С помощью правой кнопки мыши перезапускаем обе службы.
Способ 2

Запустите Редактор реестра. Для этого нажмите на клавиатуре «WIN»+ R и введите «regedit».


В редакторе реестра перейдите по адресу «Компьютер\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RapiMgr»
Щёлкните правой кнопкой мыши по пустому месту в правой части экрана. Выберите «Создать» - «Параметр DWORD (32 бита)».
Переименуйте создавшийся параметр в «SvcHostSplitDisable».
Щёлкните двойным щелчком по этому параметру и укажите значение «1». У Вас должен получиться результат, как на скриншоте.



Теперь перейдите в редакторе реестра по другому адресу «Компьютер\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WcesComm».
Создайте такой же параметр, как описано в пунктах 3-5, с таким же значением.
После того, как всё выполнено, закройте редактор реестра и перезагрузите ПК. После перезагрузки у Вас, вероятно, не будет видно окна Центра Устройств Windows Mobile, но в остальном всё будет работать нормально.

Правка: baggio, 24.07.2020 13:22

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.