21.08.2020 11:46
lev292
 
Добрый день.
Пытаюсь загрузить из 1С бонусы в SetRetail.

Написал такой код:

Парам = Прокси.ФабрикаXDTO.Создать(ПространсвоИмен, "chargeOnBonusAccount");
Парам.activatingDate = НачалоДня(ТекущаяДата());
Парам.expirationDate = НачалоДня(ТекущаяДата()+30*24*60*60);
Парам.cardNumber = НомерКарты;
Парам.chargeSum = 1000;
Парам.bonusAccountType = 579725;

Парам.shopNum = 1;//1;
Парам.cashNum = 1;//1;
Парам.shiftNum = 1;//1;
Парам.checkNum = 2;//2;

Результат = Прокси.chargeOnBonusAccount(Парам);

В результате выдает ошибку:
Недостаточно фактических параметров
{ВнешняяОбработка.ОбменДанными_SETRetail10.МодульОбъекта(2109)}: Результат = Прокси.chargeOnBonusAccount(Парам);

Каких еще параметров не хватает? Всю голову уже сломал.
21.09.2020 18:07
talkon
 
Попробуйте по аналогии:
Либо:
Код:
Процедура Процедура2(lastName)      
	ip = "192.168.101.101:8090";//ссылка на сервер SET10               
	Ссыль = Новый WSОпределения("хэttp://"+ip+"/SET-ERPIntegration/CashiersImport?wsdl"); //ссылка на WSDL файл 
	СЕТ = Новый WSПрокси(Ссыль, "хэttp://ws.cashiers.ERPIntegration.crystals.ru/", "CashiersImportService", "CashiersImportPort");
	СЕТ.importCashiers("<cashUsers>
	|<cashUser>
	|<tabNum>"+tabNum+"</tabNum>
	|<firstName>"+firstName+"</firstName>
	|<lastName>"+lastName+"</lastName>
	|<middleName>"+middleName+"</middleName>
	|<password>"+password+"</password>
	|<role>"+role+"</role>
	|<barcode>"+barcode+"</barcode>
	|<Blocked>false</Blocked>
	|<shop-index>"+shopindex+"</shop-index>
	|</cashUser>
	|</cashUsers>");
	Сообщить("Загружен");             
КонецПроцедуры
Либо:
Код:
Процедура КоманднаяПанель2кнMSXML(Кнопка)
	каталогТемп = КаталогВременныхФайлов();
	имяФайлаXML = ""+каталогТемп+"ZReports.xml" ;
	
	МестоположениеWSDL= "192.168.101.101:8090";
	Запрос =  "

            |<soapenv:Envelope xmlns:soapenv=""хэttp://schemas.xmlsoap.org/soap/envelope/""; xmlns:plug=""хэttp://plugins.operday.ERPIntegration.crystals.ru/"">;

            |<soapenv:Header/>

            |<soapenv:Body>

            |<plug:getPurchasesByParams>

            |<dateOperDay>"+Формат(Дата1,"ДФ=""yyyy-MM-dd""")+"</dateOperDay>

            |<shopNumber>3</shopNumber>

            |</plug:getPurchasesByParams>

            |</soapenv:Body>

            |</soapenv:Envelope>";     

            MSXML = Новый COMОбъект("MSXML2.XMLHTTP");

            MSXML.open("POST", "хэttp://" + МестоположениеWSDL + "/SET-ERPIntegration/FiscalInfoExport?wsdl", 0);

            MSXML.setRequestHeader("Content-Type", "text/xml; charset=utf-8");

            MSXML.setRequestHeader("Content-Length", СтрДлина(Запрос));

            MSXML.setRequestHeader("SOAPAction", "getPurchasesByOperDay");

            MSXML.send(Запрос);

            ОтветПолучен = Ложь;

            Для НомерЦикла = 1 по 100 Цикл

                Если MSXML.readyState > 3 Тогда

                    ОтветПолучен = Истина;

                    Прервать;

                КонецЕсли;      

            КонецЦикла;  

            

            Если ОтветПолучен Тогда

                ДвоичныеДанные = Base64Значение(MSXML.responseXML.text);
				ДвоичныеДанные.Записать(имяФайлаXML);
            КонецЕсли;      
	КонецПроцедуры

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.