[ОТВЕТИТЬ]
30.01.2007 18:35
OlegON
 
Цитата разработчиков:
"Мы используем Net Framework 2.0 для работы почтового модуля и некоторых компонентов клиентской части. Его надо ставить обязательно. Программа установки Net Framework 2.0 (MSI 3.1) использует Microsoft Windows Installer версии 3.1. Соответственно, его придется тоже установить и до установки Net Framework 2.0, иначе установка будет невозможна. После MSI 3.1 можно и убрать, если его наличие на компьютере кого-то смущает.

MDAC 2.8 содержит компоненты для связи с БД. Раньше мы использовали иную версию MVC, соответствующие компоненты которой уже присутствовали в ОС Windows 2000 и старше. VC 8.0 DLL необходимо устанавливать потому, что по новым правилам MS для новых ОС (XP и Server 2003) все компоненты для работы С++ приложений необходимо обязательно устанавливать. Раньше было достаточно просто скопировать, что мы и делали собственной программой установки Супермага."
31.01.2007 12:19
reddevil
 
это для серверной части?
или для клиентской тоже нужно ставить весь этот набор?
31.01.2007 12:26
Mtirt
 
Наверное можно исключить MDAC.
Net Framework нужен, если ТСД используешь.
VC 8.0 DLL нужна обязательно.
31.01.2007 12:37
bob
 
на 2000 винду и VC 8.0 DLL не надо ставить
31.01.2007 13:09
OlegON
 
Цитата:
Mtirt Наверное можно исключить MDAC.
Net Framework нужен, если ТСД используешь.
VC 8.0 DLL нужна обязательно.
Net Framework нужен по любому. А вот то, что VC8.0 DLL на 2000 не надо - сомнительно. Поподробнее можно?
31.01.2007 13:37
bob
 
На компы с 2000 виндой мы не ставили ничего, кроме инсталяшки СМ2000. Ни MDAC,ни VC8.0, ни Net Framework. Все работает (ТСД к этим компам не цепляем).
31.01.2007 13:41
OlegON
 
Либо СМ старый, либо винда неправильная (точнее - нестандартная).
31.01.2007 13:47
bob
 
СМ 1,024,4 (указано в подписи, но почему-то не присоединяется). Винда 2000 стандартная со всеми последними обновлениями.
31.01.2007 13:53
OlegON
 
Подпись обновляется во всех сообщениях, когда ты ее обновляешь, что снижает ее ценность. Что касается винды с обновлениями, пиратская сборка? Инсталлер в стандартных обновлениях есть, а вот NF нет...
01.02.2007 08:10
reddevil
 
Цитата:
reddevil это для серверной части?
или для клиентской тоже нужно ставить весь этот набор?
Кто нибудь может ответить?
Вложения
Тип файла: xls Равномерный заказ.xls (40.5 Кб, 217 просмотров)
Тип файла: xls Равномерный заказ.xls (40.5 Кб, 217 просмотров)
01.02.2007 09:36
inna
 
Если клиент не работает с портативным терминалом, то только DLL. На XP. На 2000 ничего не надо.
01.02.2007 10:03
vdm
 
На 2000 sp1 без обновлений - надо, иначе карточки не открываются (СМ 1024.6 sp2). Что именно нужно - не проверял, поставил все.
01.02.2007 10:17
inna
 
спорить не буду - у меня sp4.
01.02.2007 10:40
reddevil
 
Цитата:
vdm На 2000 sp1 без обновлений - надо, иначе карточки не открываются (СМ 1024.6 sp2). Что именно нужно - не проверял, поставил все.
нескромный вопос сколько у тебя серверов и раб. станций)
01.02.2007 10:58
vdm
 
2 сервера, 39+6 лицензий.
Да, очепятка, 2000 sp4 конечно.
01.02.2007 11:21
bayan
 
На клиентах ставлю NF 1.1 (если работают с портативниками), MDAC и VC 8.0.
На данный момент юзаю SM 24.5 SP2.
На серверах использую полный набор, т.к. стоит и почтовик и кассовый модуль. Вроде нареканий нет.

Экспериметны с серверами не ставил, как-то привык читать рекомендации разработчиков ;)
01.02.2007 15:15
OlegON
 
Хм, какая нужная тема оказалась. Я в свое время интересовался у главного разработчика, на зачем надо ставить NF на рабочие станции, если я не использую терминал. В ответ получил разъяснение, что одна из основных библиотек СМ содержит в себе ссылку на функцию NF и поэтому без него не загрузится.
Выскажу свое мнение, сформировавшееся на основе всего того, что я знаю. Для современных версий СМ и на сервер, и на клиента необходимо ставить все три компонента. Т.е. NF2,MDAC,VC DLL.
НО, мне кажется, что MDAC в этой связке не обязателен для клиента. А инсталлер у регулярно обновляющихся людей ставится вместе с одним из апдейтов на винду. По крайней мере на XP/2003.
Кстати, в свое время было открытием, что сервис-паки не включают все апдейты. Т.е. лучше ставить винду, накатывать на нее все апдейты, потом сервис пак. В противном случае есть шанс не поставить какой-то апдейт вообще, потому, что уже будет поставлен сп.
Опции темы


Часовой пояс GMT +3, время: 22:11.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.