[ТЕМА ЗАКРЫТА]
30.08.2013 14:54
vitamin
 
сабж. Никода не думал, что будут косяки в отлаженной работе sb_pilot и доса, т.к. на жуках все работает и по com и по USB. На VIKIPOS появились косяки... Если поставить в работу по USB, то после загрузки параметров отваливаются все USB девайсы, и что критичнее клава ps/2, подключенная через переходник ps/2-usb,вместе со сканером. Подключаю на ком-порт, связь с пин-падом теряется каждые 2-5 сек. после удаленной загрузки..Пробовали с представителем сбрф разные версии sb_pilot,результат тот же. Кристалл Сервис отправил в спербанк...
VIKIPOS взят на тест, с последующей установкой.
30.08.2013 16:23
student
 
Цитата:
vitamin Если поставить в работу по USB, то после загрузки параметров отваливаются все USB девайсы
не так давно общался с инпасом (делаем стыковку укмвин с ихним дуалконектором - привезли для проверок\тестов вх810 усб), он упоминал подобное относительно сбера и сказал, что их (инпаса) пинпады этому не подвержены, типа драйвер другой используется - но это про винду было, возможно и под досом что то подобное есть :)
09.01.2014 06:21
EVROPRINTUI
 
День добрый. У нас с вики тоже проблема.
При попытке настроить связь со сбербанком, при подключении терминала Verifone VX810 (для работы через sb_pilot) не получается прогрузить на него файл с настройками. Меняли терминалы, провода, прошивки, версии банковского ПО - всё безрезультатно, всегда одно и то же. Выдаёт на экран надпись что режим PC-3 не поддерживается данным устройством. При этом в .tlv-файле явно выставлен режим обмена PC-2. Откуда это берётся - загадка.
Тот же самый файл настроек, с тем же самым терминалом, через тот же провод, на соседней кассе NCR почему-то прекрасно грузится и работает.

Сбер с тестов не вернул VIKI с результатами ?
09.01.2014 11:16
Nikus
 
надпись что режим PC-3 не поддерживается данным устройством появляется в том случае, если в BIOS включена поддержка USB
09.01.2014 12:32
vitamin
 
Наш сбер все-таки нашел решение, теперь все операции проходят на самом пинпаде, а не через длл на кассе.Но это все так хреново работает, есть печальный опыт.
09.01.2014 12:33
EVROPRINTUI
 
Терминал цепляется по com порту. Отключив поддержку USB мы потеряем такие девайсы как - клавиатура , табло покупателя, и сканер. Кристал советовал подать 12 вольт на ком порты, результат таже ошибка.
09.01.2014 12:34
EVROPRINTUI
 
Цитата:
vitamin Наш сбер все-таки нашел решение, теперь все операции проходят на самом пинпаде, а не через длл на кассе.Но это все так хреново работает, есть печальный опыт.
Так все таки проблема в железе VIKI ?
15.01.2014 07:11
vanyatka
 
Есть такая же проблема с VIKI.
Долго и упорно решали проблему на Beetle. Нашли более менее нормальную 40 версию sb_pilot, с ней на одной точке все работает на другой не захотело (как оказалось из-за версии bios, с новыми не читались чиповые карты, поставили старую 0507 и все заработало). Подключение через COM. Может и тут тоже надо найти версию biosa нормальную??
15.01.2014 15:03
vitamin
 
Цитата:
EVROPRINTUI Так все таки проблема в железе VIKI ?
На самом деле хз)) тк PC stub, о котом я говорил выше криво отрабатывал что на viki, что на ncr realpos 40. Все это через ком-порт подключено.
20.01.2014 10:02
nz-bit
 
был глюк при установке новой кассы (ncr) в магазин, sb-pilot никак не хотел цеплятся по com-порту, пошарив в настройках пилота и в биосе обнаружил что прерывания на com в биосе (11) и на пилоте (10) разные. выставил в биосе 10 сразу зацепился.
02.05.2014 11:35
Infotech
 
подскажите как настроить связь через USB. В файле pinpad.ini поставил EnableUSB=1. В настройках tlv удалил номера прерывания и адреса ком портов. При попытке загрузить пораметры в пинпад весит надпись "подождите" а потом ошибка запись в пинпад не удалась. Пробывал вкл/выкл USB 2.0 b USB legacy в BIOS. В DOS надо подгружать какие то драйвера для работы USB портов?! может каки то параметры в config.sys. Никогда с USB в DOSe не работал... поэтому прошу подсказать что да как... СПС.
02.05.2014 15:02
whitewizard
 
Сам пинпад в USB режиме?
05.05.2014 10:57
Infotech
 
Попробую все суммировать. Терминал переключен в USB режим. UPOS Версия 11.41. В папке SC552 вместе с sb_pilot лежит TLV файл в настройках которого удалены все настройки связанные с ком портами. В файле pinpad.ini поставил EnableUSB=1. Запускаю sb_pilot -> служебные операции -> настройки -> техобслуживание -> загрузка параметров -> выбираю TLV. Весит сообщение "Подождите..." В BIOS пробовал отключать/включать USB 2.0 и USB legacy. результат такой же.
Не понял нужно ли прописывать что либо в config.sys или autorun.bat?! я имею ввиду драйвера на USB контроллер?!
12.05.2014 10:53
Xapac
 
Марка терминала? Что прописано в config.sys и autoexec.bat? Пока судя по всему терминал не подцепляется к системе. Так же стоит почистить если есть все файлы настроек если таковые создавались(файлы с расширениями .D)
12.05.2014 13:31
vitamin
 
От КС пришла новая версия updosmn. Как появится википос под рукой, буду тестить.
16.05.2014 13:38
krh2004
 
Infotech, в биосе все настройки про usb отключай, vf810 под досом по usb нормально работают только со старыми скрученными как у телефонной трубки проводами, с новыми длинными прямыми не хотят.
16.05.2014 13:46
Infotech
 
у меня как раз прямой. usb отключить не могу клава на нем. PS/2 отсутствует. терминалы vx805 vx820. По USB настраивал на объекте на обычном ПК. на VikiPOS-ах никак не хочет работать.
16.05.2014 13:51
krh2004
 
в config.sys и autoexec.bat ни чего прописывать не надо
16.05.2014 13:53
krh2004
 
Мне сберовцы сказали что 820 под досом вобще работать не будет
16.05.2014 13:56
krh2004
 
про 805 сказали надо пробовать с 43й версией пилота
16.05.2014 17:24
Infotech
 
попробывал несколько разных прошивок BIOS на 3-х из низ прогрузка по COM порту начинается, доходит до 80% некоторое время висит а потом пишет что данная версия терминала не поддерживает PC-3. При этом на терминале появляется его номер. Про 43-ю версию спрошу у сбера... С USB все мертво... пока все..
19.05.2014 04:12
Xapac
 
Цитата:
krh2004 Мне сберовцы сказали что 820 под досом вобще работать не будет
Работает, по USB, Кристалл, DOS. Вот только проблемы раз в день стабильно заявляет, что нет связи с банком и после перезагрузки POS снова работает до конца рабочего дня. Пока непонятно почему так.
19.05.2014 13:30
Infotech
 
у тебя железка википос или другая? здесь речь именно о википосе. на обычном пк у меня тоже есть настроеные на USB подключение. А на википосе ничего не работает ни COM ни USB. Правда COM на некоторых прошивках подает признаки жизни, но с ошибкой PC-3...
21.05.2014 04:09
Xapac
 
Нет не vikipos. Но на другом магазине такое веселье с vikipos: подключили сбербанк, день отработали и после включения на следующее утро не работал фискальник и сбер терминал. Оказалось, что терминал переполз каким то образом на 1 COM порт. Пока загадка(Кристалл Set 10).

OlegON:
Начался оффтоп в неудачно названной теме. Закрываю. Прошу заводить новые темы в соответствии с вопросом.
Опции темы


Часовой пояс GMT +3, время: 21:03.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.