[ТЕМА ЗАКРЫТА]
06.11.2013 13:04
Tagir
 
В каждой новой теме пишу, что об Oracl и СМ знаю только то, что они такие есть =) Не разбираюсь.
Мне нужно перенисти базу на другое железо.
Стоял Oracl 8 (не знаю какой патч) и СМ не могу посотмреть БД упала там вроде 1.19
Сейчас пустил на новом железе win 2003 x86, установил oracl817 (из названия дистра) Сейчас я так понимаю, что надо пропатчить его до той версии на которой до этого болталась БД.
Отсюда вопрос, как посмотреть версию оракла. На машине где он стоял ява валяется.
И если можно, как бы найти хаутушку по переносу дампа? по каким ключевым словам можно найти сие действие на форуме, чтобы я не задавал очевидно тупые вопросы...
06.11.2013 13:12
OlegON
 
При таких знаниях предлагаю все же найти ту версию, которая была раньше. Если погуглить по форуму, то можно ее найти, это 8.1.6.3.0. Я просто не знаю, как работает столь древняя версия Супермага на чем-то еще. Если есть желание пройти по тернистому пути - пожалуйста, но я бы тогда переходил на 9.2.0.7. Задача, которая сейчас стоит - не перенос базы, а восстановление ее из дампа. Можно найти переход с 8 на 9 Оракл в FAQ. И задавать сюда более конкретные вопросы.
06.11.2013 13:51
Tagir
 
Стоял 8.1.6, на новом железе стоит 8.1.7, даунгрейд ораклу сделать нужно?
06.11.2013 14:22
OlegON
 
Можно заливать и в 8.1.7, вопрос в том, как к этому отнесется Супермаг.
06.11.2013 14:41
Tagir
 
Извиняюсь кончно, но я не могу нарыть в нете этот патч. перерыл уже все торенты и гугл. Он радикально отличается от 1.7 ?
06.11.2013 14:51
OlegON
 
Какой ответ ты ждешь? :) Я уже все написал выше.
06.11.2013 15:49
Tagir
 
вообще, очень надеялся, что у кого нибудь может в закромах завалялась антикварная 8.6.1 ?)
06.11.2013 16:08
Dim
 
8.6.1 или 8.1.6 ты уж определись
06.11.2013 16:17
whitewizard
 
Цитата:
Tagir вообще, очень надеялся, что у кого нибудь может в закромах завалялась антикварная 8.6.1 ?)
Так он на ФТП С+ есть.
06.11.2013 16:24
leonid
 
Цитата:
Tagir по каким ключевым словам можно найти сие действие на форуме
по словам exp imp
есть старые темы от 2007-го года, там все разжевано

вообще, ваш дамп можно импортировать в оракл любой версии старше вашей
06.11.2013 17:27
OlegON
 
Цитата:
leonid вообще, ваш дамп можно импортировать в оракл любой версии старше вашей
можно-то можно, будет ли Супермаг работать, вот в чем вопрос... С 10кой точно не будет, там баги в пакетах.
07.11.2013 14:52
Tagir
 
Да, извините, 8.1.6, нашел я версию оракла эту. Что то типо сборки от olegon, уже с теми двумя патчами, ставлю на абсолютно чистую систему, и вот что я вижу - ORA 27102 ошибка, из гугла я понял, что оракл думает, что ему отдают слишком много памяти, как это поправить?
07.11.2013 15:25
leonid
 
Цитата:
Tagir ORA 27102 ошибка, из гугла я понял, что оракл думает, что ему отдают слишком много памяти, как это поправить?
при вопросе следует писать полностью:
- версия операционки
- версия оракла
- версия см
- конфиг железа
- последовательность действие
- содержание конфигурационных файлов
...
короче, чем больше инфы, тем вероятнее получите нужный ответ
07.11.2013 15:25
OlegON
 
я знаком с той сборкой ;) она не уже с двумя патчами, а с ответами на вопросы и патчем для пентиума. ты запусти SQL Plus, например, он тебе версию напишет, какая установлена.
а вот все на свете вопросы в эту тему писать не надо - заводи отдельные темы под отдельные вопросы. Если будет продолжение про память, то тему закрою.
07.11.2013 15:31
Tagir
 
-2k3 sp2
-oracle 8.1.6
-1.19 (Если не ошибаюсь)
-Что конкретно ты имеешь ввиду под конфигом железа?
-Через гуевый интерфейс шла установка, создал базы я так понимаю, дал имя, в установке "Configuration tools" установил net8 configuration assistant, на установки Oracle DataBase Configuration assistant возникла загвоздка, при установке "Creating database File" вылезла как раз ошибка "ORA27102: out of memory"
- Опять же каких конфиг файлов? Оракла? Я все ставил через ГУИ, если нужны какие то его файлы, подскажите где они лежат, чтобы показать.
07.11.2013 15:48
leonid
 
Tagir
лучше попробовать на оракле 9.2.0.1
07.11.2013 15:59
Tagir
 
Мне нужен Oracle 8.1.6, а не 9.2.0.1
07.11.2013 16:31
leonid
 
Цитата:
Tagir Мне нужен Oracle 8.1.6, а не 9.2.0.1
мне вот это собственно и не понятно, почему?

9.2.0.1 на вин2к ставится в лет, работает хорошо,
а для 8.1.6 видимо какие-то спец шаманства нужны.

а супермагу собственно (думаю) без разницы - 8 будет или 9.

(и еще я думаю, что на этом форуме никто не будет разжевывать, как поставить 8.1.6, создать базу и сделать импорт, хотя может и заблуждаюсь)
07.11.2013 17:03
baggio
 
Цитата:
leonid а супермагу собственно (думаю) без разницы - 8 будет или 9.
Это очень большое заблуждение...
07.11.2013 17:28
OlegON
 
разжевано уже и не один раз... на 9.2.0.1 Супермаг не работает, 9.2.0.7 - минимум. и baggio прав, разница есть. версии Супермага на некоторых версиях Oracle не работают.
08.11.2013 09:18
Tagir
 
что делать то подскажите по вопросу "Через гуевый интерфейс шла установка, создал базы я так понимаю, дал имя, в установке "Configuration tools" установил net8 configuration assistant, на установки Oracle DataBase Configuration assistant возникла загвоздка, при установке "Creating database File" вылезла как раз ошибка "ORA27102: out of memory" "
08.11.2013 09:31
OlegON
 
Тебя уже просили объяснить, какие параметры задал, сколько памяти у тебя всего, кроме того, я просил на разные ошибки заводить разные темы. Эту закрываю, как и обещал. К дампу это не имеет отношения.
Опции темы


Часовой пояс GMT +3, время: 16:34.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.