[ОТВЕТИТЬ]
Опции темы
11.11.2013 08:10  
porcha
Доброго всем времени суток.

Начну с начала. Все работало,было замечательно. Зависла выше указанная служба, сервер перезагрузили и все вновь заработало. спустя 20-26 часов все повторилось. перезапуск сервера, службы не помогло.
Начал копать, служба не стартует+HASP не видится в Set.
Hasp перетыкал,драйвера переставлял. не помогло.
На форуме видел что глюк со службой может быть из-за JAVA,но она не обновлялась, вообще на сервере ни чего не менялось. переставил на всякий случай JAVA. Изменений нет.
ОС - Win Serv 2003 SP1
Версия системы 5.02.50
версия программы 5.02.47
На кассах пишется Автономный режим.

Если нужна доп информация,пишите, обязательно предоставлю(если расскажете где ее взять).
Заранее всем большое СПАСИБО!
 
11.11.2013 10:11  
Stepan_Shock
Какая служба? пришлите список ваших служб
 
11.11.2013 10:43  
porcha
Вот эти службы от СЕТа есть
Ses-platform (запускается)
ses- tcp сервер Pinpad-Inpad (отключена)
Ses- Интерфейс к СТО (запускается)
Ses- Мониторинг файловой системы (запускается)
Ses - печать на термопринтеры (отключена)
Ses- Сервер банковской авторизации (отключена)
Ses- Сервер торгового оборудования (не запускается, а она ой как нужна)
Ses- Служба файлового обмена с ККМ (запускается)

Я так понял что эта служба Ses- Сервер торгового оборудования отвечает также за определение HASP ключа?
 
11.11.2013 10:59  
Stepan_Shock
А в журнале приложение сервера что пишет?
(часто бывает, что залипают COM объекты кристалла)
 
11.11.2013 11:12  
porcha
Ни чего там не пишет. При запуске службы появляется 1053 ошибка. Служба не ответила на запрос своевременно.
В системном журнале пишется ошибка одна. Сбой при вызове ScRegSetValueExw для Start из-за ошибки. Отказано в доступе.
 
11.11.2013 12:52  
Капустин Евгений
DCOM -добавляли пользователей в безопасности? DCOMCONFIG
Под кем запускается служба?
 
11.11.2013 13:09  
porcha
Новых пользователей не добавлял. все службы запускаются от одного и того же пользователя - crystal.
Сейчас снес антивирь. системная ошибка "Сбой при вызове ScRegSetValueExw для Start из-за ошибки. Отказано в доступе." ушла.
перезапустил сервер, теперь не запускается 2 службы. Ses- Интерфейс к СТО и Ses- Сервер торгового оборудования
 
11.11.2013 13:12  
Капустин Евгений
Воспользуйтесь утилитой (в папке Utils) COMRegister -зарегистрируйте Com объекты
Либо создайте bat файл
sesCOMRegister ..\..\COM\crsHASP.tlb
sesCOMRegister ..\..\COM\crsSESIntf.tlb
sesCOMRegister ..\..\COM\crsExchangeClasses.tlb
sesCOMRegister ..\..\COM\KassServer.tlb
 
11.11.2013 13:27  
porcha
Выполнил COMRegister, Ses- Интерфейс к СТО запустилась, Ses- Сервер торгового оборудования вываливается все с той же ошибкой.
 
11.11.2013 14:18  
Капустин Евгений
переинсталируйте службу (/install,/uninstall)

доступен ли HASP? выполните в браузере http:\\localhost:1947
 
 


Опции темы



Часовой пояс GMT +3, время: 03:04.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.