[ТЕМА ЗАКРЫТА]
08.04.2014 13:54
brontock
 
Не заливаются весы SM 300.При мониторинге программа(SIS 2002) весы видит.Компьютер IP пингует,но при попытке залить весы заведомо рабочей базой выходит сообщение "ошибка при попытке соединения".Весы SM 100 и SM 500 эаливаются без проблем.

PS.Весы взяли недавно,б/у.
08.04.2014 13:58
OlegON
 
полный сброс делали? да и частичный сначала можно попробовать.
08.04.2014 15:28
baggio
 
Проверьте что айпи адрес не совпадает с другим устройством...
09.04.2014 13:00
brontock
 
Цитата:
OlegON полный сброс делали? да и частичный сначала можно попробовать.
Частичный сброс делал,-увы не помогло...Полный пока не решаюсь(Ни разу не делал - прочитал как делать,немного страшновато...)
09.04.2014 13:12
brontock
 
Цитата:
baggio Проверьте что айпи адрес не совпадает с другим устройством...
У весов свой (уникальный) IP адрес.Другого оборудования с таким IP в сети нет.Весы отлично пингуются с компьютера (пуск-выплнить-cmd-ping XXX.XXX.XXX.XXX)
09.04.2014 13:21
brontock
 
PS - только что узнал - весы пролежали на складе 3 года.Да,ещё - когда брали весы ни одного PLU в памяти весов не было.Тест печати работает.Есть подозрения что: 1-слетели настройки в связи с разрядом батарейки. 2-проблема с ПЗУ.Есть ли возможность проверить ПЗУ?
09.04.2014 13:21
Mtirt
 
А точно это весы пингуются а не что-нибудь другое?
09.04.2014 13:25
Krokogen
 
Это очень похоже на ситуацию с глючной digiTCPdrv.dll, которая из-за криво сделанной проверки доступности выдавала подобную ошибку на некоторых весах. Но ее в SIS 2002 вроде нету. Может там подобный алгоритм?
09.04.2014 13:28
brontock
 
Цитата:
Mtirt А точно это весы пингуются а не что-нибудь другое?
Точно.Больше в сети ничего нет,- сеть создавал и контролирую сам.
09.04.2014 13:32
brontock
 
Цитата:
Krokogen Это очень похоже на ситуацию с глючной digiTCPdrv.dll, которая из-за криво сделанной проверки доступности выдавала подобную ошибку на некоторых весах. Но ее в SIS 2002 вроде нету. Может там подобный алгоритм?
Можно подробнее?
09.04.2014 13:40
Krokogen
 
Цитата:
brontock Можно подробнее?
Да это скорее вопрос к знающим этот софт людям, нежели ответ.
В указанной библиотеке перед передачей данных фактически пинг проходил, но отрабатывал иногда некорректно. Почему - не знаю. Но мы мучились с этим долго, сперва правили эту библиотеку на низком уровне, а потом просто от нее избавились в пользу своего кода.
Судя по сообщениям на этом форуме у библиотеки появились новые версии, так что может быть поправлен косяк. Как работает sis - не знаю... Версия этого софта последняя? На офсайте выложена версия 4 1.123
09.04.2014 16:02
baggio
 
1. точный айпи адрес весов в студию.
1.1 маску подсети тоже...
2. пинг до весов в студию (скопировать результат из командной строки)
3. Tracert айпивесов - результат в студию... т.е. сюда
4. Лампочка (светодиод) маленький рядом с сетевым разъемом на весах светиться?

Как вариант отгнили контакты от сетевки до основной платы...
12.04.2014 06:02
brontock
 
Цитата:
baggio 1. точный айпи адрес весов в студию.
1.1 маску подсети тоже...
2. пинг до весов в студию (скопировать результат из командной строки)
3. Tracert айпивесов - результат в студию... т.е. сюда
4. Лампочка (светодиод) маленький рядом с сетевым разъемом на весах светиться?

Как вариант отгнили контакты от сетевки до основной платы...
Доброго времени суток.Прошу прощения за затянувшийся ответ - только сегодня добрался до весов (посменный график)
Итак по существу:
1. IP - 192.168.5.163 (номер весов соответственно в настройках 163)
2. Маска 255.255.0.0
3. Ping весов прилагается
4. Просьба поподробнее о "Tracert айпивесов" - что это и как осуществить.
5. Светодиод (зелёный) рядом с сетевым разъёмом светится.
Добавлю:При мониторинге весов (в SIS 2002) упомянутые весы видны (отмечены зелёным маркером)
Вложения
Тип файла: txt Ping.txt (666 байт, 136 просмотров)
12.04.2014 06:47
brontock
 
Только отправив сообщение заметил ошибку - маска подсети 255.255.255.0 !!!
14.04.2014 07:18
brontock
 
Всем привет.Всё!Тему можно закрывать,- вопрос решён,весы в работе.
Может кому пригодится:Заново ввёл IP адрес и маску подсети (в весах разумеется),сделал частичный сброс.Маску и айпишник НЕ МЕНЯЛ,а именно ВВЁЛ ЗАНОВО.После чего загрузка сразу пошла.Всем спасибо за участие.
Опции темы


Часовой пояс GMT +3, время: 01:46.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.