[ОТВЕТИТЬ]
Опции темы
27.02.2007 16:36  
OlegON
Озадачили тут вопросом, что нужно делать при таком переходе. Прецеденты были?
Единственственное, что пришло в голову:
"во-первых https://olegon.ru/index.php?name=For...iewtopic&t=365
т.е. промежуточные версии (как помню 1.021.1 и 1.023.5) и удаление производства, как минимум. Потом, в одной из версий был скрипт на удаление строк спецификации несуществующих документов...
До кучи прочитать https://olegon.ru/index.php?name=Forums&file=viewtopic&t=1437"
Что еще вспомните? Я вообще немножко прибалдел от такой перспективы. Особенно мучаюсь, какая еще промежуточная версия была? Есть идеи обходных вариантов?
 
27.02.2007 16:58  
wood30
Поднимал на одном магазине с версии 1.021 SP7.
Производство там не велось.
Прогонял поэтапно 1.022.2, 1.023.3, 1.024, далее DotNet и все что нужно, 1.024.4, 1.024.5, 1.024.6.

3 месяца - работают нормально.
 
27.02.2007 17:00  
bob
У меня сохранилась вся переписка с С+ (Морозов, Полюдовкин, Евглевский) при переходе с 1.022,1 до версии 1.024. Если надо перешлю всю переписку. Там есть несколько довольно каверзных ситуаций. Куда пересылать?
 
27.02.2007 17:02  
OlegON
Спасибо, а сюда сами ситуации цитатами нельзя? Много?
 
27.02.2007 17:06  
bob
Добрый день



В выходные дни мы пытались обновить версию СМ2000 с версии 1,022,1 с 1-ым сервис-паком до версии 1,022,2. Перед обновлением мы очистили аналитику и запустили скрипт,который прилагался. Таких документов не было (платежные документы мы вообще не ведем). Затем мы удалили старую версию СМ2000 и поставили 1,022,2. Затем запустили генерацию БД, которая закончилась ошибкой. (файл ошибки прилагается). Может необходимо выполнить остальные сервис-паки версии 1,022,1. Если это так, то где их скачать.

Здравствуйте,

Поговорил с разработчиками, выяснилось, что поднимать версию до 1.022.2

нужно обязательно с установленным сервис паком.

Сервис паки выложили на Ftp, если у вас нет – забирайте.



С Уважением, Морозов Олег

инженер отдела сопровождения
 
27.02.2007 17:07  
bob
Здравствуйте,

Технология следующая.

1. Восстанавливаете из бэкапа вашу базу,

2. удаляете старый супермаг

3. Ставите новый супермаг версии 1.022.2

4. Устанавливаете на нее сервис пак 1.022.2 sp1

5. Запускаете прилагаемый скрипт по исправлению.

6. Запускаете генератор для подъема версии базы до 1.022.2

7. Запускаете прилагаемые к сервис паку скрипты для подъема базы до 1.022.2 sp1



Дальше можете поднимать версию до нужной вам



С Уважением, Морозов Олег

инженер отдела сопровождения
 
27.02.2007 17:07  
bob
Добрый день

Все получилось со сменой с 1,022,1 SP1 до 1.022.2 SP1 . Но при запуске скрипта перед переходом с 1,022,2 SP1 до 1,023 при запуске Incorrectdoc.sql выдал ошибку (прилагается в файле) - отсутствует столбец Article.

С уважением,
Бобров Владимир


Здравствуйте,

данный скрипт надо запускать после установки версии 1.023.2. Т.к. в более ранних версиях данного столбца в таблице точно нет.


С уважением,

Андрей Евглевский
начальник Отдела сопровождения и тестирования ПО
 
27.02.2007 17:10  
OlegON
Спасибо, т.е. промежуточных версий уже три...
 
28.02.2007 07:36  
Propil
Хорошая ветка
У нас в городе один магазин с 2003 года работает без обновлений.
Вдруг вздумают, ко мне ведь пойдут...
 
 
Опции темы



Часовой пояс GMT +3, время: 15:33.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.