22.11.2014 11:28
khachik
 
В reports_ext.lua создал фукцию:

function fiscalize_last_receipt(__rep, __print_data)
os.execute("/usr/local/hdm_integrator/print_last_receipt.sh")
end


которая работает на все 100% в версии 49 sp10, никак не могу заставить ее работать в версии 48сп6
ТП ругается на то, что os.execute не будет работать в версии 48sp6. Народ может кто нибудь сможет подсказать как заставить работать данную функцию, ну или изменить что надо?

П.С
io.popen так же не работает в версии 48сп6
В LUA не силен пожалуйста сильно не пинайте:) Заранее спасибо.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.