[ТЕМА ЗАКРЫТА]
Опции темы
06.01.2015 20:54  
denissaha
Запара, уже 7 день бъюсь. В общем ситуация такая - стоят 2 весов DIGI SM-100, на компьютере в локальной сети установлен QLoad, весы прописаны, пингуются, прогружается товар, все нормально. Где то перед Новым Годом перестали прогружаться товары в весы. Что было сделано:

1. Неполный сброс памяти (по документации)
2. Весы переключены в режим работы с этикетками.

Для пробы набираю PLU 1 - как и положено пишет что PLU нет в весах.

Выгружаю базу товаров, выгрузка через CSV, кодировка все нормально, в общем товары в весы попадают. Для пробы набираю некий PLU - все ОК, пишет "сыр такой-то", цена такая-то.

И тут проблема!

Захожу через CQloadSimple.exe, выбираю шаблон этикетки, нажимаю "выгрузить в весы" - пишет "ошибка протокола". Причем хоть через QLoad, хоть через Sis 2002. Если выгружать этикетку через twswtcp.exe, то создает два файла - один errors с ИП весов, второй с кодом "-8".

То есть в весы выгружается все, кроме этикетки. Надписи типа "Спасибо за покупку" и т.д. выгружаются.
Миниатюры
Нажмите на изображение для увеличения
Название: error1.jpg
Просмотров: 589
Размер:	60.1 Кб
ID:	4263   Нажмите на изображение для увеличения
Название: error2.jpg
Просмотров: 433
Размер:	68.8 Кб
ID:	4264   Нажмите на изображение для увеличения
Название: error3.jpg
Просмотров: 443
Размер:	38.0 Кб
ID:	4265  
 
06.01.2015 20:56  
baggio
для новых sm-100 нужен новый Qload и SIS2000 ...
скачайте с сайта С+... у них отличается протокол..
 
06.01.2015 21:06  
denissaha
Так дело то в том и есть, что все началось как-то так... вдруг. То есть, ни весы не обновлялись (прошивка), ничего вообще. Весы не то чтобы прям уж новые, год точно работают. Я пробовал уже и QloadSMT версия 3.0.0.1, и 3.0.0.2. Разные конфигураторы пробовал. Сис2002 версии 4_1.123, вроде скачал самый что ни на есть новый. Може если где есть чего поновее, ткните, плиз, може не там искал. Но облазил уже все. И с местного хранилища вроде уже все скачал, что можно.

Я боюсь, как-бы диагнозом не стал "полный ресет весов". Но, что поражает, сразу на обоих весах. Лад но бы на одних. А так...
 
06.01.2015 22:09  
baggio
а возможно что кто то поправил этикетку?
не одна этикетка не грузится?
 
06.01.2015 22:57  
denissaha
Да, прошу прощения, я не указал это в теме. Я сам поначалу так думал. Взял из архива, перепробовал несколько разных, результат - "ошибка протокола". Я уже смотрел, может где-то на соседнем компе запущен параллельно QLoad и он как-нибудь мешает - нет.
 
07.01.2015 00:02  
baggio
хм... айпи адрес пробовал менять? просто ради эксперимента...
уж очень странная ситуация...
как вариант - полный сброс...
не помогло...
пере прошивка...
может где флэшка побилась... хотя оно четко говорит про протокол...
с другого компа пробовал?
 
07.01.2015 00:49  
denissaha
Пробовал с разных 3 компов, результат одинаковый. Менять ИП на весах не пробовал. Нужно будет попытаться. Просто никак не могу уразуметь ситуацию. В чем именно проблема. То есть вот... ПЛУ выгружаются, значит протокол обмена (по идее TCP) пашет. Весы пингуются. Значит не в сети. Драйвер (тот который twswtcp) без проблем забирает от весов те-же ПЛУ (twswtcp T25,DAT 221). Когда даю ему команду "twswtcp,exe T34,DAT 221" - на выходе получаю нулевой файл SM221T34,DAT и в файле error стоит 0, то есть как-бы обмен прошел без сбоев. А как только пытаюсь обратно запихнуть "хорошую" этикетку - ошибка "-8", что по бумажке значит типа "Ошибка чтения файла". Если предположить что битый файл этикетки, то тогда он должен быть и в архиве уже битый. Да и подсовывал я ему "свеженькие" скаченные стандартные этикетки - результат один и тот-же.

В общем, наверное полный сброс - и там смотреть.
 
07.01.2015 01:49  
baggio
поменять Айпи...
поменять свитч или подключить напрямую...
как вариант "прокладка" барахлит... у меня было такое единожды на весах другого производителя.. не работали нормально на гигабитном хабе... тоже глюк на глюке был...
просто как вариант...
ну а так да полны сброс... прошивка..
но перед лучше перепробовать все варианты...
 
07.01.2015 01:51  
baggio
подожди... только увидел... у тебя обмен со всеми весами заканчивается ошибка протокола? не только с одними?
 
07.01.2015 08:55  
denissaha
Да, со всеми. Что меня и удивляет. Были бы одни, то подозревал бы что дело в весах.
 
 


Опции темы



Часовой пояс GMT +3, время: 17:14.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.