[ОТВЕТИТЬ]
Опции темы
07.03.2015 14:22  
Евгений
Кто-нибудь знает как слить прошивку с весов Digi-SM300? Поделитесь опытом. Может у кого есть прошивка 2.05., откликнитесь если есть.
 
07.03.2015 20:06  
Mtirt
А точно речь о 300 весах? Номер прошивки скорее указывает на 100-ые. И она, если я правильно помню, есть в хранилище.
 
08.03.2015 05:04  
Евгений
Точно SM-300, самые старые у нас весы лет 10-12. Материнка отличается компановкой от последующих версий.
На микросхеме написана прошивка Ver 1.6 , на табло высвечивается Version 2.05 (Накатана поверх заводской).
 
11.03.2015 05:37  
Евгений
Всем спасибо. Необходимость прошивки 2.05 отпала. На весы нормально накатилась прошивка 19.05. Т.к. делал прошивку первый раз на SM-300 без косяков не обошлось. Во первых старая плата и батарейки на ней подсели 2,83 В. Тем более на плате я увеличил память до 2 MB, выжирают остатки со старых батареек и весы после выключения и отсутствия питания на несколько часов, а может и меньше выходят в PRG LOAD. После окончания прошивки не выходили в рабочий режим: экран белый и пиликает 5 коротких сразу после 3 коротких. Вообщем выпаял батарейки, вышел в полный сброс, выставил настройки, SPEK проверил остались такие же как до прошивки. Загрузил 1825 плушек и 20 форматов, полет нормальный до выключения из розетки. Осталось поставить новые батарейки.
 
"Спасибо" Евгений от:
11.03.2015 05:41  
Евгений
Извиняюсь прошивка 19.09, а не 19.05 конечно же.
 
"Спасибо" Евгений от:
03.04.2015 16:38  
badlad
Так и вольтаж таборейки в норме! зачем менять? Меряете на таборейке или на ножках микрух памяти?
 
04.04.2015 21:39  
Евгений
Цитата:
Сообщение от badlad
Так и вольтаж таборейки в норме! зачем менять? Меряете на таборейке или на ножках микрух памяти?
Измеряю напряжение на батарейке. Если весы оставить включенными на несколько дней , то акум-батарейки заряжаются, до 3,02В. Но если отключить на день, напряжение падает до 2,2В. Соответственно все базовые настройки слетают и PRG LOAD. Я думаю все таки за десять лет эксплуатации, емкость акум-батареек упала. На 1Mb памяти еще хватало, но когда установил 1 Mb дополнительно перестало хватать. Пока дополнительно поставил в схему CR123A c резистором 15 Om. Погонял часов 20 во включенном состоянии , выключал на непродолжительное время, работают нормально. Выключил, отставил в сторону, проверю через 3 суток. Если настройки не слетели, проверю на сколько просело напряжение и весы отдам на производство посмотрим как будут вести себя в работе.
 
 
Опции темы



Часовой пояс GMT +3, время: 01:24.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.