[ОТВЕТИТЬ]
Опции темы
14.07.2011 10:18  
ztn3t1
АБС анализ одной формулой.
В инвенторе, конечно, хорошая реализация, но если 500 групп? Это надо по каждой указывать диапазон, плюс,(т.е. минус), результат анализа, через инвентор, смещается, т.к. указано условие, видимо, первый пустой column.
Вводишь формулу, два раза щёлкаешь на нижний правый угол ячейки с формулой, получаешь результат.
15 тысяч строк и 400 групп обрабатывается, в среднем, 3-4 минуты.
Условия по структуре анализа прописываются внутри формулы (в формуле массива), в данном случае, это ABC, но ничего не мешает сделать ABCDEF и т.д.
Вложения
Тип файла: rar abc by formulas.rar (8.7 Кб, 718 просмотров)
 
14.07.2011 15:24  
andrey_f
Сама идея внутригруппового анализа интересна.
Думаю, некоторые пользователи могут найти эту идею полезной в работе, поэтому я усовершенствовал файл таким образом, что он считает границы групп методом касательных, а не фиксированными границами, как ранее.
Скорость работы на большом массиве очень низкая, но надеюсь, не зря колдовал.
Вложения
Тип файла: rar abc by formulas kasatelnie.rar (17.3 Кб, 606 просмотров)
 
14.07.2011 17:05  
ztn3t1
Ясное дело не зря! Отличная задумка и реализация, только в 2003 ёкселе, не пашет, что за эверейджиф?, может пакет анализа надо подключить? или просто функции такой ещё не было в 2003? Проверить не могу, уже с работы уехал.
Фишер Андрей, автоматизировать работу категорийного менеджера в рознице не приходилось? Конкретно, интересует автоматизация "отрисовки" планограмм (быстро прописать что где стоит, т.к. планограммы постоянно меняются и прописать выкладку товара занимает существенное количество времени).
Чудо инженерной мысли под названием "программа-планограмщик", стоит под пол-миллиона вечнодеревянных рублей. За эти деньги впаривают махровый ужас. Зато с тех.поддержкой девочки-менеджера из г.Москвы.
Может это, обмен премудростями тут наведём? А то площадок в интернете, и нет совсем, для работников розничной торговли. У меня уже готов шаблон для отрисовки планограммы (текстовые наименования), могу завтра скинуть, может пригодится кому.
 
16.07.2011 04:39  
andrey_f
Цитата:
Сообщение от ztn3t1
что за эверейджиф?, может пакет анализа надо подключить? или просто функции такой ещё не было в 2003?
Совсем забыл, что функция СРЗНАЧЕСЛИ появилась только в 2007. В принципе, при желании, ее можно заменить комбинацией СУММЕСЛИ и СЧЕТЕСЛИ.
Если же у вас 2007 и выше, то СРЗНАЧЕСЛИ оставляем, и функцию СУММПРОИЗВ можно заменить функциями СУММЕСЛИМН и СЧЕТЕСЛИМН - скорость работы на моем ПК от этих преобразований возросла раз в 10 точно (обновленный файл во вложении).

Цитата:
Сообщение от ztn3t1
Может это, обмен премудростями тут наведём? А то площадок в интернете, и нет совсем, для работников розничной торговли. У меня уже готов шаблон для отрисовки планограммы (текстовые наименования), могу завтра скинуть, может пригодится кому.
Обмен премудростями - всегда хорошо, выкладывайте, конечно.
Вложения
Тип файла: rar abc by formulas kasatelnie2.rar (29.2 Кб, 348 просмотров)
 
07.09.2011 11:25  
dmitry_IL
Цитата:
Сообщение от ztn3t1
У меня уже готов шаблон для отрисовки планограммы (текстовые наименования), могу завтра скинуть, может пригодится кому.
Вот это было бы совсем круто, а то я вручную устал уже отрисовывать, особенно, когда точек много и у всех выкладка разная... Буду крайне признателен!!!
 
15.08.2012 10:05  
VVY
Цитата:
Сообщение от administrator
Цитата:
Сообщение от ztn3t1
что за эверейджиф?, может пакет анализа надо подключить? или просто функции такой ещё не было в 2003?
Совсем забыл, что функция СРЗНАЧЕСЛИ появилась только в 2007. В принципе, при желании, ее можно заменить комбинацией СУММЕСЛИ и СЧЕТЕСЛИ.
Если же у вас 2007 и выше, то СРЗНАЧЕСЛИ оставляем, и функцию СУММПРОИЗВ можно заменить функциями СУММЕСЛИМН и СЧЕТЕСЛИМН - скорость работы на моем ПК от этих преобразований возросла раз в 10 точно (обновленный файл во вложении).

Цитата:
Сообщение от ztn3t1
Может это, обмен премудростями тут наведём? А то площадок в интернете, и нет совсем, для работников розничной торговли. У меня уже готов шаблон для отрисовки планограммы (текстовые наименования), могу завтра скинуть, может пригодится кому.
Обмен премудростями - всегда хорошо, выкладывайте, конечно.
Андрей, привет!
А ошибки нет в файле? Поправил, скажи как получилось. :)
Вложения
Тип файла: rar abc by formulas kasatelnie2.rar (38.5 Кб, 226 просмотров)
 
15.08.2012 10:12  
andrey_f
Цитата:
Сообщение от VVY
А ошибки нет в файле? Поправил, скажи как получилось. :)
В моем файле просто немного другой метод - Валерин. Я на основе его файла сделал, чтобы время сэкономить. Если говорить о классическом методе касательных, то у тебя все верно получилось.
 
15.08.2012 12:40  
VVY
Цитата:
Сообщение от administrator
Цитата:
Сообщение от VVY
А ошибки нет в файле? Поправил, скажи как получилось. :)
В моем файле просто немного другой метод - Валерин. Я на основе его файла сделал, чтобы время сэкономить. Если говорить о классическом методе касательных, то у тебя все верно получилось.
Ну я так и понял. Написал, чтобы не вводить в заблуждение людей... а то пишем в статьях и на форуме одно, а делаем в файлах по-другому :).
 
08.07.2013 15:02  
Aleksandr H.
VVY
А можешь пояснить, что именно мы ищем частью
Код:
ЕСЛИ(B3*СЧЁТЕСЛИ(B:B;">0")>=СУММЕСЛИ(B:B;">0")
формулы ячейки С3
Код:
=ЕСЛИ(B3<=0;"";ЕСЛИ(B3*СЧЁТЕСЛИ(B:B;">0")>=СУММЕСЛИ(B:B;">0");"AB";"BC"))
 
08.07.2013 15:15  
Aleksandr H.
Цитата:
Сообщение от Aleksandr H.
VVY
А можешь пояснить, что именно мы ищем частью
Код:
ЕСЛИ(B3*СЧЁТЕСЛИ(B:B;">0")>=СУММЕСЛИ(B:B;">0")
формулы ячейки С3
Код:
=ЕСЛИ(B3<=0;"";ЕСЛИ(B3*СЧЁТЕСЛИ(B:B;">0")>=СУММЕСЛИ(B:B;">0");"AB";"BC"))
Снимаю вопрос. Ответ нашел в теме АВСD-анализ – как всё-таки правильно его делать
 
 
Опции темы



Часовой пояс GMT +3, время: 05:31.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.